Help please with mounting nas nfs folder.

I am trying to mount a remote folder on NAS in my home directory.

I have had this work before with previous version (42.3) but I have run foul of permissions:-

An error occurred while accessing 'Multimedia on', the system responded: mount: /home/alastair/NFS_multimedia: operation permitted for root only.

I do not recall this happening before. Should I try and mount as root or have I made a mistake with my permissions either on the NAS or on this machine?


When you have a problem using a command line (or other method),
You have to post the command you tried to execute, not just the result.

Most likely you didn’t specify the arguments to allow non-root to mount,



Hi Tsu, I confess I was not using CLI but Yast GUI as I have done in the past. I asked here just in case there was something new or different, knowing that security has been improved on NAS and probably on openSUSE.
I read your note and was about to embark on a detailed account of what I had done when loh and behold when I started my laptop the mount was in place and working.
Of course if I had used cli I would have know immediately. Will use cli next time.
Many thanks,

Forgive me for resurrecting this thread but having solved the problem for a while it has returned and now both my workstation and laptop nfs mounts are failing.

Here is my cli attempt to mount:-

alastair@install:~> sudo mount -t nfs /home/alastair/Nas_Multimedia_NFS
Created symlink /run/systemd/system/ → /usr/lib/systemd/system/rpc-statd.service.

Now it is quite possible there has been a relevant update to NAS and of course daily updates on Tumbleweed but it looks like the first problem is with NAS. A clue where to look first would be appreciated please.