Help please with any media playing, Kaffeine, Openshot Digital TV via Kaffeine etc. It stall's?

This may be a bit difficult to describe so please bear with me on this.
For a while everything was OK then I either did something or down to an update, (not sure) I lost what I describe as reliability in playing any media files or viewing such things on screen.

Digital TV via Kaffeine will no longer play TV, some times I get a brief view of the image and some sound then it stops, change channel and nothing.
If I play a mp4 or flv file with Kaffeine it will run OK provided I do not pause it or try to move it along.

VLC plays the files fine.
Openshot is another program suffering, when trying to preview any video’s it will show OK providing I do not pause and move to a different time, so it gets difficult when editing. If I leave it for long enough it seems to catch up and start playing again, but this could be after 3 or 4 minutes.

Not sure what I need to do to determine where the error is so if anyone can assist I would be grateful.

I am considering moving alll my data to another PC just in case!


Post in Code-Tags:

zypper lr -d

Which Desktop?
Gnome, Plasma, XFCE …

KDE standard desktop install, I believe with Plasma?

Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type     | URI                                                                                    | Service
 1 | Downloads                           | Downloads                               | Yes     | ( p) Yes  | No      |   99     | plaindir | dir:///home/adrian/Downloads                                                           |        
 2 |            | nVidia Graphics Drivers                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |                                         |        
 3 |       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | yast2    |                      |        
 4 |     | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |                                 |        
 5 |           | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | yast2    |                          |        
 6 |         | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |                                      |        
 7 | home:mnhauke:sdr-devel              | home:mnhauke:sdr-devel                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | |        
 8 | | multimedia:libs                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |         |        
 9 | | multimedia:apps                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |         |        
10 | | openSUSE:Leap:42.3:Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |       |        
11 | openSUSE-Leap-42.3-0                | openSUSE-Leap-42.3-0                    | No      | ----      | ----    |   99     | yast2    | cd:///?devices=/dev/disk/by-id/ata-TEAC_DVD-ROM_DV-28SW_09111912180133                 |        
12 |             | Libdvdcss Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |                                     |        
13 |               | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |                                       |        
14 | repo-debug                          | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | yast2    |                    |        
15 | repo-debug-non-oss                  | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | yast2    |                |        
16 | repo-debug-update                   | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | rpm-md   |                               |        
17 | repo-debug-update-non-oss           | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | rpm-md   |                           |        
18 | repo-source                         | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | yast2    |                   |        
19 | repo-source-non-oss                 | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | yast2    |               |        
20 | skype-stable                        | skype (stable)                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   |                                                     |        

I think I do not need the repository for NVidia as I have Intel graphics, but seems to have been there for some time.
Please let me know if I responded with what you need above?


Repo multimedia:libs and Packman at the same Time is your Problem…

So delete multimedia:libs:

zypper rr

and do an :

zypper dup --from

OK thank you I have just given that a go, here is my output:-

adrian@linux-23pz:~> zypper rr
Root privileges are required for modifying system repositories.
adrian@linux-23pz:~> su
linux-23pz:/home/adrian # zypper rr
Removing repository 'multimedia:libs' .......................................................................................................................................[done]
Repository 'multimedia:libs' has been removed.
linux-23pz:/home/adrian # zypper dup --from
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following item is locked and will not be changed by any action:

Nothing to do.
linux-23pz:/home/adrian # 

So looks like no changes done.I have done a software update to check, I will reboot and test again to see if problem is still there.


One really does not have more than a few minutes to edit the post?

There was no difference, so I just tried something, I ran kaffeine up from console
On the computer that has the errors I get the following:-

adrian@linux-23pz:~> kaffeine /home/adrian/Cobel.mpeg
kaffeine(2855) DvbManager::loadDeviceManager: using built-in dvb device manager
libva info: VA-API version 0.39.4
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vo_vdpau: Failed to check vdpau get/put bits native capability : VDP_STATUS_NO_IMPLEMENTATION
libva info: VA-API version 0.39.4
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
adrian@linux-23pz:~> X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 12 (X_ConfigureWindow)
  Resource id:  0x0
libva info: VA-API version 0.39.4
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
QProcess: Destroyed while process is still running.


On a computer that does not have the problem I get:-

adrian@linux-sn1k:~> kaffeine /home/adrian/Cobel.mpeg
adrian@linux-sn1k:~> xv_set_property: property=0, value=0
xv_set_property: property=0, value=0
xv_set_property: property=0, value=0
xv_set_property: property=0, value=0
xv_set_property: property=0, value=0
xv_set_property: property=0, value=0
xv_set_property: property=0, value=0
xv_set_property: property=0, value=0


the xv_set_property etc seem to be when I skip along the track.

Not sure if this points to something or not but there are definate differences.

So I have had a look on both machines at Libvdau and found that I had extra files installed such as
On the machine with the issue, removing these does not throw any errors so I have just removed them???
I have looked for anything with i965 and not found anything on either machine so think I was clutching at straws as it is no different.


vdpau is nvidia tech and does not work on intel machines
you should remove libvdpau* reboot and run kaffeine in a terminal to check for new error messages if any

zypper rm -u libvdpau*

don’t forget the star in libvdpau* as there are several vdpau libraries some might not be installed but none should on intel only devices

Are you ABSOLUTELY sure about this???

linux-23pz:/home/adrian # zypper rm -u libvdpau*
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 42 applications are going to be REMOVED:
  Activities "Activity Bar" "Analog Clock" "Application Launcher" "Application Menu" "Application Menu Bar" "Battery and Brightness" Breeze Calendar Clipboard "CPU Load Monitor"
  "Declarative Toolbox" "Default Panel" Desktop "Desktop Containment" "Device Notifier" digiKam "Digital Clock" Dolphin "Empty Panel" "Global Menu" Gwenview "Hard Disk I/O
  Monitor" "Hard Disk Space Usage" Image "Input Method Panel" K3b "KDE Plasma Desktop" Lock/Logout "Media Player" "Memory Status" "Network Monitor" Notifications Pager "Panel
  Toolbox" "Plain Color" Showfoto Slideshow "System Tray" "Task Manager" Trashcan "Window list"

The following 165 packages are going to be REMOVED:
  accountsservice accountsservice-lang baloo5 baloo5-file baloo5-imports baloo5-kioslaves baloo5-lang baloo5-tools baloo5-widgets baloo5-widgets-lang breeze breeze5-cursors
  breeze5-decoration breeze5-icons breeze5-wallpapers catdoc digikam digikam-lang dolphin dolphin-part dolphin-part-lang exiv2 exiv2-lang ffmpeg ffmpegthumbs
  frameworkintegration-plugin frei0r-plugins gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-lang gwenview5 gwenview5-lang hack-fonts k3b k3b-lang kactivities5-imports
  kaffeine kcm_sddm kcm_sddm-lang kdebase4-runtime kdebase4-workspace-libs kde-cli-tools5 kde-cli-tools5-lang kdegraphics-thumbnailers kdelibs4 kdelibs4-branding-openSUSE
  kdelibs4-core kdelibs4support kdelibs4support-lang kde-odf-thumbnail kde-oxygen-fonts kde-user-manager kde-user-manager-lang kfilemetadata5 kfilemetadata5-lang kgamma5
  kgamma5-lang khotkeys5 khotkeys5-lang kinfocenter5 kinfocenter5-lang kio_mtp kmenuedit5 kmenuedit5-lang kpeople5 kpeople5-lang kscreenlocker kscreenlocker-lang ksysguard5
  ksysguard5-lang kwalletmanager5 kwalletmanager5-lang kwin5 kwin5-lang libakonadi4 libappstream4 libAppStreamQt2 libavcodec57 libavdevice57 libavfilter6 libavformat57
  libavresample3 libavutil55 libcdaudio1 libchromaprint1 libdigikamcore5 libdirectfb-1_7-1 libdolphinvcs5 libgstvdp-0_10-23 libjsoncpp1 libkde4 libkdecorations2-5
  libkdecorations2private5 libkdepimlibs4 libKF5ActivitiesStats1 libKF5Baloo5 libKF5BalooEngine5 libKF5JsEmbed5 libKF5JsEmbed5-lang libKF5KDcraw5 libkms1 libKScreenLocker5
  libksuseinstall1 libksysguard5 libksysguard5-helper libksysguard5-lang liblmdb-0_9_14 liblrdf2 libmjpegutils-2_0-0 libmlt6-modules libmms0 libmovit6 libofa0 libopencv-qt56_3
  libopenshot13 libpostproc54 libqalculate6 libQt5Concurrent5 libQt5Multimedia5 libqt5-qtgraphicaleffects libQtAV1 libQtAVWidgets1 libQtWebKit4 libquicktime0 libraw15
  libSDL2-2_0-0 libSoundTouch0 libsvn_auth_kwallet-1-0 libswresample2 libswscale4 libtimidity-0_1-0 libvdpau1 libvdpau_va_gl1 libxine2 libxine2-codecs libxine2-pulse mjpegtools
  openshot oxygen5-sounds patterns-openSUSE-kde patterns-openSUSE-kde_imaging patterns-openSUSE-kde_plasma plasma5-defaults-openSUSE plasma5-desktop plasma5-desktop-lang
  plasma5-integration-plugin plasma5-integration-plugin-lang plasma5-session plasma5-theme-openSUSE plasma5-workspace plasma5-workspace-branding-openSUSE plasma5-workspace-lang
  plasma5-workspace-libs polkit-kde-agent-5 polkit-kde-agent-5-lang powerdevil5 powerdevil5-lang python3-openshot python-notify sddm sddm-branding-upstream showfoto sni-qt
  systemsettings5 systemsettings5-lang wxcam

The following 3 patterns are going to be REMOVED:
  kde kde_imaging kde_plasma

165 packages to remove.
After the operation, 670.2 MiB will be freed.
Continue? [y/n/...? shows all options] (y): n
linux-23pz:/home/adrian # 

So I went into software manager, searched for libvdpau and removed the two packages I had listed as installed without the threat of the rest going.


In fact kaffeine then reported it could not play the mpeg format and asked if I wished to download additional drivers or something,
it reinstalled

  • libavcodec57, libavformat57, libavutil55, libpostproc54, libswresample2, libvdpau1, libxine2-codecs

so the libvdpau1 is needed for this as it must provide something else.


Just thought I would update this thread and close it!

I have not succeeded yet, but things got worse for me with the computer no longer having a KDE Plasma desktop but Ice??

I had exported my emails from Kmail via pim exporter, but found out for some reason I have lost all 2017 emails and part of 2016, that would have been the point when I upgraded from Suse 13.2 to Leap 42.2, I have a back up from mid October of my home directory, but I believe it did not capture the hidden files, so no back of of emails there.

So I am in the middle of re-installing a few computers both with 42.3 both standard desktops and reinstalling my extra packages on them. I do save my files to an external HD generally every week and did manage to get them off before the PC went completely daft.

Not sure what it was, I have clamav installed and that is updated daily so hope not a virus, I doubt it, I think it lost some vital bit of software somewhere.

So my next thread will be asking about proper back-ups and how to mirror one PC to another weekly.

Thanks for your help in trying to get my issue resolved.


OK further to this issue, I have just done a new install Leap 42.3 and installed as per the guide to install multimedia codecs etc on this forum, from all the zypper parts to also switching to Packman for the system files, but there is still the same issue when running kaffeine, well assuming it is the same issue.

So I have gone back into software manager and looked for any files with vdpau and found, So I looked at removing it and can see why I got major issues before, unfortunately as it was late in to the night yesterday I did not take to much notice. But I can not see how I can remove the file as it breaks a lot. It de-installs a lot of packages and changes a file repository from Packman to Suse.

#### YaST2 conflicts list - generated 2017-12-04 17:51:58 ####

libxine2-1.2.8-127.5.x86_64 requires, but this requirement cannot be provided

     ] Following actions will be done:
downgrade of libxine2-1.2.8-127.5.x86_64 to libxine2-1.2.8-1.1.x86_64
install libxine2-1.2.8-1.1.x86_64 (with vendor change)  -->  openSUSE
deinstallation of libavutil55-3.3.4-9.4.x86_64
deinstallation of amarok-2.8.0-19.1.x86_64
deinstallation of libopencv3_1-3.1.0-3.25.x86_64
deinstallation of libopencv-qt56_3-3.1.0-3.26.x86_64
deinstallation of libQtAV1-1.11.0-1.5.x86_64
deinstallation of kfilemetadata5-5.32.0-1.5.x86_64
deinstallation of ffmpegthumbs-17.04.2-1.1.x86_64
deinstallation of libavfilter6-3.3.4-9.4.x86_64
deinstallation of libswscale4-3.3.4-9.4.x86_64
deinstallation of k3b-17.08.3-10.4.x86_64
deinstallation of libavdevice57-3.3.4-9.4.x86_64
deinstallation of libavcodec57-3.3.4-9.4.x86_64
deinstallation of gstreamer-plugins-libav-1.8.3-3.6.x86_64
deinstallation of libswresample2-3.3.4-9.4.x86_64
deinstallation of libxine2-codecs-1.2.8-127.5.x86_64
deinstallation of libpostproc54-3.3.4-9.4.x86_64
deinstallation of ffmpeg-3.3.4-9.4.x86_64
deinstallation of libavformat57-3.3.4-9.4.x86_64
deinstallation of libavresample3-3.3.4-9.4.x86_64
deinstallation of libquicktime0-1.2.4cvs20150223-12.3.x86_64
deinstallation of vlc-noX-2.2.6-8.3.x86_64
deinstallation of libdigikamcore5-5.5.0-2.11.x86_64
deinstallation of libQtAVWidgets1-1.11.0-1.5.x86_64
deinstallation of libKF5Baloo5-5.32.0-1.3.x86_64
deinstallation of gwenview5-17.04.2-1.5.x86_64
deinstallation of dolphin-part-17.04.2-4.1.x86_64
deinstallation of digikam-5.5.0-2.11.x86_64
deinstallation of baloo5-widgets-17.04.2-1.1.x86_64
deinstallation of baloo5-tools-5.32.0-1.3.x86_64
deinstallation of baloo5-file-5.32.0-1.3.x86_64
deinstallation of kfilemetadata5-lang-5.32.0-1.5.noarch
deinstallation of k3b-lang-17.08.3-10.4.noarch
deinstallation of amarok-lang-2.8.0-19.1.noarch
deinstallation of mjpegtools-2.0.0-19.6.x86_64
deinstallation of libmjpegutils-2_0-0-2.0.0-19.6.x86_64
deinstallation of vlc-codecs-2.2.6-8.3.x86_64
deinstallation of vlc-codec-gstreamer-2.2.6-8.3.x86_64
deinstallation of vlc-qt-2.2.6-8.3.x86_64
deinstallation of vlc-2.2.6-8.3.x86_64
deinstallation of showfoto-5.5.0-2.11.x86_64
deinstallation of plasma5-workspace-5.8.7-6.1.x86_64
deinstallation of plasma5-desktop-
deinstallation of dolphin-17.04.2-4.1.x86_64
deinstallation of baloo5-kioslaves-5.32.0-1.3.x86_64
deinstallation of baloo5-imports-5.32.0-1.3.x86_64
deinstallation of gwenview5-lang-17.04.2-1.5.noarch
deinstallation of dolphin-part-lang-17.04.2-4.1.noarch
deinstallation of digikam-lang-5.5.0-2.11.noarch
deinstallation of baloo5-widgets-lang-17.04.2-1.1.noarch
deinstallation of gstreamer-plugins-bad-1.8.3-8.9.x86_64
deinstallation of patterns-openSUSE-kde_plasma-20170518-6.1.x86_64
deinstallation of sddm-theme-openSUSE-42.1.1-19.1.noarch
deinstallation of plasma5-workspace-lang-5.8.7-6.1.noarch
deinstallation of plasma5-workspace-branding-openSUSE-42.1.1-19.1.noarch
deinstallation of plasma5-session-5.8.7-2.1.noarch
deinstallation of plasma5-desktop-lang-
deinstallation of kinfocenter5-5.8.7-1.1.x86_64
deinstallation of gstreamer-plugins-farstream-0.2.8-3.4.x86_64
deinstallation of gstreamer-plugins-bad-lang-1.8.3-8.9.noarch
deinstallation of sddm-branding-openSUSE-0.14.0-5.1.x86_64
deinstallation of patterns-openSUSE-kde_imaging-20170518-6.1.x86_64
deinstallation of patterns-openSUSE-kde-20170518-6.1.x86_64
deinstallation of kinfocenter5-lang-5.8.7-1.1.noarch
deinstallation of libfarstream-0_2-5-0.2.8-3.4.x86_64
deinstallation of libpurple-2.12.0-9.1.x86_64
deinstallation of telepathy-haze-0.8.0-7.2.x86_64
deinstallation of libpurple-tcl-2.12.0-9.1.x86_64
deinstallation of libpurple-lang-2.12.0-9.1.noarch
deinstallation of libpurple-branding-openSUSE-42.2-4.2.noarch
     ] keep libvdpau1-1.1.1-11.3.x86_64

     ] break libxine2-1.2.8-127.5.x86_64 by ignoring some of its dependencies

#### YaST2 conflicts list END ###

So I am really not sure what I should do next, so still throwing myself on your assistance while I continue to get back to a working pc.

I am wondering what has changed to cause this, it would have been over a week agao I first noticed the kaffeine issue?


hm the problem was the -u switch it removes unneeded dependencies as some of those dependencies wore needed you should have chosen to keep them
try removing only vdpau packages in yast or with zypper search for and remove only vdpau

zypper se -si vdpau

people do make mistakes (it wasn’t a mistake it was a suggestion) you do have a head on your shoulders you really shouldn’t have removed all those packages I said remove vdpau packages
and yes I’m sure vdpau is nvidia and does not work on intel, intel uses vaapi
on intel machines libvdpau-va-gl is used to redirect vdpau to vaapi (maybe all you needed was to check you have this package )

Yes I have vdpau-va-gl1 and installed, I can remove vdpau-va-gl1 without resolving the problem but could not remove the without damage to the system that is all from the software manager Yast.

And yes the issue was mine, I was tired and missed the warnings about removing part of the system in Yast.

I can use dragon player to watch the mpeg, but I am now looking to see if I can find a simple alternative to kaffeine for the digital TV. I note there iis an update to Openshot but not through suse.

I will get there eventually.