Help Please Restoring Multiboot Installation after upgrade to 13.2

On ThinkPad T42 (32 bit) Laptop I had three operating systems, openSUSE 13.1, eComStation 2.2 and Windoze XP. The booting was quite complex but had Grub running the initial process and offering the three options. Selecting openSUSE 13.1 or Windoze XP worked directly but selecting eCS chained me to IBM Boot Manager and then to eCS. The reason for this setup is lost to me but it worked.

Because all my other machines are now running 13.2 I thought I would do an upgrade to 13.2. I followed the SDB:System Upgrade but the upgrade failed with error messages and no boot back to desktop.
I then tried an Upgrade from installation DVD but this also failed with error messages, not understood and now lost.

Since my /home directory was on separate partition I then did a new installation of 13.2 on the old 13.1 partition. The installation went OK until the end when I was asked questions about where to put the boot loader. Whatever I did it was wrong!!! Please could somebody help me sort this out.

I am planning to use 13.2 Live DVD unless I am told otherwise. It runs and I can access this site but is painfully slow so I am starting this thread on another machine. Only one starter question. On the Live installation I am still offered apper updates. Should I accept these and how does this work if whole OS is running from DVD?

Will post partition setup in next message.
Budgie2

Further to the above here is my partitioning as now:-

su - -clinux@linux:~> su - -c '/usr/sbin/fdisk -l'

Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x462d462c

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1           15120  78170399  78155280 37.3G  7 HPFS/NTFS/exFAT
/dev/sda2              63     15119     15057  7.4M  a OS/2 Boot Manager
/dev/sda3  *     78170400 234435599 156265200 74.5G  5 Extended
/dev/sda5        78170463 151910639  73740177 35.2G  7 HPFS/NTFS/exFAT
/dev/sda6       151910703 172882142  20971440   10G 83 Linux
/dev/sda7       172883968 230217727  57333760 27.3G 83 Linux
/dev/sda8       230219776 234405887   4186112    2G 82 Linux swap / Solaris

Partition table entries are not in disk order.
Disk /dev/loop0: 768.6 MiB, 805961728 bytes, 1574144 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
linux@linux:~> 

I can use the partitioning tool in Yast from Live system but have no idea what to do. If it helps I am willing to delete the eCS stuff but wish to keep Windows XP as it has proprietary software on it I need.
All help gratefully received,
Budgie2

If you have the IBM Boot manager (I presume the one from OS2), then that’s a fairly old computer.

Don’t wait till the end for setting up booting. After designating the partitions to use, there should be a summary screen. Click on “Booting” on that screen. Then you can choolse how to install boot.

Since you want to use the IBM boot manager, you should be able to put it on any of the partitions used by the 13.2 install (assuming that they use a linux file system). But perhaps your computer is old enough that it has to be within the first 9G (or even earlier). So put it on the physically first partition used by the 13.2 install. Make sure that you DO NOT use “btrfs” for the file system, as that can interfere with boot install on older systems.

On the Live installation I am still offered apper updates. Should I accept these and how does this work if whole OS is running from DVD?

No, there is no point in updating when running from a DVD. The update only goes to a ram-disk, and just takes up space that might be useful for other thing. The update is lost on reboot.

With that partitioning, I would suggest using “/dev/sda6” for the root file system, “/dev/sda7” for “/home” and “/dev/sda8” for swap.

On the boot setup, tell it to:

  • boot from the root partition
  • do not boot from the extended partition
  • do not install generic boot code

Hmm, I see that the extended partition is the active partition at present. You need to change that so that the active partition is the OS2 boot manager. And, after installing, you need to configure the OS2 boot manager to boot from the linux root partition (partition 6). It’s a long time since I last used OS2 boot manager, so I’ve forgotten how to configure that, but I presume you still know how.

I suggest “ext3” or “ext4” for the root partition file system. And with only 10G, don’t try to install more than what you need.

Hi Nrickert,
Many thanks for the reply. I have reinstalled 132. with ext4 not btrfs as you advised.

It is on sda6 and I have completed the booting setup as you advised.

When I now try and boot I get the word GRUB on my screen but nothing follows.

Before I make BM active as you suggest I would like to understand how to get the present setup to boot, even if it is only into openSUSE.

As I stated earlier this used to work and booting used to be by grub with all the partitions as they are now. As I recall it was grub that chain loaded BM for when I wanted to select eCS but I haven’t used that for a long time on this machine. The Grub screen used to show 13.1 and windoze options as well.

To be honest I cannot remember which of the two partitions sda1 and sda5 was windoze but as I would be happy to lose eCS in due course as I need the disk space. At present my priority is to get back to having 13.2 and windoze. The windoze is important for one proprietary program which I need on this laptop as it has to be moved and plugged into control systems using serial connection.

Since it worked without using BM for the two OS’s that I want I am reluctant to make BM active if not required.

Grateful for you understanding on how it might have been working as described above.
Regards,
Budgie2

That’s a left-over from your earlier flawed install.

So make BM the active partition. You can do that booting from live media or from the install media in rescue mode. Then run “fdisk” and use the “a” command twice. Once will be to set the active flag for BootManager, the other will be to unset the active flag for the extended partition.

You cannot boot opensuse without that. It is in an extended partition so needs BootManager (or something similar) in order to boot it.

As I stated earlier this used to work and booting used to be by grub with all the partitions as they are now.

Then you previously had grub installed in the MBR. Perhaps remnants of that remain.

Boot from live media or the install media in rescue mode.

Mount your linux root partition. If your partitioning is still as shown above, that would probably be:

# mount /dev/sda6 /mnt

And then, as root, do:


# cd /mnt/usr/share/syslinux
# ls -l mbr.bin

That should show a file if length 440 bytes.

Then:

# cat mbr.bin > /dev/sda

That puts generic code back into the MBR.

If you prefer, you could instead mark your root partition as active. The generic boot code from “syslinux” can actually boot logical partitions, and not just primary partitions. But you will probably be better off with the boot manager as the active partition.

Hi and many many thanks for the guidance. I still do not understand how I was able to boot before without using BM but I have followed your advice. I found my copy of bootable DFSee and was able to use it both to set BM active and edit the menu so all seems fine for now and it works exactly as you predicted. A few issues with repo site availability for updating tonight but will try again in the morning.
Thanks again.
Budgie2