Help please - messed up my kwin settings

I was playing with my special window and special application settings and now am unable to use anything but virtual desktop 4, 1 2 and 3 are all black and everything opens in 4 including all plasma stuff.

Can some please please tell me what to delete to get back to the default as I get on initial install? Then I’ll be very careful how I change things in future :frowning:


I believe all the window rules are in ~/.config/kwinrulesrc - When logged out, try renaming it and see if things are restored to normal.

Or possibly just delete individual rules you may have created (System Settings -> Window Management - Window Rules)

Deleting that file does not fix it. The file is recreated with the original contents after a re-login. Editing the rlues and deleting the offending ones from System Settings as you suggested has got me back to where I want to be now. Thanks.