Help please!! Kernel misconfiguration


I tried to apply a patch to a kernell module for allowing packet injection into my BroadCom 4311 Wifi Card. I used a patch for the b43 driver. I re-compiled the module but when I tried to install the new module I got an error, telling me to run “make oldconfig” or “make menuconfig”. I tried menuconfig, but was missing ncurses lib, so I tried the first one. Big mistake. Nothing worked, and then later, when I restarted my computer, nothing was working at all… Going through the bootlog and stuff I found out that the nvidia driver (which I installed manually through a 1-click-install for my GeForgeGo card) was not compatible with the kernell (or something like that). The wireless lan, which was working ok stopped working.
In the meantime I switched back to the prior “nv” driver, which allowed me to startx successfully, just to confirm that the sound system is not working anymore, I can’t mount usb drives nor ntfs partitions. Besides, I believe there’s something wrong with my Firewall, but I can’t really tell because I didn’t fully use it anyway. So… can anybody give me a hand with this?? Thanks!!

In a terminal window do:
rpm -qa | grep kernel-
Then start the Software installer, and reinstall those packages. This will reinstall the kernel, kernel-sources etc. Also select the Pattern Linux Kernel Development. After a reboot you would have to reinstall drivers you had to install before.
But mind, if something is wrong with the patch and you are compiling the same sources…I think you did something more to the kernel, than what you describe
And, ncurses should be installed by default.

Thanks for your help! I’ll try to do that… but, maybe I misunderstood your post… don’t I need internet conection for that? I don’t have one on site :frowning:

Yes you do