help please, cant install opensuse 11.0, error occured while

hi all,

i decided to install opensuse 11.0 on my dell inspiron 6000 (wiht intel celeron M, 40gb hd, which used to run windows XP) laptop from dvd. but the installation crashes while saving bootloader configuration. it sais error occured while installing GRUB, unable to install bootloader.
i have partitioned the whole hd, splited it into twho parts and formatted it with ext3 file system.
first i thought that the image was broken, but i downloaded it three times but i still get stuck at one and the same spot.

its the first time i’m installing linux and any ideas about how to fix it, would be so appreciated.

thank you beforehand.

Boot the DVD into the Rescue System. Login as root. At the prompt do this and post the output back here:

fdisk -l

Also note which partition is the openSUSE root; if you created 2 partitions, it will be either sda1 or sda2. Then do this:

mount -t ext3 /dev/<root partition> /mnt

replacing with the partition name. Then do the following commands and post back the output here:

cat /mnt/etc/grub.conf
cat /mnt/boot/grub/

Thanks for posting this in the forum as per our instruction in response to your earlier PM.

Just a couple of things to add extra to earlier comments:

  1. it doesn’t matter really how many time you download it. What is important is that it passes the md5sum and also the media check from the dvd.

  2. You say you formatted the whole HD and split in two (so now you have NO XP?)

Ideally you will have

Check your bootloader as I said in my PM. let us know how you get on.

NEWBIES - Suse-11.0 Pre-installation – PLEASE READ - openSUSE Forums

thank you guys for your answers,
yes i have partitioned the whole HD and i have no xp on laptop any more. now what i have is:
/dev/sda1 1gb linux swap
/dev/sda2 14.5gb root
/dev/sda3 20.25gb boot
i tried to check the MBR in the bootloader but unfortunately in vain.

as to mingus suggest:
when i reach the following seps

cat /mnt/etc/grub.conf
cat /mnt/boot/grub/
it sais: “no such file or directory”

Something not quite right here . . . sda3 is being mounted as /boot??? Are you sure that isn’t /home?

I realize it might be a pain to output the results of the fdisk command (if you have to write it down by hand), but it could be important. So please do that (again, it’s fdisk -l, must be as root; that’s the letter l not a 1).

Also, try again booting into Rescue System, be sure to login as root, and then do:

mount -t ext3 /dev/sda2 /mnt
cat /mnt/etc/grub.conf

hi all,

i think the problem was in installation CD, i downloaded iso file again from torrent and everything went fine.

now i’m struggling to enable my wifi device.

thank you all again for your help