Help Please! Can't Boot OpenSUSE 11.4 - screen goes black

I very frustrated at this point. I have tried to boot OpenSUSE 11.4 from the usb flash drive iso and CD iso. After I restart my computer the boot menu comes up and I click the boot option and the screens loads a bit and then goes black. I have also tried the text installer, but that doesn’t work either.

I know the problem must be my graphics chip. I have a integrated Intel HD Graphics chip. My laptop is a Gateway NV79. How can I get the graphics to work?

I’ve tried everything I can think off. I’m not the most computer savvy so if someone replies I would appreciate a dumb-down explanation on what to do with clear steps, if possible.

Note: I’m dual booting with windows 7. The graphics problem is not just OpenSUSE. I tried Ubuntu 11.04, Kubuntu 11.04, Fedora 15 and they all have the same problems. In Fedora 15, I was able to boot in but I got an error message that said Gnome 3 fallback and I couldn’t get the graphics to change to standard mode.

What do I do?

I have the same Gateway NV79. The problem(s) were originally reported against Dell, but the true cause of the problem(s) is the Intel HD graphics. I can not speak for booting from a USB flash drive, but boot from the live CD should function correctly.

Once installed, after selecting from the GRUB menu, and receiving the “Black Screen”, close and open the lid. You should then have a proper working display. Until this problem is resolved (it is in the kernel, specifically, KMS (Kernel Mode Select), you should take several further steps:

  1. In “Power Management”, set action of lid closure to (either) “do nothing” or “blank screen”. (I know that sounds like asking for the problem, but it works!)

  2. If you “Suspend” or “Hibernate”, you must repeat the lid closure upon restart.

  3. Make sure that you “unlock” any screen saver.

For further information, search the “Pre-Release” and/or “Install, Boot Login” forums for “black screen”. Since you are booting 11.4, you should not need to further update X11/Xorg. You may (repeat: may) wish to upgrade your kernel to 2.6.39.

On 06/02/2011 06:06 PM, Kleos wrote:
> What do I do?

this should make you smile:

[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

Have You tried to load intel i915 driver into initrd ? In my case with Samsung R528 laptop with intel graphics, putting the i915 driver into initrd solved booting problems. Please refer to my post solved “Boot Freeze” “Bug: Soft Lockup” problems on Samsung R528 Laptop
Many distros have advice to load intel kms drivers very early in the boot either compiling into kernel or loading from initrd.
Even though my problems are different I am eager to know if this method has any effect in your problem also.

It Works! Thanks soooooooo much SeanMc98!!! I did what you said and it works. I did have some trouble with the LiveUSB, but the LiveCD worked. I never would have thought of your method. You made my day, you rock!

I had read the same material regarding loading the Intel drivers. That was one of the ideas from the Fedora forum that I previously attempted (more than a few kernels ago, around 2.6.37-<something>). The lid closure/reopen was actually discovered (or uncovered") by folks in that same Fedora forum. This circumvention has consistently worked for me and others. Anyone with the Intel HD GMA (or the Intel GM945 and others) on a platform without a lid (such as an “All-in-One” do not have this capability,

I re-attempted adding the i915 Intel driver to the -initrd. While this change did not resolve the “black screen”, the boot process was noticeably faster. I believe that this is due to using the correct driver, rather than running the VESA/fbdev → (switch to) → the inteldrmfb (frame buffer).

I did not remove the VGA=xxxx, as the boot did not present a garbled screen. I will attempt removal later, and post back.

On an historicak note, the openSUSE kernel(s) 2.6.38-rc1 and -rc2 correctly handled the KMS switch, without the “black screen” and required workaround(s). Whatever functionality responsible was regressed in kernel 2.6.38-rc3, and remains conspicuous be its absence. For more review

A further interestiing point is found here :

sean@Twilight:~> sudo /usr/sbin/hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.7IS+B23HFDE
  Hardware Class: framebuffer
  Model: "Intel(R)Ironlake Mobile Graphics Controller"
  Vendor: "Intel Corporation"
  Device: "Intel(R)Ironlake Mobile Graphics Controller"
  SubVendor: "Intel(R)Ironlake Mobile Graphics Chipset Accelerated VGA BIOS"
  Revision: "Hardware Version 0.0"
  Memory Size: 127 MB + 960 kB
  Memory Range: 0xc0000000-0xc7feffff (rw)
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+832), 8 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Config Status: cfg=no, avail=yes, need=no, active=unknown

During this saga, other modes have been detected (such as 1920 x 1080 and 1600 x 1200), though the detected modes change with (almost) every kernel. However, the mode that I have (1600 x 900) NEVER has shown in the hwinfo display. This is further interesting, as the boot.msg and Xorg.log eash show proper detection (and subsequent use) of this correct mode.

I do hope that this problem is permanently resolved before complete un-hingement (either my PC’s or my own!).

I don’t suppose the same solution will work for 12.3? I’m very new to linux and I tried to install it on an old gateway nv79, and I find myself a little limited…

Old solutions may or may not work.

tell us the video card/chip

Also is this a new machine with UEFI or older with BIOS. That may make a difference.

In general at install you should press f3 (I think) and select noKMS if you have a video problem at install