Help Please Cannot Start KDE Desktop

Following a forced restart due to system freeze I am no longer able to start my KDE desktop. I am logged into a terminal and can run commands but cannot start KDM or X11.
This is my main machine so I am in trouble here. Can somebody please help?
Budgie2

Maybe disk is full. If you used BTRFS??? How much space for root partition did you allow? If so remove snapshots and perhaps turn off snapper if you have a small root partition

Maybe a disk problem run smartctl

Maybe video what video what driver and how did you install it. An update may have caused a problem if you manually installed a proprietary driver. If so reinstall said driver

Do you get the graphic login screen? Or do you have auto login set. If so as root from command line run yast and select system-/etc/sysconfig editor and change desktop display manager dislplay-manager autologin to a blank this will turn off auto login and maybe allow you to get to a different desktop

Something in your home config files went bad and stops start of KDE.as your self from terminal rename the ~/.kde4 to ~/kde4.back

That is some possibilities without more info can not give better solutions

Installed with 40 GiB for root and plenty of room remains.

Maybe a disk problem run smartctl

Disks and RAID all OK.

Maybe video what video what driver and how did you install it. An update may have caused a problem if you manually installed a proprietary driver. If so reinstall said driver

I did install Nvidia driver using yast and if there has been a recent update this is a possible cause. Trouble is I only now have console command line and have no idea where to start with reinstalling the driver. Last time there was a problem due to update the screen fell back to VGA and I was able to sort things out with help from here but now no such luck.

Do you get the graphic login screen? Or do you have auto login set. If so as root from command line run yast and select system-/etc/sysconfig editor and change desktop display manager dislplay-manager autologin to a blank this will turn off auto login and maybe allow you to get to a different desktop

I do not get any login screen at all now, however I have run yast as root and turned off auto login as you suggest, but still am left with console on reboot.

Something in your home config files went bad and stops start of KDE.as your self from terminal rename the ~/.kde4 to ~/kde4.back

That is some possibilities without more info can not give better solutions

OK I have renamed the .kde4 to .kde4.bak but this doesn’t help, probably because I never get to kde desktop. The good news is I can run commands so system is working … if I knew what to do next…
I am typing this on another machine so cannot cut and paste results but please let me know what I should try next.
Budgie2

If you installed NVIDIA from the repos then it probable is OK The problem can happen if you install manually the “hard way”

You can reinstall the driver from yast. It does sound like a video problem and it would not hurt to force a reinstall

You may be able to get to a GUI if you start with nomodeset

at boot press e find line starting linux or linuxefi go to true end of that line (it wraps) add a space and nomodeset press F10 to continue boot that should force load of fall back drivers

From the console, if you log in as root, you can run Yast. It is GUI-like, but not quite as pretty as normal Yast. As root in console, simply do:

yast

Hi and thanks. I have forced a reinstallation of the nvidia driver but that has not helped.
I need help with some command lines so I can do it all from terminal please.
Budgie2

Further to the above, there must be entries into the log created when starting which will have clues as to the problem. How can I find and view this log please?
Budgie2

The X11 log in /var/log/Xorg.0.log, kdm’s log is in /var/log/kdm.log.

Also, how exactly did you try to start kdm or X11?
As root try “systemctl start display-manager” and “startx”.

“systemctl status display-manager” should give more information why it didn’t start.

If you created/have an /etc/X11/xorg.conf: remove it, and you should be able to get into a graphical system again (although the nvidia driver might not work).

Hi Wolfi323, many thanks for the reply.

OK, they are long and don’t mean a great deal to me but the Xorg.0.log seems to be OK until at the end I have :-

Fatal Server Error:AddScreen/ScreenInit failed for driver 0

I can try putting file onto usb so I can bring it to this machine if you need to see it.

kdm.log shows essentially the same message.

Also, how exactly did you try to start kdm or X11?

as root, restart kdm and startx

As root try “systemctl start display-manager” and “startx”.

“systemctl status display-manager” should give more information why it didn’t start.

display-manager is running but startx fails with message

xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?

If you created/have an /etc/X11/xorg.conf: remove it, and you should be able to get into a graphical system again (although the nvidia driver might not work).

I have an xorg.conf.d so have removed and re-booted.
Alas, still only get console login.

Well, this does sound fatal.
And what is “driver 0” exactly?

I can try putting file onto usb so I can bring it to this machine if you need to see it.

Well, I’d definitely like to, just this error message doesn’t help much.

Do you get a graphical system when you choose “Recovery Mode” (2nd option in “Advanced Options” in the boot menu)?
Would probably make it easier to upload it somewhere.

as root, restart kdm and startx

Well, with “startx” you probably got the same error message then.
“restart kdm” does not work though, you need to run “systemctl restart display-manager” as already indicated.

xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?

You need to run it as root.
If you did, there should also have been the above error.

I have an xorg.conf.d so have removed and re-booted.

I told you to remove xorg.conf if it exists, not xorg.conf.d!
The latter is necessary for proper operation, although the graphical system should probably at least start without it.
Reinstall the packages xorg-x11-server, xorg-x11-driver-video and xf86-input-evdev to get back most content (the most important one at least).

Hi Wolfi323,
I didn’t delete Xorg.conf.d only moved it to Xorg.conf.bak so I can restore it no problem. There is no Xorg.conf in the directory which is strange.

Sadly I do not get a boot menu at present so cannot chose any options. I could run a recovery CD but since I have a running system there doesn’t seem to be much point

Will restore Xorg.conf.d and await further instructions.

Good.

There is no Xorg.conf in the directory which is strange.

No, that’s not strange.
This normally is not used any more since years.

But it is still respected when it exists, and it might have caused Xorg failing to start (e.g. if it specifies a not installed or not working driver).

Sadly I do not get a boot menu at present so cannot chose any options.

Hm?
Try to delete the file /boot/grub2/grubenv, this could cause a missing boot menu on 13.2 (or earlier) systems using btrfs.

If that doesn’t help, try to edit /boot/grub2/grub.cfg directly and add “x11failsafe” to the boot entries.
Or edit /etc/default/grub and add “x11failsafe” there to the GRUB_CMDLINE_LINUX_DEFAULT line, and run “grub2-mkconfig -o /boot/grub2/grub.cfg” to regenerate the boot menu.

Hi Wolfi323,
Sorry about the long delays. Rebooting takes more than 5 minutes due to strange IBM RAID card which causes delay.

Deleting grubenv made no difference.
Dire warnings not to edit grub.cfg directly.
I therefore added x11failsafe to command line default and rebuilt the boot menu.
Trying reboot now.
Meanwhile how can I force use of the failsafe mode because it is all there in the grub file. I can use Yast (in clunky mode!!!) to edit it rather than using vim on grub file.

BTW how much time do you have as I believe you are in different time zone. I am in UK and it is 19:37.
Regards,
Budgie2

Hm, strange.
Did you maybe set the GRUB_TIMEOUT to 0 by chance?

Dire warnings not to edit grub.cfg directly.

Yes, because they will be overwritten. But it would be ok for a quick test.

Meanwhile how can I force use of the failsafe mode because it is all there in the grub file. I can use Yast (in clunky mode!!!) to edit it rather than using vim on grub file.

Well, you can just as well use YaST->System->Boot Loader to add the “x11failsafe” option. But that does the same as editing /etc/default/grub and running “grub2-mkconfig”.

You can also try to add “nomodeset” in addition or instead “x11failsafe” to see if it helps.

BTW how much time do you have as I believe you are in different time zone. I am in UK and it is 19:37.

It’s 21:17 here currently, so I do have a few hours left this evening…

Ok and thanks.
Well the reboot was less successful than before because now I cannot get to console. The start up script scrolls and stops at:-

[OK] Started Locale Service
[FAILED] Failed to start X Display Manager
''See systemctl status display-manager.service'' for details.
[OK] Started SuSEfirewall2 phase 2
[OK] Reached target Multi-User System.
[OK] Reached target Graphical Interface.

If I press down arrow I get three small green blobs containing question marks in middle of black screen.
If I press it again I get the scrolling down to the above lines.

Cannot start yast any longer. Is it time to run the installation DVD and see if the graphics come up on that and then aborting or running recovery from DVD?

You should be able to login after pressing Ctrl+Alt+F1.

The start up script scrolls and stops at:-

[OK] Started Locale Service
[FAILED] Failed to start X Display Manager
''See systemctl status display-manager.service'' for details.

So it fails to start completely now.
What exactly did you change? Adding x11failsafe?
Then maybe the file /etc/X11/xorg.conf.install does not exist?

What does “systemctl status display-manager” say?

Maybe it helps if you just add “nomodeset”?

Also I would suggest to run “mkinitrd”. Maybe something went wrong with that the last time, this could definitely cause graphics driver problems.
Are you using a separate /boot? Maybe this was/is full…

If I press down arrow I get three small green blobs containing question marks in middle of black screen.

That’s plymouth the boot splash in the text mode version (but with a wrong character set).

Cannot start yast any longer. Is it time to run the installation DVD and see if the graphics come up on that and then aborting or running recovery from DVD?

Well, in worst case you should get to a graphical system if you uninstall the nvidia driver I suppose.
But please save the /var/log/Xorg.0.log and Xorg.0.log.old somewhere first so that we can see what the problem was.

The installation DVD should definitely come up with graphics, unless your hardware is broken.
But I thought we want to fix your system? :wink:

Hi Wolfi323,
The Ctrl + Alt+ F1 worked.
Yes I do want to fix system but thought I should check hardware.
You have given me more stuff to try which will take a while.
Will call it a day now and start again in the morning.
Many thanks once more
Regards,
Budgie2

Hi Wolfi323,
Tried just about everything with no luck so un-installed the nvidia drivers and got back to 1024 x 768 display mode with graphics OK.
Reinstalled the nvidia drivers and no graphics again.

I have un-installed nvidia drivers pending somebody sorting them out. Strange that nobody else has posted this problem. Meanwhile where should I post the Xorg.0.log file for you to look at?

Regards,
Budgie2

Ok. The Xorg log from both cases would be interesting I think.

I have un-installed nvidia drivers pending somebody sorting them out. Strange that nobody else has posted this problem.

Well, I suppose the nvidia drivers do work for most people.
I doubt there is a general problem with the current versions, or there would have been a lot of people complaining already.

Meanwhile where should I post the Xorg.0.log file for you to look at?

E.g. http://susepaste.org

Which flavour of NVIDIA are you installing and what is the card?