Help! No Sound after installing openSUSE11.1

Hi everyone,
I hope someone can give me some input on the issue I’m having. I just installed openSUSE 11.1 on my Gateway M320 Laptop. It’s an older model laptop but everything seems to be working except for the sound.

Anyway long story short, I have no sound (speakers or headphone). I’ve checked all the mixer setting and turned everything up but still no luck. I’ve followed the ALSA update guide and still nothing. I am new to SUSE so forgive me if I am overlooking something.

Here is all my info:

linux-zms6:~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17.

linux-zms6:~ # cat /proc/asound/modules
0 snd_intel8x0
1 snd_intel8x0m

linux-zms6:~ # cat /proc/asound/cards
0 [I82801DBICH4 ]: ICH4 - Intel 82801DB-ICH4
Intel 82801DB-ICH4 with AD1981B at irq 10
1 [Modem ]: ICH-MODEM - Intel 82801DB-ICH4 Modem
Intel 82801DB-ICH4 Modem at irq 10

http://www.alsa-project.org/db/?f=0a656c33534257f58756f987332f274e52c53a8f

linux-zms6:~ # rpm -qa | grep alsa
alsa-1.0.19.git20090224-1.1
alsa-plugins-pulse-1.0.18-6.12
alsa-oss-1.0.17-1.37
alsa-firmware-1.0.19.git20090120-1.1
alsa-plugins-1.0.18-6.12
alsa-utils-1.0.19.git20090221-1.2
alsa-tools-1.0.19.git20090120-1.12

linux-zms6:~ # rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.12-9.6linux-zms6:~ # rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-x11-0.9.12-9.6

linux-zms6:~ # rpm -q libasound2
libasound2-1.0.19.git20090224-1.1

uname
Linux linux-zms6 2.6.27.19-3.2-default #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux

linux-zms6:~ # cat /etc/modprobe.d/sound
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

Please let me know if you need any other info.

Thank You for your Help!

Have you ran alsaconf yet. I’m assuming you probably have, but that usually does the trick. Also depending on what desktop env your using you should also check your yast multimedia settings also to make sure the sound card showing up.

OK, theres the problem (or at least ONE of the problems). You forgot to install alsa-driver-kmp-default. (“default” since you have the 2.6.27.19-3.2-default kernel ). So there is advice here for that (3 zypper commands run with root permissions):
Alsa-update - openSUSE

After installing that, reboot and test. If that does not work, please advise, and we can try working this further. Be careful to install the alsa-driver-kmp-default-version that is applicable to your kernel version.

Hi guys,
Sorry for the delayed response. In regards to the first question: Yes I did run the alsaconf and no dice.

I just installed the alsa-driver-kmp-default and rebooted, checked all controls on the mixer and still nothing.

Here is the updated information:

http://www.alsa-project.org/db/?f=ba447bc6542fc98e078e6b73d99d3242fae509e4

linux-zms6:~ # rpm -qa | grep alsa
alsa-1.0.19.git20090224-1.1
alsa-plugins-pulse-1.0.18-6.12
alsa-driver-kmp-default-1.0.19.20090301_2.6.27.19_3.2-1.1
alsa-oss-1.0.17-1.37
alsa-firmware-1.0.19.git20090120-1.1
alsa-plugins-1.0.18-6.12
alsa-utils-1.0.19.git20090221-1.2
alsa-tools-1.0.19.git20090120-1.12

linux-zms6:/ # rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-x11-0.9.12-9.6

libasound2-1.0.19.git20090224-1.1

Thanks for you help!

Ok, then since I can not see what you checked on the mixer, could you confirm some things? First let me say I am a user, just like you. I am not a developer. I do not have your hardware. And every hardware has a different mixer. … So I can only ask questions on what I see, not knowing what you tested …

I note this in your mixer:

!!-------Mixer controls for card 0 [I82801DBICH4]
Card hw:0 ‘I82801DBICH4’/‘Intel 82801DB-ICH4 with AD1981B at irq 10’
Mixer name : ‘Analog Devices AD1981B’
Simple mixer control ‘IEC958’,0
Mono: Playback on]
Simple mixer control ‘IEC958 Playback AC97-SPSA’,0
Mono: 3 100%]
Simple mixer control ‘IEC958 Playback Source’,0
Items: ‘AC-Link’ ‘A/D Converter’
Item0: ‘AC-Link
Simple mixer control ‘External Amplifier’,0
Mono: Playback on]
Simple mixer control ‘Stereo Mic’,0
Mono: Playback on]You have digital audio (IEC958) on. Should it be ON ? Did you test with it OFF? You have your External Amp ON. Should it be ON ? Did you test with it OFF ? You have the Stereo Mic mixer playback ON. Should it be ON? I’m not saying what the setting should be, … I’m just asking.

Also, what are you using for a sound test? Do NOT do something complicated like try to play an mp3 file or some avi video. Instead, a simple test to see if your sound works, is to open a konsole or xterm, and type (it may be easier to copy and paste this into your konsole/xterm):
speaker-test -Dplug:front -c2 -l5 -twavNote Linux is case sensitive, and “D” is not the same as “d”. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Note the test for surround sound is different. Back off on the volume after you get basic sound.

If that test yields errors, try instead this more simple test:
speaker-test -c2 -l5 -twavIts quite common one test will work and the other will not. Note you should hear a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times.

Try those tests as a regular user, and also with root permissions.

Also, do not forget to go to YaST > Hardware > Sound > Other > Volume and move the PCM and Master volume levels there up to 95%. Close Yast. Then go to your mixer and do the same there with PCM and Master (until you get basic sound).

Alright so here is the updated alsainfo.

http://www.alsa-project.org/db/?f=df25e64ab29cfa7c3455f24b4479428e8f573270

I believe I have tried all scenarios. I went back into my mixer and clean it up. ( I think I went a little crazy with enabling everything when testing)

I changed all the settings one by one that you requested then changed them back to test all scenarios.I used both commands that you directed to test the sound and still nothing.I ran them as root and user as well.

Originally i was using (speaker-test) because i figured that should have given me something.

Just to add some more detail, I get no feed back from the headphones or speakers on the laptop. I know sometimes if the mixer is just turned down to low or volume for a devise such as the cd player is turned down to low, you still hear a little of static out the speaks which I do not hear at all.The laptop only has 2 jacks (headphones and Mic)

Let me know if you have any ideas or need any other info from me.

I appreciate the consistent help and your time.

Ok, another mixer question. I don’t know what this does:
Simple mixer control ‘Headphone Jack Sense’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
should it be on? On my PC, if it is in the wrong position, it MUTES ALL SOUND. I do not know what the “right” position is for your PC.

Reference your PC, it has an AD1981B. I do not see any entries for that in the 1.0.19 alsa HD-Audio-Models.txt file, but I do see entries for the AD1981.

AD1981
======
  basic		3-jack (default)
  hp		HP nx6320
  thinkpad	Lenovo Thinkpad T60/X60/Z60
  toshiba	Toshiba U205

You could try an edit to your /etc/modprobe.d/sound file, trying first “basic” from the above. Change that file to:

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
options snd-intel8x0 model=basic 

save the change, then restart your alsa sound driver with su -c ‘rcalsasound restart’ and enter root password when prompted, then restart your mixer, and test your sound, your mixer, both sound tests … etc …

Then if that does not work, replace “basic” with “hp” and try again … restart alsa, mixer, test sound …etc … Then try the others in the list (thinkpad, toshiba) one at a time.

alright you lost me.

This is what I have in the current sound file in modprobe.d

linux-zms6:/etc/modprobe.d # cat sound

options snd slots=snd-intel8x0

W60f.wxMdEc9vFX5:82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller

alias snd-card-0 snd-intel8x0

I take it you want me to edit the alias line, however I’m confused on the Basic,HP etc. Can you point me in the right direction?

Thanks

alright I’m sorry i just read my post and realized it. Sorry for the brain failure. I take it you want me to add the following syntax to the sounds file.

alias sound-slot-0 snd-intel8x0
options snd-intel8x0 model=basic

and replace model= (with basic,HP and so on)
restart the service and try!

Not replace. ADD a line. ie …

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
options snd-intel8x0 model=basic

and then after that, leave the line in, but replace “basic” with different models such as “hp”, … etc …

Note Linux is CASE SENSITIVE !

Getting an Error:

linux-zms6:/etc/modprobe.d # cat sound

W60f.wxMdEc9vFX5:82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
options snd-intel8x0 model=basic
linux-zms6:/etc/modprobe.d # su -c ‘rcalsasound restart’
Shutting down sound driver done
Starting sound driver: intel8x0FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.27.19-3.2-default/updates/alsa/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)
failed
linux-zms6:/etc/modprobe.d #

snd_intel8x0: Unknown parameter model' snd_intel8x0: Unknown parameter model’
Intel ICH Modem 0000:00:1f.6: PCI INT B disabled
snd_intel8x0: Unknown parameter model' snd_intel8x0: Unknown parameter model’

OK, try the other model options.

If they don’t work, remove that line, and put things back the way there were at the start, with this /etc/modprobe.d/sound file:

# W60f.wxMdEc9vFX5:82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

then restart your PC, and after restarting, provide the output of your dmesg file. ie copy and paste this into a terminal with your PC connected to the internet:dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a and post here the URL that provides.

I’m hoping the dmesg provides a hint. If it does not, we are in bug reporting territory. …

I note this from the Alsa-configuration.txt file for the intel8x0 where it does support autoprobe (although autoprobe appears not to have worked for you):

Module snd-intel8x0
  -------------------

    Module for AC'97 motherboards from Intel and compatibles.
			* Intel i810/810E, i815, i820, i830, i84x, MX440
				ICH5, ICH6, ICH7, 6300ESB, ESB2
			* SiS 7012 (SiS 735)
			* NVidia NForce, NForce2, NForce3, MCP04, CK804
				 CK8, CK8S, MCP501
			* AMD AMD768, AMD8111
			* ALi m5455

    ac97_clock	  - AC'97 codec clock base (0 = auto-detect)
    ac97_quirk    - AC'97 workaround for strange hardware
		    See "AC97 Quirk Option" section below.
    buggy_irq     - Enable workaround for buggy interrupts on some
                    motherboards (default yes on nForce chips,
		    otherwise off)
    buggy_semaphore - Enable workaround for hardwares with buggy
		    semaphores (e.g. on some ASUS laptops)
		    (default off)
    spdif_aclink  - Use S/PDIF over AC-link instead of direct connection
		    from the controller chip
		    (0 = off, 1 = on, -1 = default)

    This module supports one chip and autoprobe.

    Note: the latest driver supports auto-detection of chip clock.
    if you still encounter too fast playback, specify the clock
    explicitly via the module option "ac97_clock=41194".

Here is the Link:

dmesg.txt - nopaste.com (beta)

I don’t recall reading your answer to this:

Thanks. All I note is this:

ALSA /usr/src/packages/BUILD/alsa-driver/pci/ac97/ac97_codec.c:2170: MC'97 1 converters and GPIO not ready (0xff00)

… and I do not know what that means.

I recommend you write a bug report on openSUSE re: your sound not functining: Submitting Bug Reports - openSUSE

Man you are good!

Alright so I went back in and I muted it (i thought i had done that before however i think i just unchecked it in channel config menu) I guess I made the assumption that checking that off turned it off. Which isn’t the case, you need to mute it to turn it off. Anyhow sure enough after turning that off it worked. I muted a few other things so I’ve posted the alsa-info that worked for me below.

Anyhow I want to thank you for help and your time.Muchly appreciated!

!-------Mixer controls for card 0 [I82801DBICH4]

Card hw:0 ‘I82801DBICH4’/‘Intel 82801DB-ICH4 with AD1981B at irq 10’
Mixer name : ‘Analog Devices AD1981B’
Components : ‘AC97a:41445374’
Controls : 34
Simple ctrls : 23
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [0.00dB] [on]
Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control ‘Master Mono’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control ‘Headphone’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [0.00dB] [on]
Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control ‘Headphone Jack Sense’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘PCM’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [12.00dB] [on]
Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control ‘Line’,0
Capabilities: pvolume pswitch cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 31 [100%] [12.00dB] [off] Capture [off]
Front Right: Playback 31 [100%] [12.00dB] [off] Capture [off]
Simple mixer control ‘Line Jack Sense’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘CD’,0
Capabilities: pvolume pswitch cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 31 [100%] [12.00dB] [on] Capture [off]
Front Right: Playback 31 [100%] [12.00dB] [on] Capture [off]
Simple mixer control ‘Mic’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 0 [0%] -34.50dB] [off]
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘Mic Boost ( 20dB)’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘Mic Select’,0
Capabilities: enum
Items: ‘Mic1’ ‘Mic2’
Item0: ‘Mic1’
Simple mixer control ‘Video’,0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘Phone’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 31 [100%] [12.00dB] [off]
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘IEC958 Playback AC97-SPSA’,0
Capabilities: volume volume-joined
Playback channels: Mono
Capture channels: Mono
Limits: 0 - 3
Mono: 3 [100%]
Simple mixer control ‘IEC958 Playback Source’,0
Capabilities: enum
Items: ‘AC-Link’ ‘A/D Converter’
Item0: ‘A/D Converter’
Simple mixer control ‘Aux’,0
Capabilities: pvolume pswitch cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 29 [94%] [9.00dB] [off] Capture [off]
Front Right: Playback 29 [94%] [9.00dB] [off] Capture [off]
Simple mixer control ‘Mono Output Select’,0
Capabilities: enum
Items: ‘Mix’ ‘Mic’
Item0: ‘Mic’
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 15 [100%] [22.50dB] [off]
Front Right: Capture 15 [100%] [22.50dB] [off]
Simple mixer control ‘Mix’,0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘Mix Mono’,0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [on]
Front Right: Capture [on]
Simple mixer control ‘External Amplifier’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘Stereo Mic’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]

Thanks. Glad to read this is working now.

Having struggled so much, a minor tidbit that you might find of interest.

Back in Nov-2008, when one of the alsa developers (who is also the individual at Novell/SuSE-GmbH (who I believe) is in a large part responsible for sound on openSUSE) modified the kernel/alsa so that headset automute would work on my Dell Studio 15 laptop, noted that this “Simple mixer control ‘Headphone Jack Sense’,0” control likely caused more trouble than it was worth, and sometimes wondered if it should be removed as an alsa control. (It was a control present before and after the efforts to fix the auto mute on my laptop). His recommendation to me was to never touch the control.