Help needed with Broadcom 43227 [14e4:4358] and openSUSE 64bit

Hello, this is my first post in this forum. I’m almost new to Linux and struggling to enable wifi on my Acer 5755G laptop.

This is what I’ve done so far:

  • Installed Broadcom-wl from ludmiloff repo
  • Tried both NM and ifup to see if wlan option is visible or not but no luck
  • Checked dmesg output for various keywords e.g. firmware, broadcom, wireless, 4358, etc but no luck

YaST hardware information doesn’t show Wireless LAN

lspci output

03:00.0 Network controller: Broadcom Corporation BCM43227 802.11b/g/n

lspci -n output

03:00.0 0280: 14e4:4358

rfkill output

0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Here is the relevant dump from YaST

PCI 300.0: 0280 Network controller
  [Created at pci.319]
  Unique ID: svHJ.yItFnUFsYTB
  Parent ID: qTvu.S+eWMef6uw9
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Broadcom Network controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4358 
  SubVendor: pci 0x105b "Foxconn International, Inc."
  SubDevice: pci 0xe040 
  Memory Range: 0xd1a00000-0xd1a03fff (rw,non-prefetchable)
  IRQ: 7 (no events)
  Module Alias: "pci:v000014E4d00004358sv0000105Bsd0000E040bc02sc80i00"
  Driver Info #0:
    Driver Status: bcma is not active
    Driver Activation Cmd: "modprobe bcma"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)

I ran the modprobe bcma command after which the above shows bcma is active.

I checked /etc/modprobe.d/50-broadcom-wl-blacklist.conf it shows:

blacklist bcma

Now I’m hopelessly confused. Any help will be appreciated.

  • Installed Broadcom-wl from ludmiloff repo

I think, this will install a


But I would install broadcom-wl from the packman repo.

Does the repo matter that much? I checked Packman and found some broadcom-wl for 12.3 64bit. The one click install gives me message that its not for my version of openSUSE. I installed broadcom-wl-kmp-default and broadcom-wl-kmp-desktop.

Now the command modprobe wl doesn’t return fatal: module wl not found like before.

However, NM and iwconfig still shows no WLAN. :frowning:

That’s a known and long standing problem.

I installed broadcom-wl-kmp-default and broadcom-wl-kmp-desktop.

You only need one of those, according to the kernel you’re using. Check with “uname -a”

But you are still missing broadcom-wl itself (this contains the blacklist for bcma). You just installed the kernel modules.
You should not call “modprobe bcma” since that’s the wrong driver and without the blacklist bcma will be used.
“wl” is the right one.


I removed the default module and kept the desktop one. I also installed broadcom-wl from Packman but the issue persists.

And what does “lspci -k” now say? Is the “wl” driver in use now?

Ran the command lspci -k and it showed Kernel driver in use: bcma-pci-<something I forgot>.

I used modprobe to remove bcma and load wl but lspci -k doesn’t show the kernel module part anymore.

But I think this is progress, finally getting somewhere.

Is the blacklist file there (/etc/modprobe.d/50-broadcom-wl-blacklist.conf)?
And did you reboot after installing the Packman packages?

I’m posting this through wifi!!!

I deleted the 50-broadcom-wl-blacklist.conf when I uninstalled ludmiloff’s broadcom-wl.

After your post I updated 50-blacklist.conf to blacklist bcma and rebooted. Wifi is working like a charm!

Thank you Sauerland for pointing me to Packman and thank you wolfi323 for guiding me to change the driver from bcma to wl. You guys are awesome!

But the package “broadcom-wl” from Packman does contain the blacklist file as well, as I said before. Just install that package and don’t add that line manually to 50-blacklist.conf…

Anyway, glad it’s working now!:slight_smile: