Help needed setting up Epson Stylus SX420W printer/scanner

I am trying to set up my Epson Stylus SX420W printer (via USB) on a fresh install of 11.4.

I have found a driver called ‘epson-inkjet-printer-nx420-1.0.0-1lsb3.2.x86_64.rpm’, which I guess is right for my Intel Core i5-system on the Avasys-site that Epson refers to for Linux drivers.

I have downloaded the driver and installed it via Right-Click -> Open With -> Install/Remove Software, which seemed to go well.

When I open Yast -> Hardware -> Printer -> Add, my printer is found all right, but ‘No matching driver found’.

What am I doing wrong?

Any help would be appreciated - I am quite new to Linux.

Well - now I’m even more confused …

There seems to be another set of drivers for the same printer on the Avasys-site: 日本のものづくりをITで支援する|アヴァシス株式会社](

But when I try to install the printer driver on that page (after having uninstalled the first one) I get this message:

error: Failed dependencies:
libjpeg is needed by pipslite-1.5.0-2.i386 is needed by pipslite-1.5.0-2.i386


that japanese link doesn’t work for me

have you installed the pipslite packages??
They are also needed in addition to the drivers specific to your model.

Thank you for replying.

This is the site with Avasys-drivers for Epson printers: All-in-Ones (Multifunction Inkjet Printers) | AVASYS CORPORATION

If I choose my model in the drop down box at the top of the page, I get at page with ‘Epson Inkjet Printer Driver (ESC/P) for Linux’. From there I can download the ‘epson-inkjet-printer-nx420-1.0.0-1lsb3.2.x86_64.rpm’ that I mention in my first post, which seems to install correctly, but doesn’t work.

On the other hand, if I don’t choose my printer model at the top of the page All-in-Ones (Multifunction Inkjet Printers) | AVASYS CORPORATION I can find another driver further down on the same page - the one called ‘pipslite-1.5.0-2.i386.rpm’. This is the one I mention in my second post that doesn’t even install, but gives me the error message i mention above.

It’s unclear to me what the difference is between the two kinds of drivers?

I don’t know about the pipslite packages you ask about. If i search for pipslite in Yast, I don’t get any results. I have even tried searching for pipslite at without luck.

Can you install libjpeg and libltdl through yast?

I already have:



I can install:



plus some libjpeg development tools.

Should I install all this before the pipslite-1.5.0-2.i386.rpm? (I guess I don’t need the development tools?)

Did you install the 64-bit version of opensuse?

Yes, I did.

OK well I’m stumped unless you need to select the driver from a list when trying to add the printer. Sorry I can’t be of more help.

My printer isn’t on the list that I can select from when adding the printer. I have tried some that ‘are close’, but they don’t work.

But thanks for trying!

It seems that your SX420W is listed as supported by the ESC/P or ESC/P-R drivers available from the Avasys site.

Epson Inkjet Printer Driver (ESC/P) for Linux | AVASYS CORPORATION

Epson Inkjet Printer Driver (ESC/P-R) for Linux | AVASYS CORPORATION

The latter might provide the best capability for your printer (for now).

  1. Download and install the correct rpm package for your system.

  2. Configure your printer (turned on and connected) via the CUPS web interface with your browser:


Select ‘Add Printer’. (You’ll need to supply your root password when prompted). From there you should be able to find the ‘Epson Inkjet Printer Driver (ESC/P-R) for Linux’ driver. When finished, try printing a test page.

Thank you.

I downloaded and installed …

But in the web interface, I still can’t see any driver for my printer.

To assist you, I installed the ‘epson-inkjet-printer-escpr-1.0.2-1lsb3.2.i486’ package using the ‘Install/Remove Software (default)’ option that firefox provides. After installation, I was able to pretend to add a remote printer via the CUPS interface. Open firefox, or your preferred browser, and use


Click on ‘Add Printer’ and your attached printer should be detected (if usb connected). I chose a network-connected option to fool CUPS into thinking I’m configuring a remote connected printer, but the next step is common to all printer configuration. For make and model I selected ‘Epson’ >> ‘Epson Stylus SX420W-epson-inkjet-printer-escpr-1.0.2-1.lsb3.2’ from the list of entries (towards the end), without an issue. (Obviously, I can’t test any further, without being in possession of the actual printer).

Thank you for your effort.

To the best of my knowledge, I have done exactly as you say. I have downloaded the driver. I right click on the .rpm file and choose Open With -> Install/Remove Software. KPackageKit opens, I install the driver and it confirms the installation. I have confirmed in Yast that the driver is now installed. But it is not in the model list when I try to add a printer in the web interface.

I choose the driver ‘epson-inkjet-printer-escpr-1.0.2-1lsb3.2.x86_64.rpm’ - isn’t that correct? As mentioned above, my system is an Intel Core i5, and my openSuse 11.4 version is 64 bit.

What does this return from a console (as root)?

rpm -qa |grep epson

You should get this returned (if installed)


Did you try configuring via YaST?

I get exactly the return from console that you specify.

‘Configuring via YaSt’ - you mean the printer? I have tried that, and it doesn’t find a driver either.

Ok, lets see that the ppd exists (in the expected location)

ls -l /usr/share/ppd/epson-inkjet-printer-escpr/Epson |grep SX420W

It should return something like

-rw-r--r-- 1 root root 3907 2011-03-08 18:23 Epson-Stylus_SX420W-epson-inkjet-printer-escpr.ppd.gz

Edit: Navigating to /usr/share/cups/model/, there should also be a link to the ppd.gz file(s) in one of the sub-directories pertaining to the installed Epson drivers. For reference, I have


containing the newly installed Epson drivers.

Hm …

The command returns:

ls: cannot access /usr/share/ppd/epson-inkjet-printer-escpr/Epson: No such file or directory

Navigating to /usr/share/cups/model/, I have

/usr/share/cups/model/manufacturer-PPDs/epson/, where I see these files:

epal2600.ppd.gz epalc420.ppd.gz epl5900.ppd.gz epln2120.ppd.gz epln400p.ppd.gz
epalc190.ppd.gz epalc850.ppd.gz epl6100.ppd.gz epln2500.ppd.gz epln7000.ppd.gz
epalc200.ppd.gz epalc860.ppd.gz epl6200.ppd.gz epln2700.ppd.gz
epalc260.ppd.gz epalc900.ppd.gz eplc8200.ppd.gz epln2750.ppd.gz
epalc400.ppd.gz epalc910.ppd.gz epln2050.ppd.gz epln3000.ppd.gz
epalc410.ppd.gz epl5800.ppd.gz epln205p.ppd.gz epln4000.ppd.gz

I have similar in /usr/share/cups/model/manufacturer-PPDs/epson/, but the avasys package installed drivers in


which actually points (linked) to


It might be that you need to browse for the relevant PPD (rather simply than selecting make and model) with the CUPS web config. Where it says ‘Or Provide a PPD File:’, browse to /opt/epson-inkjet-printer-escpr/ppds/Epson/, where you should be able to locate the appropriate ppd for your SX420W printer. (The associated filter referenced by the ppd is located in /opt/epson-inkjet-printer-escpr/cups/lib/filter/).