HELP! My Desktop has been squashed!

Late Yesterday, very late, I updated my new 12.2 install using the apper notification icon in the taskbar. It came up with a long list of things, which I did actually read through. Some of it was obscure upgrades to libs or other system stuff, some upgrades to things like Foirefox, ntp, other useful programs. Nothing stuck out as something I did not want, so I told it to go ahead. After a while it finished, telling me I needed to reboot.

I rebooted and it was a mess. The desktop was a small square in the lower right corner. All the windows were screwed in size and position, though they all seemed to work properly otherwise. After checking some settings I decided to reboot again. Now the desktop is a band across the bottom of the screen, just on top of the taskbar about 30 pixels high. Or another way to say it is the desktop is there, but only 1280X30, instead of 1280X1024. When I open windows they are the width of the screen and about twice the hight of the desktop. Before they were sized and positioned appropriately for each program. They all seem to work correctly otherwise and do work in full screen. I am using Firefox now in full screen and have found no problems. BTW, the rest of the screen above the desktop is black. You can resize and position windows in the black space, but there is no right click context menu in that space.

Install is SUSE 12.2(X86-64), KDE 4.8.5, Release 2. Hardware is AMD Turion 64, 2.0G RAM, Nvidia G71 (7950GT) with Nvidia 304.43 drivers installed, Samsung SyncMaster 940b, LED monitor with native resolution of 1280X1024.

I have gone over all the settings in systemsettings and found nothing amiss. Resolution is set to 1280X1024; everything else looks to be the same as before.

BTW, boot splash, and KDE splash screens are all full screen and appear just as they were before.

Does anybody have a clue what happened here? What more information might you need?

Thank you for any help you can give.

OK, maybe I found the problem. In .kde4/share/config/plasma-desktoprc I found the following:


[ActivityManager HiddenTemplates]

Height 1024=659
Height 768=696
Width 1024=730
Width 1280=755

CurrentPalette=Forty Colors








dbfile=/home/BobTheBull/.mozilla/firefox/9dkqfxrw.Default User/places.sqlite




Note the section: [PlasmaViews][4][Sizes][Horizontal1280]; it has a setting of 1280X35 apparently, just what I have. Should I change this and any where else 35 appears to the correct pixels? Does anything else here look out of line? And, how could this have happened?

Just a shot in the dark, but have you tried opening ‘NVIDIA X server settings’ and tried changing the resolution there?

Yes, I thought of that. It is already set correctly. So is everything else in nvidia config as far as I can see.

While I am not sure what is wrong, here is a copy of my file for you to look at:


Height 1200=719
Width 1920=692

[DownloadDialog Settings]
Height 1200=400
Width 1920=700

[KFileDialog Settings]
Height 1200=600
Recent Files$e]=nvidia-settings.png,$HOME/Pictures/nvidia-settings.png,/usr/share/doc/NVIDIA_GLX-1.0/nvidia-settings.png
Width 1920=960

Height 1200=484
Width 1920=645













My normal resolution is 1920x1200. When you do a Ctrl-Alt-F1, do you get a normal looking terminal session? When you do a Ctrl-Alt-F7, does your desktop change in any way? Have you tried to load any other desktops besides KDE?

Thank You,

Thanks for the reply; always good to hear from you jd, but not good to hear you don’t know either.

I had already decided that file is probably not the problem, by making changes in it and comparing to the same file on my laptop, although I have not ruled it out. I note the size section that is used has -1,-1 settings, which neither of mine have. I may try changing that and see what happens.

But for now, got to go to bed. The only thing I am sure of is it is something in /home/user/.kde4. I will explain that tomorrow, along with results of my trial and error, but take my word for if anyone is looking at this and thinking of possibilities.

Easy to test if .kde4 is the problem
Just create a new user, and the problem should be gone
If not - we have to dig deeper, as you did mention the A word :smiley:

Sorry, I’ve had some bad allergy problems lately. Still need to get this fixed really bad.

How did I know it is in /home/user/.kde4 (hereinafter referred to as .kde4)? I have a setup in my first data partition, with a folder with my username where I store folders & files for the configuration of programs and settings in my installs. For instance, all .Mozilla, which has all the settings for all my Mozilla programs. When i install a new distro I symlink the .Mozilla file in data1 to home. Voila, Firefox opens just as I have set it up to my liking, with all the same tabs as when I last closed it, favs, history, etc. I can go from one distro to another and Firefox, Thunderbird, etc. are the same and always in “sync”.

This is especially useful when setting up a new version of suse. I still have my 12.1 install available as a fallback until I get all the kinks worked out. In order to get all my KDE settings into 12.2, I symlinked .kde4. This worked fine; I had to make only a couple of tweaks myself to get KDE set up my way. Note the linked .kde4 was the one setup and maintained by 12.1. It now has duplicate sections for cache, socket % tmp for both distros. Things were working fine and I was going through my symlinks list file copying and pasting into bash to link the files I wanted to link.

Then I hit the update icon in the taskbar and let apper update everything. This was a long list.

Immediately after that the current problem up. When I went back to 12.1, I had the exact same problem. Thus it has to be somewhere in .kde4 folder. I have tried several things which have confirmed that, but did not solve the problem.

As to the plasma-desktoprc file, I have played around with that and the result has been the size and/or position of the desktop have been changed, but have never been fullscreen; Size/position of windows is also screwed up, though nothing else. However, the size/position has changed when I have not changed that file. I deleted the file and rebooted and a new file was placed with only a few of the sections compared to before, but the problem was the same. From this I conclude that file is not the problem, though it seems to interact with it.

Since this problem ocurred as a result of system updating, it occurs to me if there is a log file for that I might find something helpful there. Anyone know if there is and where?

All said, it seems to me something in those updates screwed with something in .kde4 which has seriously screwed with the display of the desktop. BTW, by kesktop, I am referring to the entire area above the taskbar at the bottom. The taskbar and other things at the bottom are all unchanged and working.

@ jdmcdaniel: CTRL-ALT F1 does go to a console session which works as it should, but with large type. C-T F7 goes back to the KDE desktop just as it was from level5; if already in KDE nothing happens. Have not tried another desktop. I did that once by accident and had all kinds of trouble fixing it. Just deployed sysedit and used it for the first time. Wow, is that a neat trick. Takes all the hassle out of what used to be a PITA. Now, if only you could make that a right click option.

Don’t have a clue what you mean by the A word.

Then I hit the update icon in the taskbar and let apper update everything. This was a long list.

A word = Apper
Kiss of death
Don’t use it

Ohhh! I know a lot of people don’t like apper, but I thought that had to do with packagekit interfering with zypper & YAST. I have disabled it myself in the past for that reason. But I didn’t think it could actually screw up on updates. Apparently I was wrong. I shall stick to zypper & YAST in the future.

Still doesn’t get me closer to the problem, though.

Let me see your repo list

zypper lr -d

Here it is:

BobTheBull@linux-bully1:/etc/init.d> zypper lr -d
#  | Alias                             | Name                                    | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
 1 |      | nVidia Graphics Drivers                 | Yes     | Yes     |   99     | rpm-md |                                     |        
 2 |       | openSUSE BuildService - KDE:Extra       | Yes     | Yes     |   99     | rpm-md |          |        
 3 |      | openSUSE BuildService - LibreOffice     | Yes     | Yes     |   99     | rpm-md | |        
 4 | | openSUSE BuildService - KDE:UpdatedApps | Yes     | Yes     |   99     | rpm-md |    |        
 5 |        | openSUSE BuildService - Wine CVS Builds | Yes     | Yes     |   99     | rpm-md |     |        
 6 |       | openSUSE BuildService - Games           | Yes     | Yes     |   99     | rpm-md |               |        
 7 |     | openSUSE BuildService - Mozilla         | Yes     | Yes     |   99     | rpm-md |             |        
 8 | openSUSE-12.2-1.6                 | openSUSE-12.2-1.6                       | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ASUS_DRW-2014S1,/dev/sr0,/dev/sr1         |        
 9 |             | Packman Repository                      | Yes     | Yes     |   99     | rpm-md |                                           |        
10 | repo-debug                        | openSUSE-12.2-Debug                     | No      | Yes     |   99     | NONE   |               |        
11 | repo-debug-update                 | openSUSE-12.2-Update-Debug              | No      | Yes     |   99     | NONE   |                              |        
12 | repo-debug-update-non-oss         | openSUSE-12.2-Update-Debug-Non-Oss      | No      | Yes     |   99     | NONE   |                      |        
13 | repo-non-oss                      | openSUSE-12.2-Non-Oss                   | Yes     | Yes     |   99     | yast2  |                 |        
14 | repo-oss                          | openSUSE-12.2-Oss                       | Yes     | Yes     |   99     | yast2  |                     |        
15 | repo-source                       | openSUSE-12.2-Source                    | No      | Yes     |   99     | NONE   |              |        
16 | repo-update                       | openSUSE-12.2-Update                    | Yes     | Yes     |   99     | rpm-md |                                    |        
17 | repo-update-non-oss               | openSUSE-12.2-Update-Non-Oss            | Yes     | Yes     |   99     | rpm-md |                            |        

It’s not ground breaking, but my only comment is, I never use the Updated Apps repo, preferring to use the kde release repos to get updated kde.
Currently using R49 to get kde 4.9.2

Not related but I notice you don’t seem to have the repos for multimedia.

Makes sense about the kde apps updates, I will remove that. One of the things I want to do is when I get this straightened out is to update to 4.9.2. Or should I do it and see if that fixes the problem? How do I get the R49 repository?

That’s because I didn’t see any multimedia repo in community repos. If you know of a good one I would like to know. I don’t usually

I’d try the kde upgrade for sure

A thing you can do, is remove all plasma related files from ~/.kde4, and reapply your desktop appearance and widgets. That would leave all other settings and data untouched. Mind, you have to do this when not logged on to KDE, i.e. from the console. Login on the console with your own username and password and do

mkdir ~/SavedPlasmaFiles
mv ~/.kde4/share/config/plasm* ~/SavedPlasmaFiles

Return to the graphic login screen, login on KDE and report changes

OK, I have the kde49 repo loaded and ready in YaST but I’m not sure what to do next. Do I tell it to update all?

Select View - Repos
Tick the KDE repo, so that you see it’s contents
Click “Switch system packages to …” ( above the right panel)

Thanks Knurpht. The bar above the pane has dark blue letters on black background, so unless you look really closely you don’t see there’s anything there. Will have to fix that.

Did successfully get 4.9.2 installed, but still have the original problem. Doesn’t anybody have a clue what could have been changed that would cause this problem? I have hunted through all the files in .kde4 without finding anything.

If you did this
And the problem remains. You can forget it being a .kde4problem

Test another new user again.
(You can delete any you made earlier, including it’s home dir)