Help me startx

I am running 11.2 Alpha0 on a low-spec test machine. I am baffled as to why the gui doesn’t start. If I log in as root or user and type startx, it comes right up. I tried all the adjustments from within the gui but they don’t stick.

Similarly, I can’t get out of the autologin. I never see the screen that lets me choose the user (I have only one, but I should be able to get to that screen) or the session. I have tried to fix this in “configure desktop” but it didn’t help.

I just changed the kde repo to factory, thinking the updates might help. They didn’t. Also, I got rid of all the unstable kde repos.

Any ideas?

Try installing kde4-kgreeter-plugins if it isn’t installed yet. Just a wild guess though :slight_smile:

I just did a major upgrade on my alpha today including a kernel upgrade and I am having problems. This is a first alpha even before the announcement. You have to expect a very bumpy ride but things usualy correct themselves in the next upgrade or so in factory usualy a day or so.
start yast goto user and groups administration goto expert options and uncheck auto login

Are there any pointers in dmesg /var/log/messages or /var/log/Xorg.0.log that may throw some light on your problem. The other is /etc/inittab to ensure you have the default runlevel set to 5

That was it lol!

Unfortunately for me, I read to the end of the thread and tried everything from the bottom up. So, I did this last. In addition to giving me the ability to cancel autologin, it gave me the ability to select the kde 4.2 session that was what I needed. It also, strangely, fixed another annoyance. When I tried to shutdown I did not get the option to reboot or shutdown, only logout. Now, those options showed up!

The logs didn’t show anything and init 5 was called for. Maybe because the greeter was missing, I could not get autologin shut off from either kmenu–>yast–>users (grayed out) or from kmenu–>config desktop, although it said it was shut off both places.

I am in the process of doing a zypper up and the whole opensuse is being reinstalled: over 1,000 packages! When its over, I’ll make sure I have kgreeter.

Nice “guess” Axeia!:wink: