help me fuse: mount failed: Permission denied

hi
I installed libfuse-dev libpolarssl-dev fuse-dislocker for access device bitlocker

all commend work but when last line command not workings
>sudo mount -o loop /mnt/tmp/dislocker-file /mnt/disk
fuse: mount failed: Permission denied

this command work(mount point read only)

>sudo mount -o loop,ro /mnt/tmp/dislocker-file /mnt/disk
>

but this command not work
>sudo mount -o loop /mnt/tmp/dislocker-file /mnt/disk
fuse: mount failed: Permission denied
>

this command work in debian and ubuntu but not work opensuse 13.2 kde
>sudo mount -o loop /mnt/tmp/dislocker-file /mnt/disk

please help me
I use opensuse 13.2 kde
sorry for my english

Have you created this directory in the root directory?
/mnt

and have you created the subdirectory tmp, and the file dislocker-file?

What permissions have you given each of those, especially the /mnt directory?

Start by checking your permissions.

yes, I create folders mnt/tmp and request root password and yes create point disloker-file into mnt/tmp

I repeat:

What permissions have you given each of those, especially the /mnt directory?

Start by checking your permissions.

For one thing, you need to make certain the execution bits are set.

how to checking permission mnt

yes,with sudo or su permission and request password

ls -la /mnt

or a file manager of your choice…

no any one for help how to change permissions folder /mnt I want change permissions folder /mnt whit super file manager dolphin but error “could not change permissions for /mnt/tmp/disloker-file” howe to change permissions folder /mnt/~

???
You should be able to change permissions for /mnt just fine.

/mnt/tmp/dislocker is probably no normal file, so that’s probably the reason why you cannot change the permissions for that.
Can you please post the output of:

ls -la /mnt/tmp

Probably you need to change something in fuse-dislocker’s settings, or add some parameter to the call to “dislocker” to make it writeable.
Please note, that I never used fuse-dislocker myself and have absolutely no idea about it. I wouldn’t even have a “BitLocker encrypted device” to try it.

output

@linux-c0ts:~> sudo ls -la /mnt
root’s password:
total 16
drwsrwsrwt+ 1 root root 14 Apr 2 10:44 .
drwxr-xr-x 1 root root 176 Apr 2 10:10 …
drwxr-xr-x 1 root root 0 Apr 2 10:44 disk
dr-xr-xr-x 2 root root 0 Jan 1 1970 tmp

@linux-c0ts:~> sudo ls -la /mnt/tmp
total 0
dr-xr-xr-x 2 root root 0 Jan 1 1970 .
drwsrwsrwt+ 1 root root 14 Apr 2 10:44 …
-r–r–r-- 1 root root 5392826368 Jan 1 1970 dislocker-file

how to change permissions rw /mnt/tmp/dislocker-flie

Why this?

Did you set that manually? Do you have any idea what this means? Or did you just enable every checkbox you saw?
The default is “drwxr-xr-x” btw, and that should be ok.

Also there are ACLs set, that are not shown now. (notice the ‘+’)
They might override the standard permissions.
You can display them with “getfacl /mnt”.

@linux-c0ts:~> sudo ls -la /mnt/tmp
total 0
dr-xr-xr-x 2 root root 0 Jan 1 1970 .
drwsrwsrwt+ 1 root root 14 Apr 2 10:44 …
-r–r–r-- 1 root root 5392826368 Jan 1 1970 dislocker-file

how to change permissions rw /mnt/tmp/dislocker-flie

So I take it that “sudo chmod +w /mnt/tmp/dislocker-file” doesn’t work either?

i use this commands
sudo fuse-dislocker -v -V /dev/sda9 -uxxxxxxxxxx – /mnt/tmp
sudo mount -o loop /mnt/tmp/dislocker-file /mnt/disk

this parameter fuse-dislocker
> fuse-dislocker
dislocker by Romain Coltel, v0.3.1 (compiled for Linux/x86_64)

Usage: dislocker -hqrv] -l LOG_FILE] -o OFFSET] -V VOLUME DECRYPTMETHOD -F[N]] – ARGS…]
with DECRYPTMETHOD = -p[RECOVERY_PASSWORD]|-f BEK_FILE|-u[USER_PASSWORD]|-k FVEK_FILE|-c

Options:
-c, --clearkey decrypt volume using a clear key (default)
-f, --bekfile BEKFILE
decrypt volume using the bek file (on USB key)
-F, --force-block N force use of metadata block number N (1, 2 or 3)
-h, --help print this help and exit
-k, --fvek FVEK_FILE decrypt volume using the FVEK directly
-l, --logfile LOG_FILE
put messages into this file (stdout by default)
-o, --offset OFFSET BitLocker partition offset (default is 0)
-p, --recovery-password[RECOVERY_PASSWORD]
decrypt volume using the recovery password method
-q, --quiet do NOT display anything
-r, --readonly do not allow to write on the BitLocker volume
-u, --user-password decrypt volume using the user password method
-v, --verbosity increase verbosity (CRITICAL errors are displayed by default)
-V, --volume VOLUME volume to get metadata and keys from

--                    end of program options, beginning of FUSE's ones

ARGS are any arguments you want to pass to FUSE. You need to pass at least
the mount-point.

> sudo chmod +w /mnt/tmp/dislocker-file
chmod: changing permissions of ‘/mnt/tmp/dislocker-file’: Function not implemented

Looks ok.

this parameter fuse-dislocker
> fuse-dislocker
dislocker by Romain Coltel, v0.3.1 (compiled for Linux/x86_64)

That’s good, because a quick look into the changelog revealed that write support was only added in 0.3.

So does a chmod work?
Maybe it would help to revert the permissions of /mnt back to the original?

Btw, where did you install “libfuse-dev libpolarssl-dev fuse-dislocker” from?
I can’t find any “fuse-dislocker” package, so you probably compiled it yourself?
But I hope you installed the fuse-devel and polarssl-devel packages included in the distribution that actually match your installed fuse and polarssl…

thanks for help me

I installed with command terminal
sudo zypper libfuse-dev libpolarssl-dev

but download fuse-locker in site www.rpm-find.net for fedora file name (
fuse-dislocker-0.3.1-6.20140423git.fc22.x86_64.rmp)
you can give me link fuse-dislocker o.3.

These packages don’t exist in openSUSE.
Didn’t you get an error message?

Do you have them installed now? And if, from which repo?

rpm -qi libfuse-dev libpolarssl-dev

Also those are only needed if you compile dislocker yourself. For installing an rpm you don’t need -dev (or -devel as they are called in openSUSE) packages.

but download fuse-locker in site www.rpm-find.net for fedora file name (]
fuse-dislocker-0.3.1-6.20140423git.fc22.x86_64.rmp)

Well, this might probably be the reason. I have no idea whether this Fedora package, probably even built for a different fuse version, will work fully in openSUSE.

you can give me link fuse-dislocker o.3.

I think you misunderstood me. Write support (except for Windows8’s encryption) was added in 0.3. That doesn’t mean you have to or should use 0.3.
0.3.1 should be fine. They didn’t remove it again in 0.3.1… :wink: (actually, as I understand it, they even improved it to also support Windows8).

Here’s the source code for dislocker:

See the bottom for instructions how to compile/install it.

For compiling it, you probably need to install “fuse-devel” and “polarssl-devel” though.

But first, I’d rather suggest trying to change the permissions of /mnt.
So please post the ACLs, i.e. the output of “fgetacl /mnt”.

Thanx bro
you are big programmer