Help installing openSUSE on Samsung r40p

Hi,

I’ve installed openSUSE 11.0 on my Samsung r40+ laptop. But suse boots only in text mode :\ I’m pretty new at linux. Do you guys have any ideas how can i fix this?

Intel Core 2 Duo T5500 @ 1.66Ghz (better than Dual Core!)
ATI Radeon Xpress 1250 Graphics card
1024MB DDR2 Ram (Samsung)
120GB Hard Drive
Mother Board: SAMSUNG Electronics CO LTD, R40P/R41P

Sorry for my english :slight_smile:

Hi & Welcome!

Try running the video setup with standard vesa support.
To do this log into the console as root and run


sax2 -r -m 0=vesa

This instructs openSUSE’es video setup program to not look at any previous configuration, probe again and forces to use the vesa driver.

If you get a nice testscreen save the configuration and reboot. If all goes well X will startup fine.

After this you can install the propriety ATI driver, look here for a one-click install and other useful info:
ATI - openSUSE

Good luck!
Wj

Thank you for your fast response.
But when I run that code- this is what i get:

Click

:\

Maybe I can install drivers with the console?

Can you copy and paste the contents of /var/log/SaX.log here?

Make sure you run the sax2 command when in runlevel 3 (console mode), reboot and enter
init 3
as boot option.

Log in as root and retry the command.

Also, what happens if you just let sax2 try and match a working driver with:
sax2 -r

-Wj

ps: it is possible to install the Ati driver from the console, follow this guide : ATI - openSUSE Get_and_Install_ATI_Drivers (starting at the step 1 bit)

I’m sorry, but to work in console it’s a “cosmos” to me. I just don’t know how to copy /var/log/SaX.log :slight_smile: I done what you said. Every time it’s the same. but in /var/log/SaX.log i found this. Is this it?

No problem… we work it as we know it… And slowly the cosmos will be explored :wink:

You could try once more with :


sax2 -r -m 0=radeonhd

If this is a fresh install it might be easier to give the install another try? Meaning : do a new fresh install.

Maybe the setup had an issue detecting your screen settings.
If you can do the setup once more, don’t use the auto configure feature -unmark that option- Then when you are at one of the last setup screens you have the hardware detection phases where you will also see how the graphics and screen are setup.

! One thing : **During the install skip the online update and Internet connection test… **you can do the update when the install is completed.
I’ve seen setups not complete fully when the online update tries to run and fails… so it’s best to leave that till later.

Hope that helps,
Wj

Thank you for all your help. I’ll wait till 11.1 release, maybe it will work. For now Mandriva will be ok :slight_smile: Thanks again :slight_smile:

Sorry for my English :slight_smile: