help installing nvidia drivers for GeForce 210 on OS 13.2

I mentioned in another thread about having issues with displays etc, and have the GeForce 210 graphic card installed. The part I need help with is installing the drivers for the card itself. I’ve seen some past threads where users had a lot of issues with repositories, one click installs from software.opensuse.org, driver downloads from nvidia itself, changing of vendors for the drivers etc.

What’s the best method of downloading, installing, and preventing the “nouveau” driver from reinstalling / enabling each time I update or reboot or whatever, and keep only the nvidia drivers working and installed? I’m about 55% through NET installer for OpenSuse 13.2 version now. Is there a way to prevent “nouveau” driver from enabling each reboot or after update, to only keep and allow nvidia driver installed and having my display work properly?

The information on installing nvidia drivers and help guides seem to be all over the place, it’s confusing. Or is it easier to just install this: https://software.opensuse.org/package/nvidiagfx

For:

01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce G210] (rev a2)

Just go to their website, download the 340.xx driver, and off I go? Lol. Wish plug and play was easier today than long time ago. Just assume it’s simple and painless and the OS’s handle the drivers etc. Just slap in a card or what-not, the system gets the needed driver, and off you go on your merry way enjoying and loving the OS. Not other way around, where you pull hair out, get stressed out, wanting to commit suicide just installing a graphic card & cause you potentially burn out HDD from all the wiping, reinstalling of OS, wiping, reinstalling of OS, wiping, reinstalling of OS, repeat millions of times of a month, rather than enjoying the OS.

Just add the official nvidia repo to your system (YaST->Software Repositories->Add->Community Repositories), then go into YaST->Software Management to install the driver.
The correct packages should already be selected automatically, so just click on “Accept”.

See also:
https://en.opensuse.org/SDB:NVIDIA_drivers

You should not use nvidia’s installer, or you have to reinstall every time there is a kernel update, or an update to Xorg or Mesa.

And why would you install some random package by some random person (nvidiagfx) when you can get the official one too? :wink:
The one you mentioned is only available for openSUSE 11.4 anyway, and won’t work in 13.2.

Well, I see repositories in wiki for 13.2 and everything else, except Leap and Tumbleweed. But according to what you said in other thread post, Leap has the nvidia repos or whatever in it? Am I just better off using Leap and be done with it? Just let it pick up the proper driver needed, or still find the 340.xx one and install it? Lol. Is that other generic nouveau driver installed too, so it has to be removed /dropped? What’s the process for that?

If you are using leap you must use the hard way method ( ie install from hand as recommended via NVIDIA web site) until Leap is fully released. Usually all the drivers will be available in a week or so of the release.

If 13.2 or 13.1 you can simply use the NVIDIA Repo for that version

Note I believe you need to use what is designated GO3 version for a 210 I don’t thing the GO4 will work.

Note also that if this is a notebook and uses Optimus technology DO NOT use the normal NVIDIA driver use Bumblebee

Yes, and you asked about 13.2 here, no?

But according to what you said in other thread post, Leap has the nvidia repos or whatever in it?

Leap is not released yet, so the repo is not available at the moment.
It hopefully will be there when it is released.

Am I just better off using Leap and be done with it? Just let it pick up the proper driver needed, or still find the 340.xx one and install it?

Well, if you want to install the nvidia driver the easy way, you should not install Leap yet.

Use 13.2, and do as I wrote to get the correct version of the proprietary nvidia driver.

Is that other generic nouveau driver installed too, so it has to be removed /dropped? What’s the process for that?

Nouveau is not a generic driver, it is a driver especially for nvidia cards.

And yes, it is installed.
But no, you don’t have to remove it, the packages take care of everything necessary to prevent it from being loaded.
If you install manually via nvidia’s installer, you have to blacklist nouveau yourself though.

Oh okay, yeah, screw that (hard way method) lmao. I’ll just wait for Leap to be released and the drivers / repos for Leap then. I’m using 13.2 now with the community Repos for Nvidia drivers. It appears to have installed them now, and yeah, I think it was the GO3-340.xx drivers installed. This isn’t for notebook, this is for Dell OptiPlex 755 computer. I don’t have Notebooks, Kindles, Ipads, Laptop, etc…

Unfortunately Optimus notebooks a true pain and you can seriously mess thing up if you don’t know what you are doing and install the regular NVIDIA driver. SO it is something we do need to know upfront and amusingly few people offer the info upfront :frowning:

Correct… Lol. I was just asking in general “future” curiosity, IF I were to use Leap instead of 13.2 and Tumbleweed, maybe if one of those other repos would work in Leap anyway (never know).

Right, and I hope too. I’d upgrade immediately then lol.

Right, I understand. I didn’t install Leap. It WAS easier to do it via yast after adding 13.2 nvidia repos. :slight_smile:

Oh okay, I must have misunderstood from an old post then about those Nouveau drivers. But what you said about blacklisting them if I installed them the manual way is what I read about it before, hence wasn’t sure. The only thing now though, after the Nvidia drivers were installed, it lists it there in Kinfo Center program…

Driver Vendor: NVIDIA Corporation
Renderer: GeForce 210/PCIe/SSE2
OpenGL/ES version: 3.3.0 NVIDIA 340.93
Kernel Module: unknown

The only thing is, I lost the high resolution during all boot screens… It’s currently HUGE fonts, etc for the grub menu screen, opensuse / advance menu screen, LVM / encryption passphrase screen etc. Where it wasn’t like this before. Do I have to choose in boot loader options via YAST to raise resolution there again for boot related stuff? It’s weird, cause the max resolution available in there is only 1600x1200, and my max is 1920x1200?

I tried doing the failsafe kernel command line perameters to be “highres=on” instead of original “highres=off”, and that didn’t appear to work.

Yes, that’s fine and shows you that the nvidia driver is in use, and OpenGL support is working.
If you mean the “Kernel Module: unknown” then that’s a problem of KInfocenter.
The way it tries to find out the kernel module does not work any more since Kernel 3.12, the corresponding interface has been removed.

But KDE4 is dead and unmaintained upstream since August, so this won’t be fixed any more.
That problem does still exist in Plasma5 as well though.

The only thing is, I lost the high resolution during all boot screens… It’s currently HUGE fonts, etc for the grub menu screen, opensuse / advance menu screen, LVM / encryption passphrase screen etc. Where it wasn’t like this before. Do I have to choose in boot loader options via YAST to raise resolution there again for boot related stuff?

Yes.
You installed 13.2 fresh, didn’t you?
So all settings from before are lost.

And as mentioned, grub2 has problems in detecting the preferred monitor resolution on nvidia cards, certain models at least.

It’s weird, cause the max resolution available in there is only 1600x1200, and my max is 1920x1200?

Well, grub2 does not run in an operating system and cannot load the OS driver.
It has to access the hardware directly and therefore only uses generic VESA modes AFAIK.
And YaST doesn’t detect the resolution anyway, it just offers a hardcoded, pre-defined list there.
That resolution chooser in YaST is actually a text field, though. You can enter anything you like, so try 1920x1200.
I cannot guarantee you that it will work though.

I tried doing the failsafe kernel command line perameters to be “highres=on” instead of original “highres=off”, and that didn’t appear to work.

Never heard of such an option.
If you want to change the resolution for text mode, use an option like “video=1920x1200”.

And why “failsafe”?
You should do a normal boot, otherwise you won’t use the nvidia driver. The “failsafe” options only take effect when choosing “Recovery Mode” in “Advanced Options” in the boot menu.

PS: The “highres” kernel option does indeed exist, but it is totally unrelated to graphics.
From https://www.kernel.org/doc/Documentation/kernel-parameters.txt :

highres= [KNL] Enable/disable high resolution timer mode.
Valid parameters: “on”, “off”
Default: “on”

Ah okay, good to hear then, that it’s not the driver issue or whatever. Maybe / hopefully they’ll fix it in future.

Yep, correct! And okay, I just assumed it would pick up/detect and display the max resolution of the monitor regardless lol.

Ah, makes sense. I’ll try entering 1920x1200 once and see how it goes. I did choose in drop down for 1600x1200 or whatever it is, and appears to be working.

It’s there under boot kernel field in boot loader for yast. I was doing settings in the kernel for wrong thing, hence it not working for me on normal boot… lmao. I didn’t need the failsafe option/recovery mode / advanced options so I wasn’t seeing any changes I was making Lol! Makes more sense then haha. I’ll try that “video=1920x1200” once and see how that works / goes.

Little off-topic, I see network manager icon in bottom tray with little red x there saying it’s not running, but I have internet… why is it off but apparently working? Shouldn’t that be enabled by default after fresh installation?

VLC player and codecs installed, playing movies good. About Firefox and Thunderbird though, should I add repositories or PPA’s for those two to keep those updated always?

No, openSUSE uses Wicked by default, SUSE’s replacement for the traditional ifup.
Only if a wireless device is detected during installation NetworkManager is enabled, because it allows easier switching between wireless networks.

You can switch in YaST->Network Devices->Network Settings->Global Options, or you can hide/disable the NetworkManager icon in the system tray settings if you stay with Wicked and the icon disturbs you.

About Firefox and Thunderbird though, should I add repositories or PPA’s for those two to keep those updated always?

Not necessary.
Both are included in the distribution, and you’ll get the latest versions via the standard updates.

Ah okay, thanks, that explains it. Nah, it doesn’t bother me lol. I was just curious as to why it was disabled or whatever. :slight_smile:

Oh okay, well I went and added the repos from community for Mozilla and did zypper dup and it upgraded it haha. When I did update / dup after installation, it didn’t upgrade it (Firefox).

It should. I do have Firefox 41.0 here without any Mozilla repo. (13.2 shipped with 33.0)

OTOH, of course you get updates faster via the additional repo, as soon as new versions are released (and packaged). The standard updates lag behind a few days and they even might skip versions if the fixes are deemed not necessary.

Right, and was wondering about that too, cause usually it’s first thing I check is the version of firefox and try to update it to latest quick (for possibly vulnerabilities, exploits, etc). To keep the thread from going off topic, where to start threads about security, what to install for security etc? Repos and application discussions for the applications forum of course.

Thanks to you and the others for helping me though, I should be good to go (knock on wood). Much nicer on stable OpenSuse with the graphic card and etc, will have to get used to 13.2 lol.

Ok, got Leap installed. Got a plasma related error popup after getting to desktop, and that annoying pulseaudio error popup as well. Did zypper update, zipper patch, zipper dup… and errors still there lol.

Trying to do the hard way method of doing driver for card, got the driver downloaded from nvidia site, the 340.xx one. It’s .run file, it only opens in Kate text editor lol. I’m trying to do the instructions and can’t figure out how to access console login…

To install the driver you need to log out and under the shutdown options  choose "console login". If this logout option is not supported in your desktop environment (DE),  please log out from your GUI session and select "Console login" from  drop down menu of the Display Manager screen. Anyway, after logging out  from your GUI session, you can log in at any time to a [real console](https://en.opensuse.org/SDB:Login_as_root#The_real_console) using the key-combination Ctrl-Alt-F1. 

Don’t even see this option when booting to do it this way…
https://en.opensuse.org/images/a/a5/Boot-to-run-level-3.jpg

Not sure if I need to disable the KMS?

Anyway, off to bed for now… Lol

Open /etc/pulse/default.pa in a text editor (as root, so either use “File Manager - Super user mode”, or run something like “kdesu kwrite /etc/pulse/default.pa”) and replace the line

load-module module-native-protocol-unix

with

load-module module-native-protocol-unix srbchannel=no

That should “fix” the crashes.

Trying to do the hard way method of doing driver for card, got the driver downloaded from nvidia site, the 340.xx one. It’s .run file, it only opens in Kate text editor lol. I’m trying to do the instructions and can’t figure out how to access console login… [/FONT]

To install the driver you need to log out and under the shutdown options  choose "console login". If this logout option is not supported in your desktop environment (DE),  please log out from your GUI session and select "Console login" from  drop down menu of the Display Manager screen. Anyway, after logging out  from your GUI session, you can log in at any time to a [real console](https://en.opensuse.org/SDB:Login_as_root#The_real_console) using the key-combination Ctrl-Alt-F1. 

Don’t even see this option when booting to do it this way…
https://en.opensuse.org/images/a/a5/Boot-to-run-level-3.jpg

That’s the boot menu, not the display manager (= login screen).
Just press Ctrl+Alt+F1 at the login screen to get to text mode, as the quoted text states.

Or add ‘3’ to the boot options as displayed in that picture. Note though that on EFI systems you won’t have that command line to enter things. In this case you’d need to press ‘e’ and append ‘3’ to the line starting with “linux” or “linuxefi”.

Not sure if I need to disable the KMS?

Yes, you should. I think the nvidia installer just quits with an error if nouveau is loaded, disabling KMS will prevent that.

Just follow the instructions, for openSUSE >= 12.2 obviously.

Thanks! That worked. However running file manager in super user mode by searching in applications “File Manager - Super user mode” and clicking on it, didn’t work or seemed to work. Didn’t load the file manager at all in super user mode. Had to open file some other way, I think right clicking on etc folder and open in terminal, did “su” then “kdesu kwrite /etc/pulse/default.pa”. Even trying open folders by right clicking and open with file manager - super user… doesn’t work lol.

Thanks again, the first one worked… Ctrl+Alt+F1.

I had saved the nvidia .run file in downloads, but in console login I moved file from /Downloads to /root. But like I said before, the instructions aren’t in order, and they’re not in detail. Worked my way to /root in console, had to search on how to run the .run file. So found it on ubuntu ask thread: software installation - How do I install .run files? - Ask Ubuntu

chmod +x NVIDIA.run
then to run it: ./NVIDIA.run

Then it ran. Because as per instructions: sh /root - didn’t work. Replace “user” with your username. Then hit the “Tab”-key and the console will auto complete the rest. Then you press the “Enter”-key. - Doing Tab key or whatever, didn’t work. running: modprobe nvidia - didn’t seem to do nothing or I didn’t do it right after running installation there - didn’t relog back in console after reboot. I did run it though in super user mode in konsole after getting to desktop. And the command: rcxdm start

But it appeared to have installed the drivers anyway so…

Got to know how to RUN it finally from another site, not OpenSuse wiki… But the installation kept failing, so like I said too, the instructions ARE NOT in order, NOT always working for each system.

Disable Kernel Mode Setting (KMS) - DID NOT WORK, cause it’s for 11.x version only… Lol


Disable Kernel Mode Setting (KMS)[edit](https://en.opensuse.org/index.php?title=SDB:NVIDIA_the_hard_way&action=edit&section=4)] Kernel Mode Setting (KMS) works in supported versions, currently 11.4 and 12.1, and you can skip this section.  
 openSUSE 11.3[edit](https://en.opensuse.org/index.php?title=SDB:NVIDIA_the_hard_way&action=edit&section=5)] It used KMS by default, which was not supported by the proprietary Nvidia driver, therefore it was necessary to disable it. 
Add "nomodeset" to the boot options in /boot/grub/menu.lst 
Also remove it from the initrd. Edit /etc/sysconfig/kernel and set "NO-KMS-IN-INITRD = yes". Then run:  mkinitrd



Trying to edit those files with “vi” from console login gave empty / blank files, so exited it. Went to normal desktop to edit files from super user konsole with Kwrite or Vi or whatever, they were empty files or trying to create NEW files.

echo “blacklist nouveau” >> /etc/modprobe.d/50-blacklist.conf - ran from console then, and tried redoing installation of drivers, didn’t work. I did it from Desktop > Super user konsole… it worked and doing this next step, the installtion of drivers worked…


Since openSUSE 12.2 the procedure has changed, since grub2 is the default bootloader. Please proceed like here: 
 


  -  Use the YaST module: in the YaST Control Center, select System › Boot Loader.
  -  While in *Boot Loader Settings*
 dialog, click *Boot Loader Options*  -  Find the field with title: *Optional Kernel Command Line Parameter:*
  -  Add at the bottom of this line:  nouveau.modeset=0. E.g. changing  resume=/dev/disk/by-id/scsi-XX-partN splash=silent quiet showopts into  resume=/dev/disk/by-id/scsi-XX-partN splash=silent quiet showopts nouveau.modeset=0)
  -  Click *OK*
 (twice) to save the changes.  -  Reboot




but instead of :

 resume=/dev/disk/by-id/scsi-XX-partN splash=silent quiet showopts nouveau.modeset=0)

made it:

 resume=/dev/disk/by-id/scsi-XX-partN splash=silent quiet showopts nouveau.modeset=0

That trailing “)” didnt look right as per instructions, so removed it, it seemed to work cause in KINFOcenter… it lists the nvidia driver like it did in 13.2 lol. So again, the instructions aren’t in order, they’re not in detail, they’re not always right etc.

Read above, didn’t work lol.

Thanks, worked, but didn’t trust instructions for trailing “)” in *Optional Kernel Command Line Parameter so removed it. *

I know this isn’t about 13.2 but instead LEAP, but just because the power got knocked out in the day the other day from that 2B dollar military blimp that came into the area (no more than 15 min drive from me, I’m in Montour County) knocking out power lines, I some how lost the screen settings. At boot, I had nothing but console login, and tried running “startx” and got error about missing screen. Thought ****, time to reinstall AGAIN for 1,000,004th time Lol… But ended up just reinstalling the NVIDIA driver (no other steps from Wiki page), and it seemed to work. But after having screen shut off a while while I slept and turned it on, it seemed to take a while to register it again, kinda went on, off, on, off, on again and staying on. Not sure what’s going on here, but just because house power got knocked out and system shut down quickly (not technically properly) it shouldn’t delete or mess up your screen settings and graphic card drivers?

Well serious power disruption can cause file system problems. Run fsck from a live DVD/USB.

Alright, just curious, where can I get copy of FSCK to “burn” it to usb? I don’t really have any blank dvds in good condition, and only other discs are cds lol. I tried googling for FSCK to download it, but nothing really comes up for it?