Help Installing 13.1 with UEFI / secure boot

Hello all,

Needed a new laptop and bought an HP 15-g029wm. The machine had Win 8.1 pre-installed and I do NOT plan to dual boot. Only installing OpenSUSE 13.1, no other OS so I’m using the entire HHD.

I think I’ve tried every combination of UEFI / Legacy, Secure / not Secured, Boot from DVD (UEFI) / Boot from DVD (no UEFI - this way I get the traditional welcome screen), … If there were options, Ive tried them, and still nothing. With a UEFI boot up I eventually get a text screen ending with a Kernel panic end not much else. With the Legacy approach it ends with a little box containing the traditional terminal. When I try startx I get an error referring me to

I read a number of places that SUSE 13.1 handles UEFI very well. Other posts on the web digress into unintelligible geek speak.

Is there a straight forward way of doing a simple install on a UEFI machine?

I did notice something odd, I don’t get the option to remove the disk after installation but before the first boot?!?

(I’ve been using SUSE since 10.0. By no means a pro, but I’ve managed to get things working over the years.)


So if you press the F9 key you can select an efi file to boot from? If secure boot is enabled then you need to select shim.efi.

I have three HP systems booting via UEFI (two use secure boot), as long as you have a /boot/efi partition (vfat and at least 260MB), a / and a swap (and a /home if required) all should be good.

So can you boot in rescue mode from the dvd and check the output from;

efibootmgr -v

Maybe the first problem is the size of /boot/efi. Following SUSE’s recommendations it always comes up at 157.00, 157.88, 158.00, or 158.88. When I tried to resize I get ‘Resize not supported by underlying device.’ I’ve read somewhere that gparted is the tool to use. I’ll work on that tonight and get back to you. Also, does it matter if /boot/efi is the first partition?

Thanks Malcolm.

I always pre configure with the openSUSE 13.1 rescue usb device and use gdisk from the command line, the rescue system boots in uefi/secure boot mode as well.

Well technically it doesn’t need to be the first partition, just set to type ef00, for example this sytem is;

 gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.8

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 250069680 sectors, 119.2 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 250069646
Partitions will be aligned on 2048-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          534527   260.0 MiB   EF00  EFI System
   2          534528        84420607   40.0 GiB    8300  Linux filesystem
   3        84420608       233318399   71.0 GiB    8300  Linux filesystem
   4       233318400       250069646   8.0 GiB     8200  Linux swap