help I broke KDE!

Hi I’m in need of help. Unfortunately I think I broke KDE.

For some unexplained reasons KDE crashed while I was working on my computer. The screen went black and a part from a couple of windows left open everything else was gone: desktop, icons…

so I used Ctrl+Alt+BKS to log out. when I attempted to restart KDE it didn’t work and it kept on sending me back to the login.
upon rebooting I’m unable to see KDE and I only have a small terminal window (which seems to be in a some sort of graphical mode) and at the command “startx” the system replies that X is already running.
If I reboot in safe mode, when I give “startx” I get a black screen.

Any idea on how I could get KDE working again?
thanks in advance for your help!

Hello ftriscari12,

Do you get any error message from that small terminal window?

What you can do is boot into text mode.
Login as your own user and run this command:

mv ~/.kde4 ~/.kde4BU

This will rename your .kde4 folder.
This folder stores all your KDE settings, so by renaming it KDE will create a new one.

Once you’ve done that you can reboot and try to log-in.
If it doesn’t work you can try to make a new user (for test purposes).
Boot into text mode, run this command:


Select Security and Users->User and Group Management.
Select Add and fill in the form, press ok and once again.

After that you can reboot and login as your new user.

Best of luck!:wink:

thanks for your quick reply.
unfortunately it looks like nothing is working.
the normal user doesn’t create a new KDE4 folder and the new test user doesn’t even add all necessary folders to the /home folder (Desktop, Documents…).
I can login with the normal user and from the little CLI I have I can start dolphin and other programs including YaST2. When I try to install programs or to update the software I get a bunch of errors and the message that / is full!!!

I’m a bit worried…

If you log into the CLI, and do a “df” without quotes, you’ll see that / partition is full. SOmething is filling up your root partition, so the OS cannot use the “temp” folder anymore for all the temporary files. You need more storage for your root parititon. Free up some space.

ok, I managed to delete some files from temp and I logged in with KDE!!G
now my next problem. / (10GB) is still almost completely full.
one of the largest files is /proc/kcore which says is 128TiB !!! can this file be deleted?

Never delete files from /tmp on a running system. Use Yast-System-Sysconfig Editor for that. Search for “tmp” and set the appropriate value for /tmp to be cleaned at next boot.

The file /proc/kcore is not a real file. Don’t attempt to remove it. It’s the same size here :wink:

Ask yourself what you installed, other than the default. These days 10GB is not too much, certainly not if you install some games, have some mysql databases etc.

/proc files are not real files they are not stored on the disk. They are just reflections of the state of the kernel processes. In Linux all things are files.

10 gig for root partition is a little low for serious use.

You can clear the temp files at boot with this setting

YAST-System-/etc/sysconfig Editor - System-cron-CLEAR_TMP_DIRS_AT_BOOT

set this to yes

That’s not real. Don’t touch that file. Something else is filling up your root partition. Leave /proc directory.

Please type the following command in a terminal:
df -hl
and post the output here.

this is the output

linux-xcby:/home/francesco # df -hl
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda6             9.9G  8.4G  990M  90% /
devtmpfs              1.9G  252K  1.9G   1% /dev
tmpfs                 1.9G  4.0K  1.9G   1% /dev/shm
/dev/sda8              38G   17G   19G  49% /home
/dev/sda3             101G   54G   47G  54% /mnt/winC
/dev/sda5             304G  175G  130G  58% /mnt/win

before this problem I had more than 4 GB free in /
not sure what is going on here…

hmmm …
I assume sda7 is swap ?
swapon -s
Do you have an second HD on an external HD or something where you could copy 17 Gb ?

Lots of thing may make temp files. Also you may have overly large log files if there is something out of kilter.

Setting the CLEAR_TMP_DIRS_AT_BOOT flag will help mitigate this a bit.

Ok, I might have found something

/var/log/messages-20101002 over 3.5GB

I assume I can delete it?

Then you can try the following command (it might take a a couple minutes) :
du -xa | sort -n

Yep ! Ditch it!

That’s probably a system message log? There should be a setting somewhere to prevent it from growing to that size again.

HA!!! it worked!!! everything is back to normal!!!yes!!

thanks guys!!!

Sorry just one last question.
after all this process I had a couple of widgets that are no longer working. Since they were not in the default installation and I had them downloaded from the “get new widgets>download new plasma widgets” I tried to download them again.
Unfortunately it can no longer find the downloadable widgets like if the system has lost the “link” to the on-line server where you download them from.
how can I restore the “add new widgets” facility?

PS it looks like the website “” is down…or is it just me?

ftriscari12 wrote:

> HA!!! it worked!!! everything is back to normal!!!yes!!

Now the question remains what made /var/log/messages so big.
Better take a look if it is getting bigger.
And ofcourse read it :slight_smile:

Chris Maaskant