Help,I booted into bad Window Manager

I screwed up.

I installed some other Window Managers,tried a few,then made the mistake of trying “Metacity.”

Unfortunately,I get a blank screen.

On top of that,I had Opensuse 11.0 still set to boot into whatever I was using before,instead of a login screen.

Safe Mode doesn’t work.

Is there some way to boot into a login screen,or text mode,then somehow “alter” the system to boot into KDE4,or have I cooked my goose…

…meaning reinstall,in which case I’ll download 11.1

I’d rather just stay with 11.0 if poss.,especially after I got things set up just right.

What can I do?ie: How I boot back into KDE4?
(or I’ll take Gnome,or other if you know that)


When you get to the blank screen, hit Ctrl+Alt+Backspace twice in succession and this will bring you back to the login screen.

Good Luck,



Ian -you’re a genius!

It worked!

Just one MORE reason why the Opensuse Forums are the best!

ps:Metacity was the culprit.I tried FVWM,etc,but when I tried him the screen went blank!

pps: If you know: If I set the system to boot to the “login manager” first,instead of auto -last window manager,will it still start the network card and dsl live at boot in(last install I used Kinternet,but decided on live at bootup this time)to Kde,or other Window Manager?

I’m just thinking getting rid of auto boot into last window manager might be an idea -just in case -control,alt,backspace 2x doesn’t work

yes today metacity trashed my login as well. Very unprofessional of opensuse to have this gui and have it be so poor.

The thing with metacity is that you aren’t supposed to run it from the login window. GNOME does it when you run it.