Help! Hp Tx2 overheating and no WiFi!

Hi, I just installed 11.2 and my processors are running at 62% all the time. There are no obvious processess in th system monitor using so much processor, there is none over 8%, the highest is system monitor itself.

Then I am trying to make the Broadcom wireless driver but I get the next error:

KBUILD_NOPEDANTIC=1 make -C /lib/modules/uname -r/build M=pwd
make: *** /lib/modules/ No such file or directory. Stop.
make: *** [all] Error 2

So I have no wireless! I allready depackaged succesfully.

Please help me, I am seriously trying to avoid the Windows empire, but this is so hard, I am a total newbie.:frowning:

I was getting the exact same error and just got it working on OpenSUSE 11.2 64-bit. Make sure you have the following packages installed:

  • make*]gcc*]gcc-c++*]kernel-desktop-devel

other packages I installed troubleshooting, but I don’t think they were necessarily needed:

  • linux-kernel-headers*]kernel-source

Then follow the instructions in the README.txt file provided with the driver to the letter. Everything should work.

Thank you very much! You were so right! I worked like a charm,the only problem that I am having is that every time I reboot I have to input on terminal:

modprobe lib80211

insmod wl.ko

To make it work again, is there a way to make it work automatically?

Thanks again

You may have got the answer to this by now but in case not I have just had to sort out the same problem.
I am running opensuse 11.2 on a Dell d531 and had followed the instructions to install the latest Broadcom drivers : - 802.11 Linux STA driver
The readme file in this page helped a lot.
Once I had got the wireless working I had the same problem as you in that I had to run commands in the terminal window every time I booted. However if you enter commands in the /etc/init.d/boot.local file this will get it working on boot.

First of all note where the wl.ko file is (or whatever file you enter after ‘insmod’ to get your wireless working. In my case the file was in a folder I’d made called Broadcom and in a subfolder called hybrid_wl so I had to be in this folder before I could enter the insmod command. My commands then were as follows:
cd /home/davsmi/Broadcom/hybrid_wl
insmod wl.ko

It was not necessary to re-enter the modprobe command.

To get this to work on boot just log in as root and then go to the /etc/init.d directory and open the boot.local file with a text editor.
Then add the 2 lines above (modified to your particular file and location and save the file.
Restart your machine, log in as your normal user and the commands will be carried out on boot and your wireless should work fine.

Hope that helps

Dave Smith