Help! How do I disable "desktop effects"?

I shouldn’t have enabled desktop effects(I remember someone warned about it) on a newly installed 11.2.
Now I cannot login on my normal account.
What conf file is the setting for desktop effects in?

11.2/KDE 4.3.1

Click on kickoff > Configure Desktop > Desktop > Uncheck enable desktop effects.

Once the computer has finished booting, press ctrl-alt-f1 which will take you to the first Virtual Terminal.

Login with your normal username and password, then there are 2 ways to do it, quick and dirty, and the proper way.

  1. Quick-and-easy - sinply rename the .kde4 folder (which contains all your desktop settings and KDE4 programme settings. The downside is that you will lose your desktop customisations and prog settings in Dolphin/Konversation/Kopete etc’. To do that simply type -
mv .kde4 .kde4_disabled

Or simply delete it if you don’t care.

  1. Edit the file ~/.kde4/share/config/kwinrc and change the line - Enabled=true to Enabled=false in the [Compositing] section.

Then simply restart.

quick way to disable kde4 desktop-effects from my kde 4.Ouch days… do a console login as the user you wish to disable, then:

kwriteconfig --file kwinrc --group Compositing --key Enabled --type bool false

exit… then do a normal login.

:slight_smile: Thanks!:slight_smile: