Help! Grub didn't install!

I was in the middle of my download when it said Grub didn’t install properly. I said ok, so I went on with the download. Big mistake. Now I have total access to openSUSE, but XP IS GONE! I cant access it, no matter how I try. I need XP and the files on it. Please help!


If you have the Windows DVD you should be able to use that to restore the Windows bootloader.


Also, in case you weren’t aware, you can access the files in your Windows partition from Linux, it’s normally mounted as /windows.

But don’t panic, you will be able to get back into Windows.

Barry, are you available for chat? I think it might be easier so that way you can guide me through this. That’d be a great help.


I can log in to IRC if you want, but I’m really no expert in this area, I would try to follow what has been suggested by others.

I think this may be a good starting point: lost windows option from boot menu - openSUSE Forums it sounds like a similar problem to yours and has been solved.


You need to post the result of this from a su terminal

fdisk -l


cat /boot/grub/menu.lst

It is helpful, but I think I found an easier way. I’m in the bootloader now, and I’m wondering is there’s a certain setting that I can change so that I can get into XP. Is there?

Slow down, you are in danger of doing more harm than good. As it is, windows is still there, you just need to have an entry for it. If we had the info we asked for, we could help.

There is a guide here:
GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

And this section applies to where you are:

Once Suse has fully booted and settled down, go to Yast –> System –> Boot Loader. The Grub configuration screen comes up with the Tab “Section Management” activated. In the lower right is a drop-down selector labelled “Other”. Select from “Other” the option “Propose New Configuration” and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled “Boot Loader Installation” and select to “Boot from the Master Boot Record”. [Yast will often default to booting from the root or boot partition rather than from the MBR but that’s for experts only – always choose the MBR.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive’s MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk … don’t bother with the floppy – just click OK to proceed and install to the MBR. Reboot and you should be able to boot to openSUSE using the Grub menu screen. Frequently you can also boot to Windows after completing Step 2, so try that too and maybe you won’t need Step 3

Check step 3 in that guide as it deals with your issue too. I’m off to bed now.

Remember - slowly does it:)

Every time I enter Windows from the Grub menu it kicks me out. I can’t access it, but I can access SUSE fine. How can I fix this fast becuase I need my files in Windows.

Also, the Thinkpad software is inacccessable. I can’t get into the settings. Does this mean Windows is gone?

can u provide more info?

  • what happens exactly when u chose Windows (error msg?)
  • copy and paste /boot/grub/menu.lst here
  • copy and past output of “fdisk -l”
  • do u know on which partition Windows is installed

btw, why can’t u access windows files? u can read Windows partitions from openSUSE.

Output of fdisk -l plus the contents of /boot/grub/menu.lst will help someone point you in the right direction.

Even if you can’t boot windows you should be able to access the filesystem (and files). Default Suse install is to mount any pre-existing win filesystem

By “Thinkpad software” you mean the recovery partition from “Access IBM” button? Totally separate from any Windows install. Did you choose anything other than the suggested partitioning option during Suse install?



You’d fix your problems a lot quicker if you stuck with the same thread you created instead of creating random duplicate ones whenever someone tries to help you.

caf4926 is a highly knowledgeable Linux/openSUSE user, I seriously recommend you follow his advice in future, instead of starting a new thread to find a different solution.

Also the link he told you about GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader. was written by another highly knowledgeable, well respected member of the openSUSE community.

Good luck adding Windows to your GRUB menu, but please try to stick with the same thread for the same problem, and try to listen to the advice of the more experienced users.


Another excellent and handy option is super grub disc found here:

Duplicating threads more or less at the same time drives the helpers here nuts – I’ll merge them for you.