[help] freezing on start up, how can i fix it ?

my computer is dell xps 2720

(UEFI + GPT) Windows 8.1 + openSUSE 13.1

the BOOT Secure is Disabled

when i start up my computer, after the grub2, sometimes it displays the following picture, what is the problem? how can i fix it ? thank you for you help!!!

Seems to be a problem with the nouveau graphics driver.
I would suggest to install the proprietary nvidia driver, see here: http://en.opensuse.org/SDB:NVIDIA_drivers

What exact graphics card/chipset do you have?

/sbin/lspci -nn | grep VGA

thank you for your suggestion, i have installed the graphic driver, and there is no freezing happened during the start up in my three times’ test ! it means a lot for me, thank you !

but another problems arises …
here is my graphic chipsets:
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev a1)
i installed VirtualBox in my computer, after updating the graphic driver, the 3D Acceleration became invalid:O:O:O strange thing!

ps: when i installed the opensuse13.1, i set my four virtual desktop switch in cube mode, several days later, its amazing switch disappeared, i suppose it would come back after the NVIDIA dirver installed, but it makes me down

all the way, it is enought for me that the computer can start up into suse rightly

As far as I know
Windows 8 with GPT, must have EFI secure boot enabled

Your hybrid graphics is the problem in openSUSE, but not unsolvable

If this is an Optimus system (i.e. switchable hybrid intel+nvidia graphics) you can not use the nvidia driver and should not have it installed.
On such a system, the intel chip is used normally, but installing the nvidia driver breaks the intel driver’s 3D part.
Installing the nvidia driver fixed your problem none-the-less even in that case, as it prevents the nouveau kernel module from being loaded (and that caused the crashes/freezes in your case).

Can you please post the file /var/log/Xorg.0.log? (upload it to http://susepaste.org or similar and post a link)
This should show in any case what’s going wrong.

If this is indeed an Optimus system, you could have a look in the BIOS settings whether you can turn off the intel graphics, the nvidia driver should work then (with full 3D support).

If that’s not possible, you would have to uninstall the nvidia driver again and use Bumblebee instead.

But let’s have a look at the Xorg log first…

here is the Xorg.0.log, thank you for your attention!


Ok, as suspected. The intel graphics and intel driver is in use.

If you want to only use the nvidia GPU, have a look into the BIOS settings whether you can turn off the intel chip.
The nvidia driver should just work then. (but this is not possible on all optimus systems)

Otherwise you should uninstall the nvidia driver again, i.e. remove those packages with “nvidia” in their name in YaST f.e.:
nvidia-gfxG03-kmp-xxx, nvidia-uvm-gfxG03-kmp-xxx (where xxx can be desktop or default f.e.), nvidia-computeG03, nvidia-glG03, x11-video-nvidiaG03

In that case you could install Bumblebee to switch between intel and nvidia and use the nvidia driver from there. I cannot really help with that, but here’s a link: http://en.opensuse.org/SDB:NVIDIA_Bumblebee

Or, if you are fine with just using the intel, you could try to switch off the nvidia card in the BIOS settings.
If that’s not possible prevent the nouveau driver from being loaded by creating a file in /etc/modprobe.d/ with the following content:

blacklist nouveau

Or add “brokenmodules=nouveau” to the kernel boot options (in YaST->System->Boot Loader->Boot Loader Options f.e., “Optional kernel parameter”)

the secure boot must be disabled, otherwise there will be the signature error even if the openSUSE is in ‘secure boot’ mode!
at first Windows 8 says the secure boot is not configured correctly,but after some time, it did not say something any more!
now it works very well !

i’m very appreciate your attention, i followed your suggestion, uninstall the nvidia driver and add the “brokenmodules=nouveau”, but it still freezes in the opensuse picture,
the way you recommended installing Bumblebee should be the best way, but there is another thing have to be done, so put this down for a moment
now i install the nvidia drive, you did not suppose that, but it guarantees that the openSUSE is available for me at least, forgive me to be a weaker, i will come back to defeat it, but now!

Hm, this should work I think.

Ok, I would suggest this then:
Leave the nvidia driver installed and only uninstall the package “nvidia-glG03”. You should have working 3D acceleration with the intel driver then, so this might be a (easy) solution as well. You could even use CUDA on the nvidia card that way. (that’s why the driver is split up in several packages)

i think that there should be something wrong that i have done:shame:, for example, the following screenshot implies that

Did you try to install Bumblebee now?
This doesn’t work with the standard nvidia driver packages AFAIK. you would have to install the “nvidia-bumblebee” instead.

Please remove those packages, as they are wrong in any case:
nvidia-gfxG01-kmp-default, nvidia-gfxG03-kmp-pae, x11-video-nvidiaG01. And also kernel-default and kernel-pae that might be installed now.

If you want to “use” the standard nvidia driver, install nvidia-gfxG03-kmp-desktop (but I guess you would to add the nvidia repo again, it looks as if you removed it), and remove bumblebee.

For using Bumblebee, you would have to remove x11-video-nvidiaG03, nvidia-computeG03, and nvidia-uvm-gfxG03-kmp-desktop as well, and install nvidia-bumblebee instead. (I think. As I said I have no experience with Bumblebee.)
EDIT: apparently you can either use the standard nvidia-driver or nvidia-bumblebee. So either add the nvidia repo again, and install nvidia-gfxG03-kmp-desktop and nvidia-glG03, or do what I said in the last sentence, i.e. remove the rest of nvidia’s packages and install nvidia-bumblebee.
And follow that link I gave you.
But I spotted an error there: you should not call “useradd -G video,bumblebee username” (this would create a new user), but “usermod -a -G video,bumblebee username” instead to modify your existing user.

Thank you for your great help! now i have solved this problem! i think i should share my experience for every mates on optimus system!
this is the webpage you recommended : http://en.opensuse.org/SDB:NVIDIA_Bumblebee
and based on it, i found a content-rich and detailed page here : https://zh.opensuse.org/SDB:Bumblebee it said the bumblebee is a relay project waiting for the support of kernel and driver from official and the effect of bumblebee is not impressive. so i tried once and dropped it.

i know that you may not believe i said, but it is truth. my computer is DELL XPS 2720, CPU is i5 4440s. 1T + 32G SSD, no doubt it is a optimus system. after reinstalling the openSUSE13.1 on it ( it is not a easy thing! ), i followed this http://en.opensuse.org/SDB:NVIDIA_drivers and typed command line for installing the NVIDIA driver , the terminal told me something( sorry, i forget ) is not installed successfully, and now it won’t hang there any more when start up !

ps1: my computer will hang when install the linux, e.g. opensuse, ubuntu, centos, linuxmint
ps2: it can not use the CUDA, but it have supported the 3D Acceleration, a magical thing
ps3: i will pleased if there is anything i can do and provide for improving openSUSE

It is a trade off of you want performance you use the NVIDIA if you want to conserve battery use the Intel with lower performance But you really can not use both at the same time. So it is a choice. The problem is that NVIDIA uses a custom mesa and thus incompatible with the Intel. Unless you use the bumblebee version of the NVIDIA driver

i’m sorry if some of my words sounds offensive, i‘m always respecting the developers on bumblebee project, they are selfless and respected. and i feel the same when Linus said that : “NVIDIA has been the single worst company we’ve every dealt with. So, NVIDIA, f**k you!”

so the only thing i want to “performance” is that my computer is running opensuse well, he will not hang me, even thought i don’t know what happened when i install the NVIDIA driver, but i’m sure that the driver is not installed completely.

at last, if someone have the same problem, you can
A. the best way is installing the Bumblebee
B. use the intel chips only
C. as to my solution, it works, you can try but not recommended

a) follow instructions here exactly first remove any NVIDIA drivers you may have already installed

b) maybe a setting in the BIOS to turn the chips off/on Really just depends on th hardware and what is provided in the BIOS. Remove any NVIDIA driver and possibly black list nouveau

It is really best to use bumblebee since without it the NVIDIA chip may run, even if unused and lower battery life