Help find a setting on LEAP 42.2

Had an awful time updating from 42.1 to 42.2 using zypper dup. Eventually, I gave up because my system was left unusable and did a network install. It worked nearly unattended and 42.2 is humming right along. :slight_smile: One thing I would like to change is the lock out after a period of inactivity. My computer is in my home and no one but me touches it. I rarely shut it off since I run a boinc research project in the background. However, after a period of time and I don’t know how long that is, I have to re-enter my password to continue.

I can’t find a setting to alter this. I checked yast security and desktop settings for display. If this was a laptop, or an office computer, I wouldn’t mind. But, at home, its an annoyance

Which DE are you using?

KDE. Plasma 5. Standard theme.

Seems weird that you were unable to update 42.1 to 42.2 properly, at least a fresh install works well :slight_smile:

Are you referring to the lock screen appearing after about five minutes or so?

If so, go to System Settings (not YaST, the other one) -> Desktop Behaviour -> Screen Locking and uncheck the “Lock screen automatically after:” checkbox.

Thanks. I looked elsewhere and couldn’t find it.

When I tried using zypper dup, I got messages that I was out of disk space. It seemed odd to me and no matter what I deleted to make room, I kept getting that message and then the effects of a partial upgrade began to appear. Each reboot made it worse. I finally gave up and used a CD install. I choose the upgrade method to save my home stuff. I had to enter a minimal amount of info and the install went fast and automatically. I was called away and when I came back, I had a new system! There have been none of the problems posted elsewhere. But, I didn’t realize how many customizations I had done over time that have to be redone. That gives me a chance to try something fresh and new.

If you use BTRFS and have snapper an and a root partition less then 40 gig you can easily run out of space. Solution clean out some snapshots

Where is the snapshot setting? Last time I looked, I had it set low. That was before the upgrade and I forget what the setting should be. Did you look at my avatar?

The config file is /etc/snapper/configs/root (look at the number section), manually run the cronjobs;


Try this:

Create a script file and give it a meaningfull name, such as noblankscreen & save it in /bin

Use this as the content:

    xset dpms 0 0 0
    xset -dpms
    xset s noblank

Set the permissions rwxr-xr-x

Set it as a login script for each user you want to disable screen blanking on. (In your case, just you.)

Log out, log back in.

Check to see that it all worked by opening a terminal and typing:

xset q

It should give output something similar to the following lines:

Screen Saver:
  prefer blanking:  no    allow exposures:  yes

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled


I am not running Leap, yet.

The above script has worked well from v12.1 through v13.2, though, and I see no obvious reason why it would not work in Leap.

The return key worked and got the space key back!

I looked at the config file and don’t want to mess it up. What setting should I change?

# subvolume to snapshot

# filesystem type

# btrfs qgroup for space aware cleanup algorithms

# fraction of the filesystems space the snapshots may use

# users and groups allowed to work with config

# sync users and groups from ALLOW_USERS and ALLOW_GROUPS to .snapshots
# directory

# start comparing pre- and post-snapshot in background after creating
# post-snapshot

# run daily number cleanup

# limit for number cleanup

# create hourly snapshots

# cleanup hourly snapshots after some time

# limits for timeline cleanup

# cleanup empty pre-post-pairs

# limits for empty pre-post-pair cleanup

LOL, think it’s your browser… See

Change this section;

 # limit for number cleanup

to say


See how that goes, but may need to tweak to your requirements.

Done. Thank you.