Help connecting to internet using ZTE MF190U USB Modem in OpenSUSE 13.1

Hello, everyone!! This is my first post here. I am an absolute newbie to linux though I am a power user in the Windows environment. I connect to the internet using a ZTE MF190U USB Modem which worked fine in Windows. But as I can see, using it in OpenSUSE is not very easy. When I connect it, OpenSUSE detects it as a CD and not as a USB modem. Can anyone please explain me how to use my modem in OpenSUSE in a step-by-step (beginner friendly) way. Please keep one thing in mind that I have access to the Internet only through my Windows installation (My computer has a dual-boot setup). So, in case I have to download anything, please provide a link to the installer (if at all installers like .msi, .exe etc exist in linux too). Thanks. :slight_smile:

When I run into stuff like what you describe, one of the first things I do is search for anything that might exist on the ARCH LINUX wiki, almost everything published there applies to <all> Linux although anything related to packaging would be specific to them and not apply to openSUSE.


Looks like the article describes what you are encountering exactly.


Thanks for answering tsu2,

Following are the results from the commands which are mentioned in

linux-aeqc:/home/username #  dmesg | tail
 6771.713295] usb 3-2: GSM modem (1-port) converter now attached to ttyUSB3
 6771.743157] systemd-udevd[2144]: renamed network interface wwan0 to wwp0s20u2i4
 6772.637950] scsi 7:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2
 6772.638126] scsi 7:0:0:0: Attached scsi generic sg1 type 5
 6772.638695] scsi 7:0:0:1: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
 6772.638875] sd 7:0:0:1: Attached scsi generic sg2 type 0
 6772.641447] sd 7:0:0:1: [sdb] Attached SCSI removable disk
 6772.642855] sr0: scsi-1 drive
 6772.642864] cdrom: Uniform CD-ROM driver Revision: 3.20
 6772.643255] sr 7:0:0:0: Attached scsi CD-ROM sr0
linux-aeqc:/home/username # lsusb | grep -i zte
Bus 003 Device 005: ID 19d2:**1254** ZTE WCDMA Technologies MSM

As you can see, 1254 is shown in place fo 0150.

Also, I’ve found that wvdial is not pre-installed in my OpenSUSE. So, I downloaded the .rpm with windows and tried to install it but it shows the error. is needed by wvdial-1.61-2.1.2.x86_64 is needed by wvdial-1.61-2.1.2.x86_64 is needed by wvdial-1.61-2.1.2.x86_64 is needed by wvdial-1.61-2.1.2.x86_64

But I could not find these packages in

What do I do now ? Please help.

I have a similar mobile broadband device (which works out of the box). When you first plug it in, you’ll find ‘lsusb’ will report a different chipset. After a few seconds, usb-modeswitch will do it’s job, and the modem device is initialised. Based on the dmesg output, your device is ready to go. In particular, there are a number of /dev/ttyUSB* nodes reported, which is a good sign to proceed with configuration via the network manager.

If you choose to, you can install wvdial from the standard repos

zypper in wvdial

There are a number of steps to getting it working as a regular user. I have used it in the past, but quite frankly, a GUI dialler such as ‘qinternet’ (KDE) is easier to configure and use if necessary.

Finally, I managed to install those requirements by installing the wvstreams package. But running wvdial doesn’t help. It is not able to connect using my modem.

Read my last post re network manager. If you really want to persist with wvdial however, I can help with that tomorrow. (Late here NZ time.)

The ID 19d2:1254 is likely relatively unimportant but to keep in mind. That is the way a device is identified, the number before the colon is the manufacturer and the number after is the specific device. Your number is different because it’s likely a later release than the device described in the Arch Wiki, but it normally should be sufficient for the device to be properly identified. Sometimes though, you may need to make or modify init.d configuratons, and to do so will require this number.

When you’re looking for files, they’ll hopefully be included as dependencies if you run the main package, in this case wvdial but it requires an active network connection. From Windows, you might be able to download the files only from Download openSUSE 13.1 (search for each file)

If you have another openSUSE machine which with Internet Access, you can download the packages, then “sneakernet” the files to your new machine. Although the following command downloads the file only, if the machine isn’t running 13.1 you may need to specify the 13.1 repo (-- from)

zypper --download-only <file1><file2>

In any case, as Deano says, wvdial is only one dialing app and if you choose to use a different network connections manager, these files would not be needed.