Help.. complex environment, internet slow and Iffy..

Hi all

I have a desktop and a linksys cisco bridge connected to a WEP wireless network. It turns out slow and iffy… for example, the download of a file using wget -c … always stalls at 32%, when the speed simply disappears; and it takes forever to wait.
by ifconfig:
eth0 Link encap:Ethernet HWaddr 00:1A:4D:55:1B:5F
inet addr:192.168.0.24 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21a:4dff:fe55:1b5f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:59168 errors:0 dropped:0 overruns:0 frame:0
TX packets:50780 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:73911588 (70.4 Mb) TX bytes:7092112 (6.7 Mb)
Interrupt:219 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:640 (640.0 b) TX bytes:640 (640.0 b)

Could you tell me where is wrong?

Thank you!

why can’t I edit more than once?

On Mon, 09 Nov 2009 09:26:01 +0000, paulga wrote:

> why can’t I edit more than once?

All edits have to be done within 10 minutes - once 10 minutes passes, the
post is passed through the NNTP gateway and edits are then disabled.

(Don’t know the answer to your original question, but this one I know.)

Jim


Jim Henderson
openSUSE Forums Moderator

Start yast and - in the network devices menu - disable IPv6. This may help and does no harm.

1.have you turned off IPv6?

2.have you investigated changing your txqueuelen and/or MTU?

3.are you sure the net connection is strong/reliable?
-are you behind a firewall you don’t control?
-is it possible ‘someone’ [even the ISP] is throttling your line)
-are you on a school campus?
-what do you get at (for example) http://www.speedtest.net/

4.wget
-does it always stall at 32% even from different sources?
-what does 32% equal in size
–that is, what is the size of the file you are trying to download?
–does the stall happen at 32% of 1 MG and 32% of 10 GB?
–crazy: do you have hard drive space for the download to complete?
-have you tried using YaST to un- and re-install wget?
-can you determine where the stall is, your net or the sending host?

ps: there are things i can discuss/direct/trouble shoot with some
authority, but networking is not one of them…i hope for you a real
guru drops in and helps…that said, think one or more of the Qs above
might get you started…if you are willing to use
http://www.google.com/linux
and/or
http://forums.opensuse.org/search.php)


palladium
Have a lot of fun…

You may need to disable TCP window scaling as some broken routers have problems with it. As root on console:

sysctl -w net.ipv4.tcp_window_scaling=0

to make it permanent, open /etc/sysctl.conf and add below line

net.ipv4.tcp_window_scaling = 0

Thank you.
I haven’t been able to tweak my linksys cisco bridge becoz I don’t know its ip address.
I’ll try your advice anyway.
but fact is I share the network with three other guys, who love using p2p software like bitcomet…
so after they went sleep last night(their computer shut down) I tried again. this time there is no problem at all. everything was fine. so my linksys cisco bridge always yield for p2p appeals… :X
to palladium:

the network is in an apartment so quite strong.
i’ll try speedtest.net later. that file was about 25M. when the download begins the speed is normal. then it gradually drops until disppears. then minutes later it comes back, roars, then diminishes again… it took 40minutes to complete.
of course when there’s only one person using the network, the speed remains reliable, roaring up to 300kbps, with a lowest value 120kbps.
maybe the bridge need tweak, but I don’t know where…

There are things you can do:

Talk to the guys; they can limit the up- and download speeds of their p2p program to at least a couple of 100 kB/sec from max. Unless they do so, the impact of what they do on the network will always be tremendous. And it regards up- as well as download, since others download from the other guys’ computer.

To find out the IP of your router, open a terminal window and do:
su -c ‘route -n’
Enter rootpassword, and you’ll see something like this:


Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan1
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 wlan1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan1

In this case the address of the router (linksys btw) is 192.168.1.1
But you will need a username and password to enter it. Depending on model and firmware you could find a solution in the configuration of the router.

Good luck.

Thanks Knurpht! I’ll have a negociate ~
I’m totoally unaware the point of turning off ipv6. but I’ll read and try all suggestions.

thank you. but that ip address in my case takes to the main router (motorola) to which my linksys bridge connects. The bridge itself gets an ip from motorola router through dhcp.
my ethernet card connecting to the bridge should get another ip address from the bridge, which acts like a router.