Help changing displays?

Running v13.1x64, KDE, Graphics = AMD Radeon HD 7500 Series . I’ve been using a 20" flatscreen and have replaced it with a 22" TV w/ PC capability.

The max resolution of the 20" is 1680x1050, connecting with a DVI plug. The 22" has a max resolution of 1920x1080 connecting with an HDMI plug.

When I plug in the 22" the “desktop area” expands so that I loose the tray at bottom of screen and the plasma icon in the upper right. I have the AMD Catalyst installed and when it is set to the max resolution it also shows the same resolution for the desktop area. Also the highest resolution is the “preferred setting” on the Catalyst application. It is also set to auto detect. Currently, I have reduced the resolution to the original 1680x1050.

The 22" displays fine at my original resolution of 1680x1050 so I figure there must be a setting buried somewhere in system settings that I am overlooking.

A screenshot of my normal resolution desktop is at http://susepaste.org/5330116. What I lose when I change resolution using either the Catalyst or the System Settings Display Configuration utility is about 1/2" at top & bottom, cutting off the task manager and at the bottom & the Plasma Toolbox icon in the upper right. I didn’t determine if I lose anything on the right & left edges.

What do I need to do to “shrink” the desktop display so that it does not overflow the screen?

Secondly, the 22" screen appears a bit washed out compared to the 20" monitor. Is that because of HDMI vs DVI, or is it just that this monitor is really a TV and not a computer monitor, or maybe just my eyes not used to the change yet?

Thanks, jon

Your TV is likely rescaling the image internally, and adjusting the image by cropping. (One reason why I dislike the use of TV’s as a monitor.) It is not an openSUSE issue, but rather a display issue. Maybe you can prevent this behaviour by adjusting a setting inthe TV menu?

Reminds me of this old thread…

https://forums.opensuse.org/showthread.php/498399-Television-as-display-and-resolution-problem

Deano:

Thanks for link to old thread. First off, I checked that I have the latest fglrx installed.

In my Xorg.log I have:

    22.920] (II) fglrx(0): Connected Display0: DFP1
    22.920] (II) fglrx(0): Display0 EDID data ---------------------------
    22.920] (II) fglrx(0): Manufacturer: SAM  Model: 710  Serial#: 0
    22.920] (II) fglrx(0): Year: 2010  Week: 11
    22.920] (II) fglrx(0): EDID Version: 1.3
    22.920] (II) fglrx(0): Digital Display Input
    22.920] (II) fglrx(0): Max Image Size [cm]: horiz.: 51  vert.: 29
    22.920] (II) fglrx(0): Gamma: 2.20
    22.920] (II) fglrx(0): No DPMS capabilities specified
    22.920] (II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
    22.920] (II) fglrx(0): First detailed timing is preferred mode
    22.920] (II) fglrx(0): redX: 0.640 redY: 0.330   greenX: 0.300 greenY: 0.600
    22.920] (II) fglrx(0): blueX: 0.150 blueY: 0.060   whiteX: 0.312 whiteY: 0.329
    22.920] (II) fglrx(0): Supported established timings:
    22.920] (II) fglrx(0): 720x400@70Hz
    22.920] (II) fglrx(0): 640x480@60Hz
    22.920] (II) fglrx(0): 640x480@67Hz
    22.920] (II) fglrx(0): 640x480@72Hz
    22.920] (II) fglrx(0): 640x480@75Hz
    22.920] (II) fglrx(0): 800x600@56Hz
    22.920] (II) fglrx(0): 800x600@60Hz
    22.920] (II) fglrx(0): 800x600@72Hz
    22.920] (II) fglrx(0): 800x600@75Hz
    22.920] (II) fglrx(0): 832x624@75Hz
    22.920] (II) fglrx(0): 1024x768@60Hz
    22.920] (II) fglrx(0): 1024x768@70Hz
    22.920] (II) fglrx(0): 1024x768@75Hz
    22.920] (II) fglrx(0): 1280x1024@75Hz
    22.920] (II) fglrx(0): 1152x864@75Hz
    22.920] (II) fglrx(0): Manufacturer's mask: 0
    22.920] (II) fglrx(0): Supported standard timings:
    22.920] (II) fglrx(0): #0: hsize: 1280  vsize 800  refresh: 60  vid: 129
    22.920] (II) fglrx(0): #1: hsize: 1440  vsize 900  refresh: 60  vid: 149
    22.920] (II) fglrx(0): #2: hsize: 1440  vsize 900  refresh: 75  vid: 3989
    22.920] (II) fglrx(0): #3: hsize: 1680  vsize 1050  refresh: 60  vid: 179
    22.920] (II) fglrx(0): #4: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
    22.920] (II) fglrx(0): #5: hsize: 1152  vsize 864  refresh: 75  vid: 20337
    22.920] (II) fglrx(0): #6: hsize: 1280  vsize 960  refresh: 60  vid: 16513

This seems that fglrx doesn’t support a higher resolution even though Catalyst shows it as a preferred setting, & the manual shows it as max resolution.

Further into that file is;

    22.921] (II) fglrx(0): User Preference Output DFP1 using refresh rate 60.0 Hz.
    22.921] (II) fglrx(0): Printing probed modes for output DFP1
    22.921] (II) fglrx(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz UeP)
    22.921] (II) fglrx(0): Modeline "1920x1080"x60.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz eP)
    22.921] (II) fglrx(0): Modeline "1920x1080"x59.9  148.35  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.4 kHz e)
    22.921] (II) fglrx(0): Modeline "1920x1080"x60.0   74.25  1920 2008 2052 2200  1080 1085 1095 1125 interlace +hsync +vsync (33.8 kHz e)
    22.921] (II) fglrx(0): Modeline "1920x1080"x30.0   74.25  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (33.8 kHz e)
    22.921] (II) fglrx(0): Modeline "1920x1080"x59.9   74.18  1920 2008 2052 2200  1080 1085 1095 1125 interlace +hsync +vsync (33.7 kHz e)
    22.921] (II) fglrx(0): Modeline "1920x1080"x30.0   74.18  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (33.7 kHz e)

And this:

    22.922] (II) fglrx(0): Output DFP1 connected
    22.922] (II) fglrx(0): Output DFP2 disconnected
    22.922] (II) fglrx(0): Output CRT1 disconnected
    22.922] (II) fglrx(0): Using user preference for initial modes
    22.922] (II) fglrx(0): Output DFP1 using initial mode 1680x1050
    22.922] (II) fglrx(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
    22.922] (II) fglrx(0): Display dimensions: (510, 290) mm
    22.922] (II) fglrx(0): DPI set to (83, 91)
    22.922] (II) fglrx(0): Eyefinity capable adapter detected.
    22.922] (II) fglrx(0): Adapter AMD Radeon HD 7500 Series has 6 configurable heads and 1 displays connected.

It seems to me that I should be able to get a higher resolution, is that how you see it from the above snippets?

Thanks, jon

I’m not sure if I follow you clearly. I understood that your question was was about the 22" display image being cropped when using 1920x1080 (16:9 aspect ratio). You really need to refer to the TV manual to investigate that behaviour further. What brand/model?

You are correct in your understanding of my issue.
In the code above from xlog.0 it is “Samsung Model 710”.
The manual is “LCD TV Monitor SyncMaster B2230HD”. The manual has max & optimal resolution of 1920x1080 @ 60hz.

As near as I am able to determine, I have the TV settings correct but apparently I am mistaken.

What puzzles me is the log supported timings does not have anything above 1280x1024 yet it also shows probes supporting much higher resolutions.

And Catalyst & also Desktop Settings allow the max of 1920x1080 @ 60hz but selecting this crops the ‘desktop area’.

Jon

What puzzles me is the log supported timings does not have anything above 1280x1024 yet it also shows probes supporting much higher resolutions.

Well, it’s the probed (EDID) display modes that are most relevant, and that’s what allows you to select the appropriate display mode.

And Catalyst & also Desktop Settings allow the max of 1920x1080 @ 60hz but selecting this crops the ‘desktop area’.

Jon

Yep, and that is down to the TV, not openSUSE/X-server, or the graphics hardware.

I don’t have AMD hardware, so can’t check myself, but does the Linux version of Catalyst Control Center allow you to adjust for this?

http://www.justin.my/2011/12/cannot-display-full-screen-using-ati-amd-radeon/

OK, I guess I’ll live with the resolution as it is. The TV does not have a specific way to change the resolution that I have found.

Thanks, Jon

The resolution list comes from the TV ie supported resolutions. Sometime the monitor/TV does not report sensible information so you have to force things. You can add in the xorg.conf files a mode line for the missing resolution. Do a Google search for “xorg mode line” it will explain it and there are on line calculators to produce them.

Yes, but that is not what the OP is having an issue with. When the display’s highest resolution (1920x1080) is invoked, there is cropping of the image evident.

Well then got to be a setting on the TV. Or it is lieing about it’s resolution

Deano:

Thanks for this link, even though it appears to be Windows it pushed me to look further.

It was a 2 step process for me. In case others are looking for a solution:

In the Catalyst Display Manager I first had to select ‘Adjustments’ and then check ‘Use scaling value override’

Then I went to Display Manager Properties and changed the resolution to 1920x1080

When I applied the setting, the desktop area adjusted itself.

I haven’t gone through a restart to verify all is well but this seems to have fixed my problem.

I looked at my xorg.conf and it currently contains the 1920x1080 line.

Thanks everyone for the tips.

jon

Yes, I couldn’t find a graphical Linux reference, but was hoping that it might still be similar in its functionality etc

It was a 2 step process for me. In case others are looking for a solution:

In the Catalyst Display Manager I first had to select ‘Adjustments’ and then check ‘Use scaling value override’

Then I went to Display Manager Properties and changed the resolution to 1920x1080

When I applied the setting, the desktop area adjusted itself.

I haven’t gone through a restart to verify all is well but this seems to have fixed my problem.

I looked at my xorg.conf and it currently contains the 1920x1080 line.

Thanks everyone for the tips.

Glad to have been of help. :slight_smile:

For others who come searching, the following graphical guide might also be useful

https://delightlylinux.wordpress.com/2012/12/12/catalyst-hdmi-black-border/

There’s also a bit about making changes persistent with

he problem is that Catalyst forgets this setting upon the next reboot and requires that you manually adjust it again and again to get a proper picture. Adjusting other settings, such as the Image Options or vertical refresh rate, have no effect either. Catalyst stubbornly refuses to remember the current settings. There is a command line solution as discovered on this link. It also works in Ubuntu 10.10, and it is repeated here for convenience.
Open a terminal and enter a single line,
sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 Reboot the computer, and the HDMI image fills the screen properly without any black borders.

OK, just rebooted and am confirming that the change is not persistent. I’ll go through the steps indicated to see if I can make it persistent.

Another issue the resolution change caused is that my colors now seem (for lack of a better description) to be ‘electrified’. I can play with the various controls for hue/saturation/contrast but I’m not going to go there.

It appears that if I boot with 1680x1050, then make the change in resolution and set the borders it looks ok. But if I leave it at the higher resolution and boot I have to fix the border but loose the color quality (electrified appearance). And going back to 1680 w/o rebooting does not fix the color problem.

I’ll report back after I try the cmdline suggestion at the above link.

jon

I can confirm that the commandline posted above does correct the persistance problem. The link to the wordpress article was for the opposite problem I had, that post was for a border around the desktop area, my problem was for the desktop area being expanded to outside the edges of the screen.

I ran the command and then I had to underscan (rather than overscan) the scaling but it does maintain it’s scale through a reboot. When I ran that command it returned:

# aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
Set key MCIL,DigitalHDTVDefaultUnderscan

I don’t see that ‘key’ in xorg.conf nor can I find it in anywhere that I’ve looked. Where would this value be stored?

I still have a problem at this resolution with the coloring. When I started tweaking Catalyst it was using 30hz refresh. I changed it to 60hz (the only other choice) and I got an improvement. Looking at xorg.0.log there is reference to 75hz

  8292.651] (II) fglrx(0): Monitor name: SMB2330HD
  8292.651] (II) fglrx(0): Supported detailed timing:
  8292.651] (II) fglrx(0): clock: 74.2 MHz   Image Size:  510 x 290 mm
  8292.651] (II) fglrx(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
  8292.651] (II) fglrx(0): v_active: 540  v_sync: 542  v_sync_end 547 v_blanking: 562 v_border: 0

I’d like to know if I should change the xorg.conf where the targetrefresh is 60. Or is that potentially playing with fire?

On susepaste http://susepaste.org/48272842I posted a screenshot of part of my desktop to show what I meant with an earlier comment about ‘electrified’ images. The screenshot doesn’t quite show it as bad as I see it but if you look at the menubar on the browser and the text shown on gapcmon you can see how poor it is rendered with a smearing of the background between letters and words. And the blue color of the folders is much more intense.

If I cannot resolve this poor display appearance I’ll have to revert back to a lower resolution.

Any ideas?

thanks, jon

I don’t see that ‘key’ in xorg.conf nor can I find it in anywhere that I’ve looked. Where would this value be stored?

It writes to /etc/ati/amdpcsdb

On susepaste http://susepaste.org/48272842I posted a screenshot of part of my desktop to show what I meant with an earlier comment about ‘electrified’ images. The screenshot doesn’t quite show it as bad as I see it but if you look at the menubar on the browser and the text shown on gapcmon you can see how poor it is rendered with a smearing of the background between letters and words. And the blue color of the folders is much more intense.

Are you able to improve the display output by adjusting the color settings? If anything, the image looks a bit saturated to me.

I have little patience for that sort of thing because I don’t know which control to adjust. Saturation control certainly is not the one. Contrast has the most effect but it doesn’t seem to be the correct solution either. I could spend all night playing with the 4 sliders and may screw up something else.

I take it you don’t think much of forcing a refresh of 75. I’ve heard horror tales of pushing refresh rates and blowing out hardware so I am afraid to try it without guidance. Because the improvement from the original setting of 30 to 60 was so good is why I am interested in that possibility. The card spec’s are for up to 75. Ahhh, but the screen max is 60 so I guess I’m heading down the wrong path. It’s hard to keep all my marbles in the circle.

jon

Okay - your choice.

I take it you don’t think much of forcing a refresh of 75. I’ve heard horror tales of pushing refresh rates and blowing out hardware so I am afraid to try it without guidance.

No, you won’t damage the hardware - at worst it will result in no display. (Very old CRT displays could be impacted, but those days have long gone.) However, it is unlikely to help anyway, and the hardware has to be capable.

Because the improvement from the original setting of 30 to 60 was so good is why I am interested in that possibility. The card spec’s are for up to 75. Ahhh, but the screen max is 60 so I guess I’m heading down the wrong path. It’s hard to keep all my marbles in the circle.

jon

Ah, as I suspected.