Help! Audio not playing through Bluetooth speaker when connected.


I have been using Opensuse kde for nearly a year now and I must say I love it! It’s been a learning curve, but well worth it.

I can usually solve most problems myself, but I’m stuck this time. I’m running Suse12.2 and I’m trying to play through a Bluetooth speaker, but It’s just not working. I’ve tried pretty much everything I’ve found online ;
**Bluetooth Headset, connected, but sound plays thru speakers
****openSuSE 12.1, VoIP via Ekiga and a Bluetooth headset | Turning it off and on again
I’ve spend countless hours trying to figure this out and I’ve found no solution. I’ve disabled pulse audio. Installed and Re-installed Alsa and done all the suggested solutions in the previous posts.None seem to work. As a last resort I tried installing pulseaudio and all it’s components and it fails every time Bluetooth connects. Bluetooth in 12.1 worked well with pulseaudio, but I can’t believe how difficult It’s been to make this work. Here’s what I get when I open Phonon. I’ve tried switching everything to preferred and nothing is working.

If I’ve missed anything or you need more information please let me know. I’ve tested the speaker on Windows and I have no problems. If only support for devices was as easy on Linux I think it would be the perfect system. I guess Linux would change dramatically if that were true though.

Thanks in advance!

Can you please post the output of

aplay -l

(l) is small letter ‘L’


aplay -L

This is what I get.