help? anyone play world of warcraft

ok, I used wine to install the original warcraft and burning crusade ok, I hit a snag at lich king, I was advised to go into windows, copy all the dvd files to a folder, then move that folder to suse, run it there, that seemed to work perfectly, the game installed, the launcher did the updates, and then we could play

the intro cinematic plays where the king goes on about how good his son is, you press escape to get out of it, then the wowerror pops up wanting to know what I did when wow crashed.

so yes anyone else had this problem? and know the solution?

I’m already aware that codeweavers crossover games can run wow, but there were some annoying sound issues when I used that, if I must then I must but if anyone knows how to run lich king directly under wine I would be grateful to know how?

Intel(R) Core™2 Duo CPU E8500 @ 3.16GHz
Total memory (RAM): 3.2 GB
Free memory: 99.0 MB (+ 2.6 GB Caches)
Free swap: 2.0 GB
OS: Linux i686
System: openSUSE 11.1 (i586)
KDE: 4.1.3 (KDE 4.1.3) “release 4.9”
Display Info
Vendor: Mesa Project
Model: Software Rasterizer
Driver: 2.1 Mesa 7.2
sound card is soundblaster x-fi

Are you sure that you want to see this movie? :wink:
File: World of Warcraft/WTF/

SET movie "0"
SET expansionMovie "0"

hmm, there is no WTF folder?
there is

/home/user/.wine/drive_c/Program Files/World of Warcraft/WTF.20090323-160703


/home/user/.wine/drive_c/Program Files/World of Warcraft/WTF.20090323-173123

and none of them contain the file you described,

first one just contains, and, and both contain .directory, so 3 in the 1st and 1 in the 2nd.

could this be the cause of my problems?

Nono, that’s correct. You need to modify the given parameters in the

ok, I entered those settings into the runonce, but when I ran wow.exe, the cinematic still came up, I still escaped out, and the thing still crashed

Okay, you need to avoid the movie. If you have another, modify those files also.
After starting wow the parameters:

SET movie "0"
SET expansionMovie "0"

reseted or they still have 0 value?

ok, I created a WTF folder, copied and pasted the RunOnce.WTF file over with the code inside that you wrote.
and it did work it skipped the cinematic, now the wowerror comes up right away :slight_smile: no need to hit escape.

so yes still need help?
but it occured to me that maybe wine just installed the game all wrong, if I boot into my xp partition, install the game in there, then come back to suse, and use wine to run that wow.exe, might it have a better chance of working that way?

I’ve never installed WotLK to my opensuse. I did it just with BC, more than 5 time - without any problem. Try to reinstall it - I don’t have any idea.
Have you tried the -opengl option?

yeah ram88, wine had no trouble installing vanilla wow and burning crusade, it was at wrath of the lich kind dvd it fell down.
I had to copy all the files on the dvd to a folder on a windows partition, move that folder to linux, use wine to run the installer to get it to install.
but clearly it mustn’t have installed right.
so unless anyone knows of a way to get wine to run it from the DVD directly, I’m not seeing how I can play wrath on linux

well I tried the code weavers program, and it installed fine, had a little trouble mounting the wrath DVD but I managed to overcome that.
but when u run the game the frame rate is about 1 frame per 10 seconds.

sigh, does no one on suse play wrath of the lich king? can’t you just tell me what u did?


bump bump bump

I’m having the same kind of problem. but, i think mine is the built-in video card.(SIS650).

My other computer with WinXP home:( has a major problem which blizzard forums say is more than likely the Intel video drivers.
Check and see if you have the latest video drivers. if you do try an older driver see if that works. What i had to do just to be able to play the Lich KIng.

if you can get to the log-in screen go to options and put all video settings as low as they will go. myself I cant even get to the log-in screen, so i am going to try a new video card.

tried that alving, the game runs perfectly on my xp boot, when I got in with code weavers program I slowly made my way to the video settings inspite of 1 frame every 10 seconds
set everything to minimum, and didn’t help add 1 single frame.

Have you tried the regedit hacks listed on wowwiki?