Help\advice on RDP server solutions

I have Suse Leap 15.1 and seem to be banging my head against the wall and going round and round in circles trying to find any application or info on such applications to provide a remote desktop type server on my system.

I have previously run Team Viewer on SuSe 13.1 and that worked reasonably successfully - even detecting that I have 3 screens and displaying them all - however the one click TV install offering for Leap 15.1 throws errors on installation and although it does seem to continue to install I get the known issue of being infinitely stuck at ‘initialising display settings’ message when I try to connect in to it.

I have also tried X2Go server but once again the recommended version fails to even install.

I’ve had a go with VNC server which seems to be the only inbuilt offering in Leap - however whilst I can get it running and connect a VNC session I just get a small 800x600 black window with mouse cursor only…

Could anyone share any successful ‘working’ solutions for connecting to their Leap systems with a usable full screen display resolution on the client??
Or any links to fairly straightforward guides\ways to do this?

There seems to be a multitude of info on how to connect ‘from’ Leap to remote Windows PC’s using Remina, KRDC or Tiger VNC - but hardly anything on the other way round. Its almost as if the SuSe folk don’t really want people to be able to access their desktops from afar… :frowning:

Thanks in advance for any inspiration.

In the LEAP documentation for remote sessions, it describes

how you can specify or re-configure for different display resolutions (eg the Reminina section, last steps)

and configure non-default defaults (sections 4.3.1 and 4.3.3)

If still not working post what you tried and the specific documentation you tried to follow.

When I set up a VNC server but then use forwarding X over SSH, I can re-size the remote display by just dragging the edges of the console. I haven’t tried doing this on Windows, but I imagine any terminal client should behave the same way.


Thanks - but that mostly seems to relate to RDP ‘client’… I have no problem using the KRDC or Remina apps on Leap 15.1 to access ‘remote’ PC’s. What I want is the opposite - a way to set up something on LEAP15.1 so that I can access it from Windows PC\laptop…
I’ve tried following the steps to set up the VNC server and I can connect to it using TightVNC from a Windows Desktop, but after providing the password all I get is a small 800x600 black window. The mouse cursor is visible and moves but no desktop background display…

  1. Have you tried to connect using X over SSH? IMO it’s the easiest way to have a re-sizable display that fills the console window

2 If you really want to run VNC, you’ll have to describe which VNC client you’re using and if you’ve tried the Java client (using a web browser).


Thanks - yes after searching more online for ‘black screen only’ on SuSe VNC server it seems this is a common problem that can be an absolute nightmare to fix. All seems to be related to the new Plasma\KDE and whatever display manager is running with possibility of Nvida Gfx also impacting on it…

So I’ve binned the idea of a full VNC desktop - I’m 59 years old and probably dont have enough years left to waste on sorting it out :wink:

Really my main requirement is just to access my POP Kmail client graphically on the SuSE box while working remotely on a Windows PC\laptop - so X over SSH should do that nicely for me.

However… having installed Putty and Xming on a Windows PC, enabling SSH on the Leap box I can now login to it using SSH - but as soon as I try to run a graphical app ie type kmail in the windows terminal I get the following error:

login as: ***********
Keyboard-interactive authentication prompts from server:
| Password:
End of keyboard-interactive prompts from server
Last login: Sun Jun 16 13:07:11 2019 from
Have a lot of fun...
***********:~> ls
Barbosa.png  Downloads                       Pictures                Templates
bin            Public                  Videos
Desktop     Documents    Music      
***********~> kmail
qt.qpa.screen: QXcbConnection: Could not connect to display
Could not connect to any X display.

I followed the guide here: which seems to indicate it should_just_work… if only!

Any ideas where I go from here??

Some slight progress…

The log file in Xming on Windows didnt appear to contain much so I restarted and it then filled up with loads of info.

I was then able to Putty SSH in to Leap and I could type xclock and it duly opened up the xClock window - albeit with messages about font errors.

However typing kmail resulted in just a simple ‘couldnt find any display screen’ error.

Typing kontact though did actually briefly launch Kontact but it instantly crashed with the following output:

login as: ********
Keyboard-interactive authentication prompts from server:
| Password:
End of keyboard-interactive prompts from server
Last login: Sun Jun 16 13:47:52 2019 from ********
Have a lot of fun...
***********:~> xclock
Warning: Missing charsets in String to FontSet conversion
***********:~> kontact
failed to get the current screen resources
WARNING: Application calling GLX 1.3 function "glXCreatePbuffer" when GLX 1.3 is not supported!  This is an application bug!
[3220:3252:0616/141324.691560:ERROR:gl_surface_qt.cpp(241)] GLX 1.3 or later is required.
[3220:3252:0616/141324.691605:ERROR:gl_surface_qt.cpp(371)] GLContextHelper::getEGLDisplay() failed.
No text-to-speech plug-ins were found.
qt.qpa.xcb: QXcbConnection: XCB error: 170 (Unknown), sequence: 170, resource id: 90, major code: 146 (Unknown), minor code: 20
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
[3220:3252:0616/141326.211472:ERROR:gl_surface_qt.cpp(667)] Requested OpenGL implementation is not supported. Implementation: 0
*** stack smashing detected ***: <unknown> terminated
*** KMail got signal 6 (Exiting)
*** Dead letters dumped.
/tmp/messageviewer_attachment_q6Eb8p was removed .
/tmp/messageviewer_attachment_TEXsFU was removed .
QSocketNotifier: Invalid socket 7 and type 'Read', disabling...
QSocketNotifier: Invalid socket 63 and type 'Read', disabling...
QSocketNotifier: Invalid socket 66 and type 'Read', disabling...
QSocketNotifier: Invalid socket 76 and type 'Read', disabling...
QSocketNotifier: Invalid socket 68 and type 'Read', disabling...
KCrash: Application 'kontact' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
Warning: connect() failed: : No such file or directory
KCrash: Attempting to start /usr/lib64/libexec/drkonqi directly
failed to get the current screen resources
found lsb_release
Using /proc to determine executable path
Executable is: "/usr/bin/kontact"
Executable exists: true
Enabling drkonqi crash catching
Xlib:  extension "MIT-SCREEN-SAVER" missing on display "localhost:10.0".
qt.qpa.xcb: QXcbConnection: XCB error: 170 (Unknown), sequence: 170, resource id: 90, major code: 146 (Unknown), minor code: 20
Sending SIGSTOP to process

[1]+  Stopped                 kontact

For as long as the X11 SSH session remains open I then get continuous warnings on Leap that drkonki is crashing - until such point as I close the SHH connection on Windows client…

I’ve just discovered that TeamViewer have now released an updated installer for SuSe x64 which works like a charm. Fully detects all 3 of my displays and provides the perfect RDP solution with a workable full screen resolution!

Kind of annoying that we have to go to a 3rd party provider to find a simple working solution for a common place activity… would have thought by now that RDP server functionality would be built into the SuSe OS…

Thanks tsu2 for your input in trying to help.

Looks like the Linux project has an article how to set up Putty to enable X over ssh…