Help - 6-screens after installing nvidia driver 4 suse 11.1

im having an ASUS K501N series laptop that has a G102M GeForce NVIDIA graphic card.Im having a dual boot with windows XP and OpenSUSE 11.1.i have already installed the graphic driver to windows but dont really Know how to installed it in SUSE 11.1…so i came up to this forum topic and did as what was told:

Start the Software installer and make sure you have the pattern ‘Linux Kernel Development’ installed.

Open a terminal window and issue following commands:

mkdir NVIDIA-driver
cd NVIDIA-driver

Now logout of your desktop back to the login screen. At the graphic login screen, hit Ctrl-Alt-F1. This brings you to the console, with a text based login. Login with username and password. Now issue the following commands to install and configure the driver. You will be prompted for your rootpassword on all the ‘su -c’ commands. but that’s for your own security.

cd ~/NVIDIA-driver
su -c ‘init 3’
su -c ‘sh -q’

Everything was ok up till this stage but as i type in this:

su -c ‘cp /etc/X11/xorg.conf .’

the following error comes out:

cp: missing destination file operand after ‘/etc/X11/xorg.conf.’
Try ‘cp-- help’ for more information

then i tried manually copying the file to the nvidia folder…and tried the rest:

su -c ‘sax2 -r -m0=nvidia’
su -c ‘init 5 && exit’

nvidia was sucessfully installed but i now have 6 screen on my monitor…and through this forum i found out that adding

Option “ModeValidation” “NoTotalSizeCheck”

to the xorg.conf file might help…but my monitors stays the same with 6 screen…
for days i tried googling and forums…but nothing seems to be helpful…

if its helpful,my kernel information is:

gothu@linux-p6e8:~> uname -a
Linux linux-p6e8 #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux
gothu@linux-p6e8:~> rpm -qa | grep kernel

Plz be aware that im not linux literate…im just a newbie…plz help
Thank you…

Ok, the above is bad.

You have old kernels, new kernels, extra kernels, …

You have installed way too many kernel rpms. Which kernel do you intend to use? For example, on my 64-bit openSUSE-11.1, I use kernel-default. Hence All I have installed is:

oldcpu@hal1000:~> rpm -qa | grep kernel

If you decide to remove the unneeded kernel, pay very close attention to what this does to your computer’s /boot/grub/menu.lst file (you will need root permissions to open that file). I recommend you make a backup copy of that file first before you do anything (with root permissions) and then after you remove any unneeded kernel applications, immediately after the removal and before rebooting, compared the revised /boot/grub/menu.lst against the backed up /boot/grub/menu.lst and ensure the changes make sense.

Then after that is successful, you will need to re-build/re-install the proprietary graphic driver.

ok, i dont understand what you are asking me to do…backup copy of what file? how?
What kernel is important?
And how to compare the revised /boot/grub/ against the backup /boot/grub/

im a newbie…plz be detail?

Backup the /boot/grub/menu.lst file.

One way to do that backup, is (assuming your user name is “gothu”) is to type:

su -c 'cp /boot/grub/menu.lst /home/gothu/menu.lst'

and type root password when prompted for a password.

The kernel you intend to use is the one that is important. Preferably the version, which is the latest ? Or did you intend to update the pae kernel to but mistakenly installed the kernel-default for I don’t know. Only you have that information.

I gave you an example as to what I have on my PC that works.

But note if you pick the wrong kernel you “might” break your wireless, webcam, sound in addition to your graphics.

Open them in an editor and look at the difference ! Compare the difference Since you need root permissions to open the file, then

  • if using KDE you could type: kdesu ‘kwrite /boot/grub/menu.lst’
  • and if using Gnome you could type: gnomesu gedit /boot/grub/menu.lst
    but be VERY CAREFUL not to save any changes unless you know exactly what you are doing, as the wrong information there could destroy the capability of your PC to boot.

But since you have 6 screens, that could be difficult ! :slight_smile:

What you could do, in the mean time, is revert to an openGL or a vesa driver. Do that by rebooting, and when the very first boot screen comes up, press “3” to boot to run level 3. Then let the PC boot. It will come to an ascii/text login. Log in as user gothu (assuming that is your user name). Then type “su” to get root permissions. Then revert to a vesa driver by typing:
sax2 -r -m 0=nv
where that is zero equals nv.
Then restart with “shutdown -r now” and hopefully you will be back to an openGL driver.

If that does not work, then try:
sax2 -r -m 0=vesa
instead, where that is zero equals vesa

For example, here is my /boot/grub/menu.lst. Note mine is optimized for my PC and will NOT work on your PC. You need to use what you have.

# Modified by YaST2. Last modification on Fri Aug 21 18:57:52 CEST 2009
default 0
timeout 15
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST31500341AS_9VS14DG6-part2 resume=/dev/disk/by-id/ata-ST31500341AS_9VS14DG6-part3 splash=silent showopts vga=0x346
    initrd /boot/initrd-

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 -
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST31500341AS_9VS14DG6-part2 showopts ide=nodma apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x346
    initrd /boot/initrd-

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1

I think it might help for you to brush up on some basics? Here are some basic concepts Concepts - openSUSE

… a caution.

In Linux one DOES NOT BLINDLY INSTALL APPLICATIONS. One has to be careful and install judiciously.

Good luck!

How much time have you spent on your openSUSE?

If you just installed it, then it may be quicker for you to bite the bullet now and re-install. That will take a couple of hours.

For me to sort your mess in front of your PC might take 15-minutes. For you this could take days of post, counter-post, counter-post …

Re-installation is not the Linux way. You will learn more by trying to fix this. But your frustration levels may go thru the roof. It may be quicker for YOU to re-install, and then be very careful what you do. Seek advice each step of the way after a re-install BEFORE you do things.

If you do re-install, be CERTAIN you install on top of the old openSUSE and NOT install a 2nd version in addition to the first.

Better yet, do you have a knowledgeable Linux friend who can sit down beside you and hold your hand thru this?

No i dont have a friend that is knowledgeable in linux…wish i was your friend though! not that knowledgeble in linux in the sense that some words or phrase like, grub, kernel, and most of all the commands of linux…all my work on linux is always through googling…so i juz follow and learn along the way…as for changing to vesa…i have done it…and currently interchanging it with nvidia…i have to change it back to vesa to find solution for my nvidia…so it takes time to try out the solutions on nividia and and when it fails i have to install vesa back and find for solutions…thats y im asking for a detailed solution (i.e. linux commands)…

Back to my problem…
So through my kernel version…the graphic may show 6 screen?

and why is it im having this error:

cp: missing destination file operand after ‘/etc/X11/xorg.conf.’
Try ‘cp-- help’ for more information

after the command:

su -c ‘cp /etc/X11/xorg.conf’

What does this means?
What could have cause 6 screens??

This is a new user mistake in not understanding the syntax of the copy command, nor of root permissions.

When one copies a file, one must copy the file FROM a place, TO a place.

So to copy from file-a to file-b, the command would be:

cp file-a file-b 

In your example, you have forgotten to add the “TO” … for example,

su -c 'cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup'

would work.

Now, note the "su -c " at the start, and the single quotations around the remainder.

When you type “su” it means switch user. ie if you were to type: “su joe” you would switch user in this terminal (and only this terminal) from your current logged in user (say gothu) to user joe, assuming of course user joe had an account on your PC. You would also have to enter user joe’s password. Then any other commands in that terminal (and only that terminal) would have user joe permissions.

If you do not specify the user, but just type “su” by itself, then the command assumes you want administrator (ie root) permissions. And you will have to enter user root’s password. And any other commands in that terminal (and only that specific terminal), would be run with administrator (ie root) permissions. Once you close that terminal, then its done. No more root permissions in that terminal, as that terminal is closed. If instead of closing, you were to type “exit”, then it would log out of the last user in which you logged in (ie log out of user “joe”, or out of user ‘root’ ).

Now if you only wanted ONE command, and no others sent with root permissions, you could type the " -c " option after su. Then only the command that follows, is sent with the permission of the user to which you have switched in that line.

So by typing:

su -c 'cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup' 

you are saying with root permissions, for this command and only this command, copy the file xorg.conf to the new file xorg.conf.mybackup (in the directory /etc/X11).

Clear as mud?

I have a similar problem updating from new ubuntu.
But the bad thing is that I have the 6 screen already at BIOS stage… do you have the same problem ???

thank you oldcpu…i have solved my problem…its all good…thank you very much…