Help - 11.2 Starts to Boot then Blank Screen and nothing..

I have tried two distros - Mandriva and OpenSuse. Both provide the same results, though Mandriva booted…but still the same problem, after installing blank screen comes up and nothing. Keyboard touch bad, mouse nothing happens. Help: I would prefer openSuse but may have to switch.

Acer 7740 17" laptop
Intel i3-330M Chipset
4Gig DDR3 RAM 1066
Intel Integrated HD Video 128MB

Install Win7 64-Bit no issues, wiped and installed Linux and I cannot get past this blank screen. Installation works, no problem installed packages etc. When coming up on 1st boot, login - boom nothing? Searching the web and I suspect the Intel graphics are the problem but I’m not sure.

1st Newbie with Linux. I bought this laptop to put Linux on it solely for a personal project of using Linux for a year. I’m an IT professional for 23 years and comfortable with CLI.

Any information would be Great!

openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

I suspect the intel graphics too - see the intel section

trying to get to the CLI on the grub menu. No luck. Fail safe and regular with the options remove does the same darn thing - man is this frustrating.

What I have done (could be user error). Have to shut power off. GRUB menu shows two entries boot Suse or FailSafe. I have removed all of the command line options and put in the following:

and then I tried

init 3

in both the normal boot options and failsafe.

both produce a blank screen HAL starts and the screen goes blank.

Might want to try Fedora 12, I had pretty good luck with it and my Acer Aspire 7740, had to modprobe to get the Broadcom wired LAN to work and a few alterations to get “intel” driver to work in Xorg. Only problems I had, was no brightness control.

Trying to install OpenSUSE now, using the Gnome OpenSUSE LiveCD 10.2, and I have to chose the first option at startup with 3 in the boot options, root for user login, sax2 -r -m 0=vesa, init 5, then I can install via the Live Installer link on the desktop.

If you boot with just 3
You will be level 3

Next become su:

then: yast

First thank you for the replies…

I have tried 3 and it goes to the text mode looks good running through the installation process, then it gets to the darn Starting HAL Daemon…blank screen.

I have tried CTRL-ALT-F1 and nothing. I cannot even get to the command prompt to execute the commands.

Might want to try Fedora 12, I had pretty good luck with it and my Acer Aspire 7740, had to modprobe to get the Broadcom wired LAN to work and a few alterations to get “intel” driver to work in Xorg. Only problems I had, was no brightness control.

Trying to install OpenSUSE now, using the Gnome OpenSUSE LiveCD 11.2

  1. openSUSE Live (GNOME) - Boot Options 3
  2. linux login: root
  3. sax2 -r -m 0=vesa
  4. init 5

Install via the Live Installer link on the desktop, if you want to enable the tap function of the touchpad, computer, control center, mouse, touchpad, enable mouse clicks with touchpad. Not sure if this will work outright because I had previously install with change MBR option during the install process, though, this time I did not.

It doesn’t look like it’s going to work for you.
Have you tried 11.1? Gnome version

I have the 11.2 dvd, I will try that now, see what I can figure out.

How are you working your partitioning for this? You still going to use the Windows 7 and dual boot?

Thank you I will try these options and see if it works…

Which openSUSE 11.2 are you trying? Have you ran the Check Installation Media?

How far in the install process is it making it? Hmm, I think I just arrived where you are now, it finished install, least it closed out the process and started to load and got to the HAL and then went to black screen.

11.2 64 Bit version
KDE defaul Desktop

What you just described is where I am now

Man I hate to try something else I like SUSE…


No I wiped the whole machine I’m going to go full boat Linux…on the laptop. I took the default partioning, remember I’m a newbie and want to go Linux full time on this laptop. If that partioning is not right let me know. I updated the MBR as well based on other posts from a Google search - that didn’t change anything either.

I have a home built Win7 desktop machine that’s my beast i7-920, 8Gig, RAM dual 22" monitors…

Ok, seems for the DVD 11.2 installation to sort of work, at the initial boot screen, hit F3 and then change it to Text Mode, install as usual, it will reboot and continue with some updates, I think, then it will black screen again.

Hard boot
Desktop – openSUSE 11.2 Boot Options 3
sax2 -r -m 0=vesa
init 5

Least this is what has worked for me, I am going to mess around some more to see if I can come up with an easier way, because this is a bit rediculous.

OK I will try this as well. I agree kind of crazy, I would expect this for Beta.

So far the Boot Options 3 did not work…trying it now. Son is at soccer, so if there is a delay I will be back.
Thank you again for your assistance with this. I will keep you posted.

It is all because of the onboard video, too bad its quite troublesome to get around. I actually got past the black screen you first encountered by doing:

Boot Options single

added the following lines to xorg.conf:

To open xorg.conf in the editor, vi /etc/X11/xorg.conf insert key to start editing, when done entering data, hit escape key, the do :wq

Section “Device”
Identifier “Vesa-BIOS Driver”
Driver “vesa”

Then, init 5, and the installation continued

I did finally figure a way to get past the black screen, thing is, this is not even a complete install we are discussing here, it is getting the black screen on the 2nd part of the install.

If installed in text mode, you can still use 3 on the Boot Options to use sax2 to fix your xorg.conf so it will end up booting normally, with VESA driver.

If you try anything but the text mode, you can still recover from the black screen by using single on the Boot Options, but I ended up having to create a /etc/X11/xorg.conf with:

Section “Device”
Identifier “Vesa-BIOS Driver”
Driver “vesa”

Then do init 5 and then the rest of the installation would continue. Finishing up with sax2 to finish changes needed to xorg.conf

From what I have read, the Intel GMA HD Integrated graphics is not compatible with kernel versions older than the 2.6.33 kernel. My reference for this: Intel HD Graphics - ThinkWiki

Hence I recommend you wait until 22-April or 23-April (ie Thursday or Friday this week) and then download openSUSE-11.3 Milestone-6. Download the liveCD and try it. If that boots, then download the DVD.

Note Milestone-5 has problems, so you likely should avoid that.

Note openSUSE-11.2 only has the 2.6.31 kernel and at least 2.6.33 is needed. OpenSUSE-11.3 will have the 2.6.34 kernel.

It can be downloaded from here:

… again, WAIT until at least milestone-6.

Finally got “intel” driver working with 2.6.34-rc4-16-desktop kernel. Though it broke the broadcom wired lan and I had to modprobe install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3 to get it to work again

So you can install 11.2, but its just really a pain to get it all working on the Acer Aspire 7740