I bet ‘sooner’, i.e. now, but not aware of it. But…it can be fixed most of the time.

Each time I have openSUSE installed, I’ve only had 4 repos (base + Pacman). I prefer stability over latest-and-greatest.

Well, I’ve always taken the view that if you’re not prepared to take advice you shouldn’t ask for it, so I’ve streamlined my repo’ list to the recommended four:

# | Alias              | Name                  | Enabled | Refresh
1 | ftp.skynet.be-suse | Packman Repository    | Yes     | Yes
2 | repo-non-oss       | openSUSE-11.2-Non-Oss | Yes     | Yes
3 | repo-oss           | openSUSE-11.2-Oss     | Yes     | Yes
4 | repo-update        | openSUSE-11.2-Update  | Yes     | Yes

I went through some of the multimedia packages that I’ve installed using ‘zypper what-provides’ (an excellent cli tool) to see what I actually enabled vlc for, and I couldn’t find anything, they all came from packman. When I first installed openSUSE last week I was using google to find out about setting up repositories and installing software, and I think I was using other peoples’ ‘non-official’ recommendations, although installing applications using the ‘1-click install’ option from the openSUSE Build Service can enable a lot of repo’s if you don’t exaclty know what you’re doing. :\

That answers another question for me, about removing Nvidia after installing the driver. Thanks for all your replies. :wink:

Besides the vlc repo, the only one that could pose a problem is the Kde playground repo. The other Kde repos should be ok.
Disable those two, then go to the packman repo and click on “Switch to this repo” at the top to switch any possible vlc repos to packman.