Heads-up: VirtualBox VMSVGA controller causes issue with TW guest on TW host, use VBoxSVGA to avoid

This is just a heads-up when running a VirtualBox Tumbleweed guest on a Tumbleweed host. The VirtualBox default to use the VMSVGA graphics controller with Linux guests doesn’t work - cf. below what the issue is. I switched to the VBoxSVGA controller, and the issue disappears. Maybe this is known already, maybe this heads-up might help some people. And I would like this to be a heads-up only, no detailed attempt to hunt for the actual errors involved.

The details:

Issue when using the VMSVGA VirtualBox graphics controller: Booting the virtual Tumbleweed into Plasma fails after entering the user password. The graphical Plasma interface doesn’t show up, the screen goes black. Luckily, CTRL+ALT+F3 (actually Host+F3 = Right-Ctrl+F3) works, and the virtual machine can be shut down properly.
The issue does not exist when using the VBoxSVGA controller in VirtualBox.
With VBoxSVGA, the VirtualBox display screen does switch to full size and resolution as desired.

Host operating system:

  • Tumbleweed as of snapshot 20220420, kernel 5.17.3-1-default
  • Graphics platform X11
  • Plasma 5.24.4, KDE Frameworks 5.93.0, KDE Gear 21.12.3
  • VirtualBox 6.1.32 with Extension Pack, VirtualBox switching to full-screen display of guest

Guest operating system:

  • Tumbleweed as of snapshot 20220422 (fresh install as a virtual machine) and updated to 20220424, kernel 5.17.4-1-default
  • Graphics platform X11
  • Plasma 5.24.4, KDE Frameworks 5.93.0, KDE Gear 22.04.0
  • With Guest Additions installed as per the default installation routine

Remark: My rationale to build a new guest TW virtual machine was to test kernel 5.17.4 and the new KDE Gear 22.04.0 for proper functioning before attempting to update my critical TW bare-metal installation (the host).
Of course, a virtual machine is not identical to a bare-metal machine, and thus it won’t reveal every bug or regression of a new TW update.

I use VirtualBox on a Win10 host for running several operating systems including openSUSE. Under settings/system/acceleration there is a setting for the paravirtualization interface. I read up on it a while ago and have forgotten the important details now but that setting may a bearing on some inconsistencies and source of problems. Likewise, I am not really able to investigate this fully, so it’s just an idea.