headphones not working in dell vostro 320

can’t get to work this, anyone knows how to make it happen? :slight_smile:

i´m using opensuse 11.3 64-bit on a dell vostro 320.

thanks in advance! :wink:


If KDE, check the channel is not muted in kmix (or alsamixer in terminal).

I’m using KDE, this is a snapshot ok kmix…


do you need more information?

please help! :slight_smile:

Could you please check in alsamixer ? You have sound form the speakers ?

I do have sound (listening to aerosmith in amarok)

do i have to do anything else on alsmixer?

everything works as normal (except that a I don’t have sound in flash videos, but I think thats a diferent matter)…


You may want to check here to see if everything is ok : S.T.A.R.T. - SuSE Terminal Audio Reporting Tool

everything seems normal using that script? any help?


Where is the headphone?
Use the setting and add the headphone
I am using xfce mixer it has what is callde switches under alsa control which is maybe similar to kmix you have to put a check to enable it.

In kmix go to settings > configure channels, and drag the headphone setting from the left “available channels” to the right “visible channels”. Then ensure headphone volume is moved up and test. Don’t forget to move up your master volume setting.

If you wish us to take a better look at your settings, with your dell vostro pc connected to the internet run the diagnostic script:


and select the SHARE/UPLOAD option, and it will upload your settings to the web, and give you the web/address/url where that is located. Copy that web/address/URL and post it here and we can check your settings.

I don’t have a channel named ‘Headphone’, just the ones that I previously showed in the snapshot, plus these: Mic B to Mic F.

so I think it is not installed or configured :s

here are my settings from the script :slight_smile:


Ok, for your Dell Vostro 320 I note the with alsa driver and 1.0.23 alsa utilities, and it has the Conexant CX20582 (Pebble) hardware audio codec. A surf on “alsa cx20582” indicates many Linux users have had this problem, … for example this ubuntu bug report: https://bugs.launchpad.net/ubuntu/lucid/+source/alsa-driver/+bug/497546

It appears the model option “ideapad” may work (I would need to see the content of your PCs /etc/modprobe.d/50-sound.conf file to give you the correct syntax to use to apply the model option “ideapad”), but its possible you also may need to update your version of alsa AND apply the model option “ideapad”.

I recommend you:

  • update your alsa per this guide and test. SDB:Alsa-update - openSUSE (note that guide is out of date, but the philosophy still applies). If that does not work, post here so I can do a quality check of your update
  • if simply updating your alsa is insufficient then we can apply the model option “ideapad” (where I need to see your /etc/modprobe.d/50-sound.conf file)
  • no matter what you do, write a bug report on openSUSE-11.3 component ‘sound’ per guidance here: openSUSE:Submitting bug reports - openSUSE You can log on to bugzilla using your openSUSE forum username and password. Don’t reference this thread in the bug report as the SuSE-GmbH sound packager (who is also an alsa developer) will refuse to read a forum thread. Instead attach to your bug report the alsa-info.txt file you get from running:
/usr/sbin/alsa-info.sh --no-upload 

Good luck.