Headphones: no sound - Realtek sound card, Intel

I’ve managed to get my sound card working by editing /etc/modprobe.d/sound, but I’m still getting nothing from the headphones. I’ve been through the troubleshooter and can provide the following info:

alsa version: 1.0.16rc2
Module: 0 snd_hda_intel
Codec: Realtek ALC660-VD

Output from alsa-info.sh: http://www.alsa-project.org/db/?f=a065de1b58827f7b797e7fd77a3d87f722af3c6e

Outpug from tsalsa: http://nopaste.com/a10yQWaRx

/etc/modprobe.d/sound now reads:

options snd slots=snd-hda-intel
options snd-hda-intel model=hp position_fix=1
# _+Pw._Bxm7sWGq96:Azalia Audio Controller
alias snd-card-0 snd-hda-intel

(the second line put in by me)

As I said, sound works perfectly through the speakers (although each time I restart I have to use the mixer to turn the volume up for some reason) but there’s no sound with headphones. I’ve checked the headphones on another machine & they work ok, so it’s not them.

Please bear in mind that, although moderately intelligent and willing to go through all the howtos/troubleshooters before posting, I am a complete n00b and have probably missed something completely obvious/basic. Your patience would be appreciated :slight_smile:

Hi
You should be able to set the volume via YaST-> hardware-> Sound select
the ‘other’ button and volume.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.18-0.1-default
up 3:15, 1 user, load average: 1.42, 0.73, 0.35
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Just a quick addendum - I notice that in the tsalsa output it says the headphone volume was ‘off’ - I’ve since turned it on & still nothing.

edit - I’ve set the headphone volume via YaST - still nothing :frowning:

That link does not work.

That URL has your headphone switched OFF.

OK, addendum noted. When you run the tsalsa script again, does it still report the headphone as switched OFF ?

Note that when you run Yast > Hardware > Sound … there is a risk your custom settings could be removed. Check to make certain this did not happen. The model=hp and position_fix=1 did show up ok in the tsalsa script output.

I note the following options for the ALC660-VD (from which you have selected “hp”) in the ALSA-Configuration.txt file for an alc660-VD

	ALC861VD/660VD
	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF OUT
	  6stack-dig	6-jack with SPDIF OUT
	  3stack-660	3-jack (for ALC660VD)
	  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
	  lenovo	Lenovo 3000 C200
	  dallas	Dallas laptops
	  hp		HP TX1000
	  auto		auto-config reading BIOS (default) 

Did you try any others? ie try “auto”, or “dallas” or “lenovo”, or “3stack” or “3stack-dig” or “3-stack-660” or “3stack-660-digout” ? If you do try those (one at a time) be certain to restart your alsa driver with: su -c ‘rcalsasound restart’

If you still have no success, can you provide more information on your installed alsa rpms ? ie provide the output of running the following in a konsole or gnome-terminal:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a

Thank you!

Changing the model to ‘lenovo’ has worked. I apologise for my stupidity - when ‘hp’ gave me sound through the speakers I didn’t think to try other models.

Many apologies for wasting your time, but thank you for helping me out.

Wonderful!!

Congratulations, and thanks for sharing your solution (‘lenovo’).

Its not exactly intuitive that “lenovo” works for a PACKARD BELL EasyNote_MX37-S-200. It would be nice if there was a database somewhere listing the various model settings for different laptops (but I am not aware of such a database). Hence we need to resort to trial and error.