Headphones are not connected automatically.

Hi all!

I have a problem with my earplugs.
When I start my system with the earplugs connected they work just fine.
If I start the computer without them or I disconnect them at some point and connect again the earphones have no sound.
I have to go to Pulseaudio volume control, then the Configuration pane, then I change the audio profile from “Analog Stereo Duplex” to “Analog Stereo Output” and to “Analog Stereo Duplex” again. That way I have my earplugs working again.

How can I configure the system to hook up the earplugs automatically?

Describe your hardware. Or we need to guess?

If KDE Plasma, this should happen auto-magically …

  • Check the KDE System Settings – audio settings …
    The output sink should change auto-magically to the headphones …

[HR][/HR]Here is my hardware info from alsa-info.sh script:
http://alsa-project.org/db/?f=4e5b769594e8a4760600b4eed607ad5aed9fbd0d
I run it with the earphones plugged in and working
I disconnected the earphones then connected them again. They stopped working. I run the test again:
http://alsa-project.org/db/?f=218055b8bb86033e5211ad8aad86af4b6805cc03
It produces almost identical result. The running of the test caused my headphones to work again, however it does not eliminate the problem.

Yes, I have KDE plasma for LEAP 15.2, but the input does not change automatically.