Headphones and speakers work together at the same time on Toshiba laptop

Hi, I have a Toshiba C650D satellite laptop with Opesuse 11.3 and Gnome.
When i try to use the headphones i hear sound fron both the speakers and the headphones.The headphones won;t mute the speakers.
I searched a little and found that if you edit a file named sound.conf and put some lines it might work but i couldn’t solve the problem.
Can anyone help me.Do you want me to outputyou something?Please say the command and i will do ot.
Thank you :slight_smile:

You need to tell us EXACTLY what you put in this file you call 'sound.conf". I do not know of that file. I do know of 50-sound.conf.

I’ve read from linlap for the Toshiba 655D which is close to your model number, that the option “ideapad” might work (by adding the line “options snd-hda-intel model=ideapad” to the start of the /etc/modprobe.d/50-sound.conf file and restarting) …


… before trying that please provide the information which is recommended to be provided from our multimedia stickie: Welcome to multimedia sub-area and I’ll quote this for you

please post … providing in your post the following information :


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “alsa-info.sh” … when you run:


you should get something like this (if it asks for an update, select NO):

followed by this (select the SHARE/UPLOAD option):

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :

followed by this (where in RED is the URL).

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on [Pastebin.com](http://pastebin.com) and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

So the link with the info is this http://www.alsa-project.org/db/?f=f74cddf3874c575ff53cbb7e987d1fe4a933c1f1

and also this toshiba_sound_prob - Pastebin.com

Now the outputs

for “rpm -qa ‘alsa’”


for rpm -qa ‘pulse


for “rpm -q libasound2”


for uname -a

Linux linux-qiq8.site #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux

and for cat /etc/modprobe.d/50-sound.conf

options snd-hda-intel enable=1 index=0 model=ideapad position_fix=1
options snd slots=snd-hda-intel,snd-hda-intel

u1Nb.jN8_s9AC_37:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
alias snd-card-1 snd-hda-intel

I think you can improve on what you have done. It appears to be random patches, as opposed to a consistent approach.

First the script :

I note this:

!!ALSA Version

Driver version:
Library version:    
Utilities version:

From that I can see you updated some utilities, did not touch the driver, and did not touch the library. Why that approach ? To make it makes more sense to update the library and driver.

Now the outputs

I think you should go here: SDB:Alsa-update - openSUSE and update alsa-plugins-jack-32bit, alsa-plugins, alsa-firmware, alsa-plugins-pulse, alsa-plugins-pulse-32bit, alsa-tools, alsa-oss, alsa-utils, alsa, alsa-oss-32bit and libasound2.

And also install alsa-driver-kmp-desktop that is appropriate for your kernel (note that web site I gave is a bit out of date, but the update/kernel selection philosophy applies).

Then delete your /etc/modprobe.d/50-sound conf file

Then reboot and go to YaST and try to configure your sound. YaST will create a new /etc/modprobe.d/50-sound.conf file.

If your sound does not work with the new file created by YaST, then add this line to the start of that /etc/modprobe.d/50-sound.conf file,

options snd-hda-intel model=ideapad

reboot and test:

Why do you have two alias’s in the 50-sound.conf file?? It does not make sense to me. Do you know why those are there?

Why do you think you need enable=1 and position_fix= ?. Did you read something in the dmesg saying that was needed ? I’m puzzled there as to why you believe that needed. One can not just randomly apply things and expect them to work. Or if you do randomly apply them and they dont’ work, then you should IMHO remove them afterward. Else one just puts in a place that will break any other subsequent fix attempts.

Well id did some of the things you told me.I updated the alsa driver and library and now the headphones work but i have no sound, neither from speakers nor from headphones on any browser (firefox, chrome).Also i have to note that i run pulseaudio every time that i start the laptop because when i go to YaST and try to configure the sound it pops up a window and says to wait ultill it finds a device and does nothing.That’s why i run pulseaudio, then when i click to configure the sound, it opens a configuration window, BUT it does not create a /etc/modprobe.d/50-sound.conf file.
Finally i couldn’t install alsa-driver-kmp-desktop, can you give me more details about how to install it?

A… and also i changed the etc/modprobe.d/50-sound.conf file and puted the line options snd-hda-intel model=ideapad

Here is now my new links http://www.alsa-project.org/db/?f=a890743311153f66107284b70fd980ad7085019e

Toshiba_update - Pastebin.com

Btw thank you very much, well i thought the “alsa” package was the alsa driver, that’s why i kept it no updated.

Its in the guide. … As long as you did not install something else to change it.

It looks like you installed something because I see:

!!ALSA Version

**Driver version:     1.0.24**
Library version:
Utilities version:

My understanding for the driver to say 1.0.24 you had to have installed an alsa-driver-kmp-somekernel.

Hence I’m wondering if there is something else you did not tell me ?

Anyway, to install it (assuming you do NOT already have a alsa-driver-kmp installed) in essence just open a terminal, and type ‘su’ (no quotes) to get root password and then copy and paste the following three lines:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.3_Update/ multimedia1

zypper install alsa-driver-kmp-desktop

zypper rr multimedia1

Reboot and test.

As you can see there is not much too installing alsa-driver-kmp-default.

Reference updating, once sound works properly IMHO one should not update alsa. But we need to get to that point first.

I also would like to do a quality check on what you installed. Please post output of:

rpm -qa '*alsa*' 

I think you are a gnome user? In 11.4 with pulse audio (on kde4) I find the app ‘pavucontrol’ helpful. I recommend you install that app and test with it to tune your audio when playing video with a with a browser. You also could consider updating your pulse apps from the same repository from where you updated the alsa apps (although I have no experience trying that).

Yast > hardware > sound, when one selects to edit/save a configuration in YaST will create that file.

Here it is


I also installed kmp-desktop driver but didn’t solve the prob with the sound.
But i found on the Net that there is a script for pulseaudio and flash player that solves a problem with the sound.
I found the info here https://wiki.archlinux.org/index.php/PulseAudio

and also here is the scriptAUR (en) - libflashsupport-pulse
but i don’t know how to run it :confused:
Finally but i think it doesn;t matter now, for the 50-sound.conf file, well when i go to
Yast > hardware > sound without first running pulseaudio it just stucks and pops up a window as i said before.If i have pulseaudio running, then it ioens the pulseaudio configuration from Yast > hardware > sound but there it has no saving changes.You just configure I/O volume and close the window.

Apologies, but I don’t undertand most of what you posted.

First this post:

If you do not know how to run it, how can you say it solves your problem ?

I do not understand any of the English that you typed. Pops up a window as before ? Before what ? What does ‘stucks’ mean in the context you mention ? What does the window say ? How can pulse open YaST ? None of what you posted there is understandable to me.

Further to that, do the headphones and speakers work together or are they separate ? Did you sort your problem with the browser audio ?

As long as pulse has NOT been disabled, then it is automatically enabled upon boot and your statement “if you have pulse audio running” makes no sense to me.

Anyway, whether or not you have this working now, the fact from what I can read is it did NOT ‘just work’ upon installing openSUSE, and it should ‘just work’ upon installing openSUSE.

I recommend you write a bug report on openSUSE-11.3 component ‘sound’ noting the symptoms of your problem in the bug report. There is guidance here for writing bug reports: openSUSE:Submitting bug reports - openSUSE and you can use your openSUSE forum username and password when logging on to buzilla to write the bug report. Attach as a file to the bug report the file /tmp/alsa-info.txt where you get that file by running:

/usr/sbin/alsa-info.sh --no-upload 

and then monitor the bug report for the SuSE-GmbH sound packagers response. That person is also a developer of the alsa sound driver and they should be able to sort this for you such that it ‘just works’.