Headphone problem

Hi!

The sound is working great, however when I plug the headphones the sound stops. I have checked the sound configuration and is all fine.

I tried to solve adding:

options snd-hda-intel model=z71v position_fix=1

in /etc/modproble.d/50-sound.conf but the headphone still not working. I also have checked the volume in alsamixer.

Thanks.

Checkout pavucontrol might help debugging

More comprehensive information about your sound hardware and configuration may be required…

https://en.opensuse.org/SDB:Audio_troubleshooting#Script_to_run_to_obtain_detailed_information

/usr/sbin/alsa-info.sh

Post the link that it generates, so that we can review the uploaded output.

BTW, I’ve just found/read this wiki page which suggested

Speakers and headphones both work great once you unmute the “Front” volume.

You could do this using

alsamixer

Select your sound card with F6 and adjust the required levels from there.

OR

pavucontrol as already suggested.

The alsa info is here: http://www.alsa-project.org/db/?f=7e5b7ff16a18c0f4247805dac1761ee6b438ce1f

Are everything right in alsamixer and also in pavucontrol. I mean: there is no muted devices.

Can you select headphones as audio output in pavucontrol?

Yeap, I can

From that output look at this:


**Simple mixer control 'Headphone Mic',0**
  Mono: Capture [on]
  Front Left: Playback 0 **[0%]** -34.50dB] [on]
  Front Right: Playback 0 **[0%] **-34.50dB] [on]

Playback from headphone mic is muted. What sort of headphones are you using ? Are they a combination mic/headphone ?

Also speakers are off (why ? ). What happens if you switch them on and increase the volume level ?


**Simple mixer control 'Speaker',0**
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Front Left: Playback 0 **[0%]** -65.25dB] **[off]**
  Front Right: Playback 0 **[0%]** -65.25dB] **[off]**