Headphone jack sense on Opensuse 12.1

Hi all,

I’m having a problem with my computer’s sound. Every time i play something, the sound can be heard from both the headphones and the PC’s internal speakers.
The system is an Optiplex 755. I’m using Opensuse 12.1 x64. Please note that i’ve also had this problem on Opensuse 11.4 x64
(i didn’t try other Linux distros on this machine, but i did have Windows XP at some point which worked fine).
I’ve searched for the problem online, and it seemed i have to look for “Headphone jack sense” in Kmix, but i see no such setting. I’ve also tried setting different models in my
/etc/modprobe.d/50-sound.conf file, but that didn’t fix the problem either (i tried “basic”, “desktop”, “3stack”, “test”).

Here’s some additional info that might be useful:


fneculciu@fneculciu:/etc/modprobe.d> cat /proc/asound/card0/codec* | grep Codec
Codec: Analog Devices AD1984

fneculciu@fneculciu:/etc/modprobe.d> cat 50-sound.conf

options snd slots=snd-hda-intel
# u1Nb.z97TXzKOvE6:Optiplex 755
alias snd-card-0 snd-hda-intel

Also note that in Yast , on Sound card the Enable PulseAudio support checkbox is checked.

Any ideas? Thanks in advance.

One just can not apply ‘any’ model option and expect it to work. Instead one should look at the HD-Audio-Models.txt file that is on their PC in the alsa documentation section and find the appropriate model options for their hardware codec.

In the case of the AD1984 I note this from the HD-Audio-Models.txt file for 1.0.24 of alsa:


AD1984
======
  basic		default configuration
  thinkpad	Lenovo Thinkpad T61/X61
  dell_desktop	Dell T3400

oldcpu wrote:

> One just can not apply ‘any’ model option and expect it to work.
> Instead one should look at the HD-Audio-Models.txt file that is on their
> PC in the alsa documentation section and find the appropriate model
> options for their hardware codec.
>

Can you please give the full path (and the RPM it came from) for that file?
I don’t see anything like that in /usr/share/al* except alsa/cards/HDA-
Intel.conf.

Or is it something on the ALSA website?

George Baltz wrote:

> oldcpu wrote:
>
>> One just can not apply ‘any’ model option and expect it to work.
>> Instead one should look at the HD-Audio-Models.txt file that is on their
>> PC in the alsa documentation section and find the appropriate model
>> options for their hardware codec.
>>
>
> Can you please give the full path (and the RPM it came from) for that
> file? I don’t see anything like that in /usr/share/al* except
> alsa/cards/HDA- Intel.conf.
>
> Or is it something on the ALSA website?

Never mind - I should have read my own sig. It’s in the source package.

Yes, I should have pointed to it, but I was very rushed last night. For those who can’t find it despite the good hint you provided, on my openSUSE-11.4 PC the HD-Audio-Models.txt file is here:


/usr/src/linux-2.6.37.6-0.9/Documentation/sound/alsa/

… of course users with a different kernel will find it in a different directory (based on their kernel version).

Ok, so i’ve installed the kernel-source package and finally found the HD-Audio-Models.txt file.
The settings are the same as oldcpu posted.

AD1984
======
  basic     default configuration
  thinkpad  Lenovo Thinkpad T61/X61
  dell_desktop Dell T3400

I tried changing my 50-sound.conf file to:

fneculciu@fneculciu:/etc/modprobe.d> cat 50-sound.conf

options snd slots=snd-hda-intel
options snd-hda-intel model=basic
# u1Nb.z97TXzKOvE6:Optiplex 755
alias snd-card-0 snd-hda-intel

but Kmix shows the same (after a system restart, of course). I remember, i previously tried the dell_desktop model as well, but that made things worse (no sound at all, only Dummy output in kmix). I guess that makes sense, since this is an Optiplex 755, not a T3400. But i can’t find a special setting for this model and “basic” doesn’t work. Am i doing something wrong? Or does the problem lie somewhere else? Any ideas?

I don’t know if it makes any difference, but I always make the model entry the first line … ie


options snd-hda-intel model=basic
options snd slots=snd-hda-intel
# u1Nb.z97TXzKOvE6:Optiplex 755
alias snd-card-0 snd-hda-intel

Note, its possible a ‘thinkpad’ or a ‘dell_desktop’ setting will work better, even if you do not have that hardware. The alsa developers will simply reuse the same label for different hardware. Else the list becomes too large.

It seems it worked with “thinkpad”.
I also set it as the first line but i’m not sure if that is important.
Thank you.