Headless install from scratch

Hi all,

I am a somewhat educated beginner when it comes to anything Linux and Unix.
I got my hands on a cheap HP desktop P4 and I would like to install OpenSUSE on it to transfom it into a server to do my downloading over usenet using sabnzbd, headphones, sickbeard and couch potato.

The issue I’m facing is that I don’t have a display at home and I’d rather not get one to use it only to install Suse and then discard it.
I am sure it is possible to boot from a LiveCD or something and then SSH into the beast to complete the installation, I’m just confused as to how to accomplish that.

Any pointer would be welcome!


SSH or VNC, whatever works

Anyone care to advise?

Does the system have a serial port that can be used? Do you have
another computer with a serial port?

One option would be to use SUSE Studio with a configured system as a
preload iso image, then it should install away.

PXE booting is another option.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 5 days 0:06, 4 users, load average: 0.29, 0.34, 0.31
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

openSUSE 12.2: Chapter 2. Remote Installation

Looks a bit out of date as it talks about SaX which does not exist anymore.

On 2012-09-16 13:46, hcvv wrote:
> londy;2487608 Wrote:
>> ‘openSUSE 12.2: Chapter 2. Remote Installation’
>> (http://tinyurl.com/99ql3d8)
> Looks a bit out of date as it talks about SaX which does not exist
> anymore.

Report that in bugzilla against documentation, please.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)


The PC does have a serial port but the other ones I have at my disposal don’t.

I am not sure regarding PXE capabilities of the system as I don’t have a screen to plug in to enter the BIOS.

I will give Suse Studio a try and report back, thanks!

I tested out the ssh method out of curiosity and it works. I had a screen to look at so it was easy but it shouldn’t be difficult to do without a screen.

If anyone is interested in doing it, this is what I did:

  1. Boot up the dvd. The default timeout on the grub screen is 60 seconds, so I guess you can wait 30 seconds or so before moving to the next step.

  2. Hit the down arrow once and then start typing this:

usessh=1 sshpassword=something netdevice=eth0 netsetup=dhcp

Hit Enter. Give it a minute to set it all up. If all went well, sshd will be started and it will just sit there and wait for you to connect from another computer.

On the other computer, you type:

ssh -X root@ is just an example, you need to find out what address your dhcpd handed out on your network.

After you login, enter “yast.ssh” and that will start the normal installer. I just clicked through the screens and didn’t do the actual install but it looked good to me.

Amazing. And thanks for reporting back. Very usefull.

On 2012-09-18 10:56, hcvv wrote:
> Amazing. And thanks for reporting back. Very usefull.


I have one (!) doubt. Where is that yast.ssh? I don’t see that program. Or is it some program
available only in the install dvd?

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

It must be something that is available in the RAM loaded install system. One of the few commands available I guess.
But indeed for the curious it is a good question. Were it only to kno where you found out that it exists and must be used here.
I tried to read quickly through the information linked at in post #5 from @londy above, but after clicking my way through, I ended up at

Enter yast to launch the installation program.

Not the same as yast.ssh. Yes, I am curious!

I got the yast.ssh directly from the installer. Here’s a screenshot I got from kvm.


BTW, there’s a lot more kernel options you can use if you want.

SDB:Linuxrc - openSUSE

Thanks for the picture with the explanation and the link.

Thanks a lot, I’ll try that when I get back next week!!


ssh -X root@

prompts for the password.
I tried with “password” and “something” (matching what I put in the first step) and every time the password was refused.
Any ideas?

I posted too fast… It seems

was ignored because I used susestudio.com to build the LiveCD and had setup another password for root there.
I used the one setup on susestudio.com and I successfully logged in.