HDMI output not recognized on Asus netbook with nvidia ION

As I mentioned my onboard sound chip is dead, could it be that those machines, for power saving reason, only allow one soundsystem? Try switching onboard audio off in the BIOS if you haven’t already tried that.

Tried it and ended up with no sound cards in opensuse.
I’ll try setting up another distro just to see if the different combination of alsa and kernel versions does anything but I’m not too hopeful.

I’m afraid the soundchip on youre nvidia card has ceased to be, just like my onboard soundchip. Did you run opensuse on this machine for a long time before I made you aware of it being an Optimus system?
They do run very hot if you don’t do anything about it and that alone can easaly frye a chip.
I would have hoped to get some feedback from other optimus owners, I can’t be the only one having succes with this. After all having a laptop that can run a long time on battery and then having it run as a media center computer at home on AC
sounds to me as being one great thing to do with those bastards.
Hello where are you Optimus suckers?
Do you have any warranty time left on it? Don’t tell them you’ve run Linux on it, reinstall Windows if possible.

Yah, it’s been running opensuse for a while. First time I heard about optimus when I started the topic!
Also, it’s a parrot well past warranty unfortunately.

I think you may be right though - signs point to a hardware issue.

I tried running ubuntu but got the same output form aplay -l - just the analog audio.

Guess I’ll be buying something else to use as a media centre…
Thanks for all your help, hank_se! Consider yourself upvoted (if there was such a thing here) :).