HDMI out with fglrx not working

I’ve been searching around the net like crazy but nothing seems to be working for me, I’m running openSUSE 11.4 64 bit, KDE 4.7 with latest fglrx drivers. My laptop is a HP Pavilion dv6 with a ATi Mobility Radeon HD5650M.

The drivers themselves work fine, I get quite a good acceleration and I can choose between discrete and dedicated graphics just fine, but when I plug in the HDMI cable from my TV it just doesn’t detect it. It works fine on Windows version of ATi CCC, but when I open CCC in openSUSE I only see my notebook’s monitor, not a sign of the HDMI cable plugged in. Any ideas?

Since you’re having a problem with the proprietary driver, you may want to consider requesting support from AMD:

ATI Catalyst™ Proprietary Display Driver

Unofficial support:

Main Page - cchtml.com

I’ll try them, thank you.

I removed the fglrx drivers to switch to default radeonhd drivers and even then it shows absolutely no sign of HDMI, I tried VGA out and it worked absolutely fine with fglrx as well as radeonhd.

It seems xrandr is not seeing my hdmi port, all it shows is VGA and LVDS, any ideas?

AFAIK, HDMI support is fairly recent, so the radeonhd/fglrx drivers may not support all cards completely. Examine /var/log/Xorg.0.log for any hints as to what may be occurring during Xorg startup. Is your HDMI-connected monitor plugged in from boot?

BTW, even where HDMI is working, I’ve seen threads that suggest that the output is reported as ‘DVI-I_x’ (x=0,1 etc) for ATI/AMD HD cards using the radeonhd driver. (Others please correct me if I’m wrong here).

  1. Try connecting another HDMI-connected monitor (borrowed or otherwise) if at all possible. Does it behave in the same way?

  2. Manual Xorg configuration may be useful (but really you need to check out the contents of /var/log/Xorg.0.log first). Here’s a thread where this approach was used successfully.

The problem is, it doesn’t see my HDMI port. All I got is VGA(Or sometimes CRT) and LVDS, nothing else(No DVI, HDMI etc). In that thread, it seems that RandR is seeing it’s HDMI port.

Check out the known bugs at

X.Org Wiki - radeonhd

(Its likely that support has not yet been added for your particular chipset).

File a new bug report if you need to.

X.Org Wiki - radeonhd


Hi, i have absolutely same problem, but i have nVidia NVS4200M (ThinkPad T420, sandy bridge). So this is maybe global problem, not only randons :frowning: