HDMI not working with 3.14 and radeon - kernel panic

Good day,

HDMI isn’t working with kernel 3.14 (both 0-1 and 0-2 from the Kernel:Stable repo). I use the open-source radeon driver with Gallium 0.4 and Mesa 10.1.0 (from the X11:Xorg repo). My video card is ATI Mobility Radeon HD 4550. There are no issues whatsoever with the 3.13 kernel series.

If I attach the HDMI cable, after a few seconds I get a message on the screen like the following:

Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu 1
Kernel Offset (...)
Shutting down cpus with NMI
drm_kms_helper: panic occurred, switching back to text console

(I cannot copy the original message because I don’t know where find it - it’s neither in dmesg nor in /var/log)

Any help is much appreciated.

I don’t use SuSE (I use Arch Linux), but I was Googling and yours was the only similar problem I found. I have an HTPC that uses a Radeon 4xxx (I forget the exact model) and I have it connect to my TV via HDMI. With 3.14.0 and 3.14.1 (and Mesa 10.1.0) it kernel panics on X startup, with 3.13.8 it’s fine.

I tried 3.15-rc1 and the problem was fixed, so if that’s an option you can try that. Maybe it’ll be fixed in 3.14.2…

Many thanks for the heads-up! It’s good to know there’s an upcoming solution. I’ve been using 3.13 since, worst case I just completely skip 3.14.

So I’ve installed 3.15 from kernel:Stable. Everything works as expected if I connect the HDMI cable after the DE is loaded. But the computer completely freezes up during the loading of the DE (be it KDE, icewm or xbmc-standalone) or even the DM (I’ve tried with kdm and lightdm) if the cable is attached. A very significant bug.