Hdmi audio problem

Hey everyone,

I’ve recently installed OpenSUSE 12.1 on my Windows 7 machine as a dual boot but I cannot seem to get the audio to work in Linux as it does in Windows. I’ve been searching for hours and can’t seem to get any solutions to work. Now is the time to post output info from my machine to this site but I can’t even remember how to do that lol (it’s been a while since I’ve last used Linux).

I’ve tried configuring pavucontrol and I can get the bars to move but no audio through the speakers.

I thought I was about to get it going because I’ve been seeing solutions regarding the /etc/pulse/default.pa file, but when I try to edit it as root in the Konsole I just get messages like “kwrite cannot connect to x server” or “gedit cannot open display”

Might as well post the info I know is relevant:

My desktop is plugged into my tv through hdmi, the tv has two speakers plugged into it through its headphone jack… and it also has a speaker connected through its optical input (windows recognizes all these speakers)

Just tell me what else you guys need and the commands to produce it. Thanks.

If you wish to run kwrite with root permissions (to edit a system file), launch it as a regular user with the command

kdesu kwrite

and enter root password when prompted for a password.

Wrt your audio / hdmi … I don’t have an hdmi setup, but if I can help at all I don’t mind trying. Can you provide more information on your audio setup with the command :


and select the Share/upload option, and post here the website URL/address where the script output is uploaded/located on the internet.

Thanks for the quick reply, no wonder it wouldn’t let me edit as root… lol I was typing in sudo because I was thinking of my Ubuntu past. Anyways here is the link:

On 2012-03-24 18:26, mackayshrooms wrote:
> Thanks for the quick reply, no wonder it wouldn’t let me edit as root…
> lol I was typing in sudo because I was thinking of my Ubuntu past.

If you run root commands from a terminal such as konsole it is better to do
“su -”.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Okay, so it turns out that I managed to get some sound via the “one click” drivers by nVidia, but after rebooting I’ve come to another problem… the font requires a magnifying glass to read… I’m not familiar with suse enough to navigate this way to simply make it larger… here’s a screenshot of firefox:

not all text is impossible to read, but most is…

and as it turns out, it’s extremely difficult to post an image as i cant read ****


That can happen when the attached monitor doesn’t report its settings correctly. What does the following report?

xdpyinfo | grep resolution

Are you using KDE? If so, you can adjust via

System Settings > Application Appearance > Fonts

and set the DPI value manually.

It can also be set via the xrandr command. For example

xrandr --dpi 96

which could be added to an executable script and placed in the appropriate ‘Autostart’ directory.

Ok, so your HDMI sound problem is now solved ?

This is a different problem. You should start a new thread with a different subject. Asking for help ‘on inappropriate small fonts in KDE’ on a thread entitled ‘Hdmi audio problem’ won’t get you the KDE experts that you want to help you.

Well, belay that.

@ mackayshrooms you are in luck. deano_ferrari is one of our more knowledgeable graphics users and you are in good hands with him.

Sorry oldcpu I just thought it could be a simple fix thus didn’t think of making a new thread, and i tried running that in the terminal but i have no idea what to do as i can’t see enough to copy / paste… I need like a video of how to change the font because I cant navigate, yes I’m on KDE

Logout and login using icewm.
It might be using a bigger font than kde

xrandr: Failed to get size of gamma for output default

i guess this is what the konsole says when i run that command

I’m assuming this is a desktop environment… however when i try to pick one before logging back in… there is a list of like 7 or 8 and i can’t even read them

Well hope this one will work
Boot using runlevel 3
login as user then su to be root
use the command

**startx -- -dpi 100**

Then configure your machine to use readable fonts

Sorry I wasn’t clear enough, I understand.
When you boot to opensuse you will see the option line down the screen
Just navigate there and type 3 and opensuse will boot using runlevel 3
you will know because it will be all in text mode until you startx.

Just be sure to erase all the written option in there before you type 3
Just to be “sure”

after it booted i got a message saying 3 sound drivers were removed, and now i can read the font but lost my hdmi audio again lol

Forget about the sound first, concentrate on configuring the fonts.
Go back to deano_ferrari earlier post on configuring font in kde
You might have to fix also the qt4-settings to make your login fonts clearer.

Hint on qt4 settings
you have to su to be root and
the command is

ok so I forced the dpi to be 96 by reading deano’s post, but i didn’t really know what to configure for qtconfig… so i just went ahead and installed the drivers again and guess what… small fonts again. so clearly i need to configure something else and i guess you told me but i still don’t know enough to do it… the headphone jack gets audio but i would just like to not have any more cords… thanks for the help so far

Ok I guess it is about time for you to make a new thread
for the fonts, just reference this thread to your new one.

My advice to you when you create a new thread
Describe your graphic card again, the version of opensuse,
what monitor you are using etc. Please give more information that you think will be of help.

so here I am again,

I had audio through hdmi the past couple days and now after a reboot it’s gone…

Hi, you’re back;)
Tell us more about it.