HDMI AUDIO PROBLEM(KMIX)

OS Information
OS: Linux 2.6.34-12-desktop i686
Current user: vastolorde@linux-9eds.site
System: openSUSE 11.3 (i586)
KDE: 4.4.4 (KDE 4.4.4) “release 2”

Display Info
Vendor: ATI Technologies Inc
Model: ATI Radeon Graphics Processor (M96 9480)
2D driver: fglrx
3D driver: ATI

My graphic card’s ATI HD4650.When I watch film on TV by using HDMI,Sound is coming from my pc not TV.I want it to come from TV.How can we do it? I didn’t find a place to adjust it from KMIX.

Thank you :slight_smile:

I am sorry not to mention my problem better.I couldn’t transfer sound to Tv.However,when i click the test button ( System Settings / Multimedia /Audio Output / Music /ATI HDMI AUDIO , I adjusted like that 1.HDA INTEL 2.HDA ATI HDMI ),Sound comes from TV.I don’t know what to do.What should I do to transfer sound to TV.My english isn’t much better,so I couldn’t explain better.Sorry about that :slight_smile:

So I would have assumed sound would work on a movie, though it would not be Dolby Digital without further modifications. Basiclly, you need to select S/PDIF passthrough, so that the undecoded Dolby Digital sound goes straight to your TV or receiver. Do you know if your TV can handle Dolby Digital?

Next, just what movie player are you using? For instance, since I use the KDE desktop, I normally use Kaffeine. If you are using KDE 4, it would seem that Kaffeine version 1, came with no way to modify the audio setup, even as it appears to use xine for such tasks. I determined that if you load the xine-ui OR, better still, the Kaffeine from KDE3 (By adding in the KDE 3 repositories to your setup), you can modify the xine configuration to get Dolby Digital passthrough to work. Then copy this configuration to the new Kaffeine that comes with KDE 4. Here is a link on this story:

KDE 4 Phonon xine-backend Configuration

So, what movie player do you use? Consider using Kaffeine if you use KDE 4. Determine what types of inputs your TV supports. On one TV set, the audio input had to be switched between PCM (for normal stereo) and RAW (for Dolby Digital input). Every movie player seems to work different in its audio configuration. Just getting one to work does not make others work. Consider you do not need more than a couple of movie players to work. A primary (Your favorite) and perhaps a backup, just in case.

Thank You,

First of all,
Thank you for your answer :slight_smile:

I use VLC Player for my videos.I haven’t tried Kaffein yet.Actually,I tried to open .mkv files with it,but I couldn’t handle it.So I did some research on the internet,and saw VLC player.According to comments about VLC,it was a good player,and I started using it.I think it’s really good.If it’s possible,I would like to use VLC player with this solution.

My Sony TV(32bx300)( // Here is a link about Technical Features you can see every detail from this __ KDL-32BX300 (KDL32BX300) : Genel Bak ) can handle Dolby digital.

How can I select S/PDIF passthrough ?

I do not normally use VLC, but I went to Software Management and installed it from the packman repository along with all of the required stuff, as it were. I tried this on two different computers. One uses a Creative Audigy sound card with an I/O module attached and connected to my receiver via coax. The second was a creative X-Fi sound card connected via optical cable to the same receiver.

In order to get Dolby Digital to work I went into VLC, Tools / Preferences / Picked Audio on the Left / Under the Output Category on the right I selected Output Module:ALSA Audio Output & I placed an X in Use S/PDIFF when available. I did the same exact thing on both computers and it worked for me. I tested this with the Matrix movie I had laying around, the Greatest Movie Ever Made, I might add.

The Audio output in a HDMI cable is coaxial audio (think a phono connector). If this audio is integrated into the same built-in sound card of the PC, it would work the same no matter if separate or in a HDMI connector. So, in theory it should work for you. The TV link you sent was not in English, but I could pick out Dolby and 5.1, so surely it does accept the signal.

Thank You,

I will try it.If something happens,I will explain to you as much as I can.Thank you :slight_smile:

Thank you very much.Thanks to you,I have resolved this issue easily.I did as you said,and everything is OK now. :slight_smile: :slight_smile:

Viplime Thank you very much.Thanks to you,I have resolved this issue easily.I did as you said,and everything is OK now. :slight_smile: :slight_smile:
I love it when a plan comes together and it works. Happy to hear of your success. As a relative new user here (based on your message count only), here is some more information about the forums you might want to read.

Fourm Message Counts:

As you start or answer any message thread here in the openSUSE forums.

Puzzled Penguin 0-49 (new users start with this level)
Student Penguin 50-99
Explorer Penguin 100-249
Busy Penguin 250-499
Parent Penguin 500-999
Wise Penguin 1000-1999
Omniscient Penguin 2000

FYI here are the reputation levels:

As you reward another user for the help they have provided you using
the reputation icon in the lower left of any message that you read.

REPUTATION LEVELS:

User is infamous around these parts -99999
User can only hope to improve -50
User has a little shameless behaviour in the past -10
User is an unknown quantity at this point 0-9 (new users start with this level)
User is on a distinguished road 10-49
User will become famous soon enough 50-149
User has a spectacular aura about 150-249
User is a jewel in the rough 250-349
User is just really nice 350-449
User is a glorious beacon of light 450-549
User is a name known to all 550-649
User is a splendid one to behold 650-999
User has much to be proud of 1000-1499
User has a brilliant future 1500-1999
User has a reputation beyond repute 2000

Thank You,