HDMI audio output on Dell Precision M6600

I had hoped that this would burst into life when I updated to 12.3, but no luck. Does anyone have any tips?

alsa-info.sh tells me that the soundcards in this laptop are:

0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xe3960000 irq 55
1 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xe3840000 irq 56

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Barts HDMI Audio [Radeon HD 6800 Series]

The internal speakers work fine, and HDMI video works fine.

Any clues would be appreciated.

You should define if you are using KDE or Gnome
Which device is set as default in Yast > Hardware > Sound?

In KDE you also need to configure sound devices in system settings (kde control centre)

You could install pulse audio volume control (pavucontrol) application and then launch that to see if you can use it to direct your sound output to HDMI.

Often it is the graphic hardware ( ! ) that provides the HDMI functionality (ie provides both graphics and hardware). If using the radeon open source graphic driver, a special boot code is needed to enable HDMI audio.

The spec sheet that I read on this laptop notes any of the following could be the graphic hardware …
• AMD FirePro M8900 Mobility Pro with 2GB GDDR5 dedicated memory
• NVIDIA Quadro 3000M with 2GB GDDR5 dedicated memory
• NVIDIA Quadro 4000M with 2GB GDDR5 dedicated memory
• Coming soon: NVIDIA Quadro 5010M with 4GB GDDR5 dedicated memory

Please advise what graphics and what graphics driver you are using ?

In order to provide this thread a more detailed look at your audio hardware and software setup, with PC connected to the internet, please send the command in a terminal/konsole:


/usr/sbin/alsa-info.sh

and select the UPLOAD/SHARE option, and let the script complete. After it has completed look in the terminal and you will see the URL-address it has asked you to post/share (where your PC’s audio configuration is stored). Please post that URL on this thread to allow us to examine the configuration and help better.

Try this:

http://crunchbang.org/forums/viewtopic.php?id=2310

might be of help … I have an M6600 as well (though it’s an nVidia card, not ATI) but the thread shows people having success …

I’m using KDE. Here’s the output of alsa-info.sh http://www.alsa-project.org/db/?f=b25bfc72e615d43af7ebd1c1f3146ee847d96c25
Thanks for the tips - I appreciate having more things to try.

‘lspci’ says I have:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Blackcomb [Radeon HD 6900M series]

and ‘lsmod’ says I am using ‘radeon’.

So it seems the issue is that I need the special boot code radeon.audio=1 . I will add that and report back.

I note this:


00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04) 01:00.1 Audio device: **Advanced Micro Devices [AMD] nee ATI Barts HDMI Audio [Radeon HD 6800 Series] ** 

ie your PC’s HDMI is using AMD graphics to provide the HDMI.

Please, what graphic driver are you using?

If you are using the open source radeon graphic driver, you need to add to grub or grub2 the following boot code into the appropriate boot code line:


radeon.audio=1 

… I also note this in the dmesg:


   12.270079] ALSA hda_intel.c:2713 0000:01:00.1: Handle **VGA-switcheroo** audio client

suggesting hybrid graphics, which adds a complexity that takes me out of my area of familiarity.

Right, as you advised previously, adding radeon.audio=1 did the trick! It now works perfectly in Gnome.

Haven’t yet got it working in KDE, but that seems typical…

Thanks for the excellent and accurate assistance.

Glad to read its working in Gnome. I do not have an HDMI setup myself, but I have read for KDE it is best to install the application pulse audio volume control (pavucontrol) and then run that in KDE to select the HDMI audio device as the output device for your multimedia applications.