HDD doesn't mount automatically at boot


As said in the title , My HDD doesn’t mount automattically at boot, I have to enter my root password each time I want to access it.

Any clue to solve this problem ?

Thanks by advance for your help.


Report your file /etc/fstab , execute this command

cat /etc/fstab | grep -i sd

Also you can use the Yast’s Partitioner for mount automatically your HD, put in “auto”

The command doesn’t work, it gives nothing as result …

Execute this, copy & paste his exit

alain@alain-fury:~> cat /etc/fstab
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /                       btrfs  defaults                      0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /var                    btrfs  subvol=/@/var                 0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /root                   btrfs  subvol=/@/root                0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /home                   btrfs  subvol=/@/home                0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=58E3-4E2B                             /boot/efi               vfat   utf8                          0  2
UUID=53437f95-bd82-4d2f-9539-806acb3eeb76  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=25c18f20-f9ea-4a51-be54-88dbdc31b66d  swap                    swap   defaults                      0  0

Add your HDD partition use the Partitioner YAST. Create a new point mount in /mnt

And show at least what you mean with “My HDD”:

lsblk -f

There is no entry for any file system outside of ones needed for the system (/ and /boot/efi), thus if you mean with “My HDD” another disk then the one containing the system, there is indeed nothing that would make mounting at boot possible.

Use findmnt to show all information pertaining to the partition of the HDD:

3400G:~ # findmnt /dev/sdc2
/media/UEFI_NTFS /dev/sdc2 vfat   rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro
3400G:~ # 

Your path may be different from /dev/sdc2. You will need to adjust.

I created a mounting point in /mnt with Yast . it seems to work I did not have to put my password to mount the disk.

Thanks for your help,

Nice it works as it should (and why not?)

Remark that /mnt was only a suggestion. You can mount where you need it.

I mounted on /mnt from advice of Diablorojo but I have no idea what the "mnt " stands for.

I hva a new problem though. Since I made the modification I have access to my data partition without password which is fine but…there is a but , all my documents are in “read only” mode !

Impossible to modify them whatever I try.

Can this be related to the mounting point I setted up ?? How to fix this ?

You need to set the user flag for this partition/hdd. Check “Mountable by user” in fstab options.

Thanks for your answer.

Anyhow , I don’t know why but I don’t have this option…

Aaaah, ok, This is a MS Windows data partition with NTFS filesystem?

Yes it is

Should I modify this by some way ?

You can try to change the line with fmask/dmask to the following:


As i don’t have any MS Windows related stuff on my machines since 25 years i searched the forum for informations. Source:

I changed the line as per your recommandations but it has no effects.

All the files are still in “read-only” mode

Did you reboot after the “fstab” change?

You might still have the problem due to Windows “fast boot” option.

If that’s a possibility, try booting into Windows. And then, from windows, use SHIFT Restart to reboot your system to openSUSE. I think that does a more complete file system shutdown.

Yes I rebooted and I did well choose "reboot "option of windows and not “shut down”.

I have two other linux distributions on this computer and I’m well aware of the WIndows reboot issue with my NTFS data partition (basically if you shutdown windows then the data partition will be in read-only in LInux, if you choose the reboot option then you can write on the NTFS partition).

By the way I just checked with KDE NEon I still have full access to my data partition (read and write). So this is an opensuse only problem.

I have no windows partition for a long time maybe long years same like hui.
So there’s no way for me to test the mounting read and write.
Only thing I can tell you is to find out is, using ntfs-3g for mounting your windows partition.