HDA Intel ICH 9 (SigmaTel STAC9271D) no sound

This sound chip comes along with the Intel DP35DP motherboard, alsa recognized it, however there are some problems.

**cat /proc/asound/version **
Advanced Linux Sound Architecture Driver Version 1.0.17.
**cat /proc/asound/modules**
 0 snd_hda_intel
**cat /proc/asound/cards**
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x93220000 irq 22
**cat /etc/modprobe.d/sound**
options snd slots=snd-hda-intel
# u1Nb.PA+KAPLQWwF:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
** head -n 1 /proc/asound/card0/codec***
Codec: SigmaTel STAC9271D
**rpm -qa | grep alsa**
**rpm -qa | grep pulse**
**rpm -q libasound2**

I DO hear the voice “Front left Front right” using the test code as non-root user:

speaker-test -c2 -l5 -twav

But there’s no sound at all in any other situation including “speaker-test -Dplug:front -c2 -l5 -twav”
Everything in alsamixer has been set to max.

Can anyone help me?

Sure, … back off alsamixer volume settings to reduce distortion.

Then setup your software package manager to install software easily by adding a very specific and restricted set of repositories (where repositories are in essence file servers on the internet with openSUSE applications). This is necessary because to get sound working in your applications the way you like, you are going to need to update your multimedia applications.

Multimedia as provided by Novell/SuSE-GmbH is mostly crippled for all proprietary codecs. This is because openSUSE is openSUSE. Note the emphasis on open. Novell/SuSE-GmbH try harder than most Linux distributions, to ensure openSUSE adheres reasonably close to the open source freesoftware philsophy, which is to NOT PROVIDE software which is NOT free to give away, and not provide software which is NOT free to copy, and not provide software which is NOT free to modify, and not provide software which is NOT free to give away modified copies. This means many proprietary hardware drivers, and proprietary video/audio codecs, and many price free proprietary applications (but not opensource free) are not included with Novell/SuSE’s open source Linux “openSUSE”.

But you can EASILY get 3rd party packages to work around this. EASILY. Setup your Software Package Manger with OSS, Non-OSS, Update and Packman repositories. Just those 4. No others. None. You can add others ONLY after you learn the risks and problems that exist with the others, and ONLY after you learn how to work around the dependency and other problems that can crop up as a result of adding extra repositories (repos). There is guidance here for adding repos to openSUSE Repositories - openSUSE-Community … click on your SuSE version and follow the instructions and add ONLY OSS, Non-OSS, Update and Packman. Just those 4.

After they are added, with your PC connected to the internet, go to YaST > Software > Software Management and change the “filter” to “search” and install the packman packaged versions of smplayer, mplayerplug-in, vlc, libxine1, libffmpeg0, w32codec-all, amarok, amarok-xine. That should get your started. For openSUSE-11.0 and earlier, you will need to remove xine-lib before installing libxine1.

Once those are installed, you will to change the amarok sound engine to xine.

Good luck.

I’ll be off on vacation for the next 2.5 weeks, so any replies will be sporadic (possibly days apart).

I think it’s not about the codecs.
Even playing wav and ogg files gets no sound, and I cannot hear the system notification sound.:expressionless:

The basis of my previous post was predicated on your statement that the speaker-test worked.

Is the speaker-test still working on your PC? If you hear the test sound " speaker-test -c2 -l5 -twav " then your sound is working, and the problem is with your player or your codecs.

Note when one launches a multimedia app, often the PCM volume will drop to a low value,and one has to go in to their mixer and move up both the PCM volume (the master volume should already be up).

Typically one has to install a couple of extra apps to get ogg working. Now .wav should work out of the box, and if that test sound worked (and you stated in your first post that it did work) then it plays a .wav file and so you have already proved .wav plays.

I have to catch an airplane flight (I’m off to a 2.5 week vacation) so I do not have time to write a detailed explanation. If the speaker-test is working, please follow the advice in my previous post. If that advice does not work for you, then try following this:
Check your multimedia problem in ten steps - openSUSE Forums

If the speaker-test is not working, you could look here:
SDB:AudioTroubleshooting - openSUSE

My replies to this thread will be some what intermittent (possibly days apart) while on vacation. Hopefully someone else may chime in during the mean time.

This was the basis for my post.

This 2nd speaker-test does not work on my PC either, yet the sound on my PC works great. I’m tempted to remove this test from the troubleshooting guide that I wrote.

Reference Ogg, Ogg is an open standard for a free container format for digital multimedia, unrestricted by software patents and designed for efficient streaming and manipulation. This includes both Audio and Video. Being a Container format, Ogg can embed audio and video in various formats, and usually Ogg is used with the following:

* Vorbis (lossy)- handles general audio data at mid- to high-level variable bitrates (~16-500 kbit/s/channel)
* FLAC (lossless) - handles archival and high fidelity audio data.

* Theora - based upon On2’s VP3, it is targeted at competing with MPEG-4 video (for example, encoded with DivX or Xvid), RealVideo, or Windows Media Video.

So you need to ensure you have the appropriate theora, vorbis, and flac libraries installed. What does this give?
rpm -q libtheora0 libogg0 flac vorbisgain libvorbis vorbis-tools

who can ‘help’ me !I also have problem with this,i show my problem in this:
uname -a
Linux linux-wb0r #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386GNU/Linux

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.19-git20090321.
Compiled on Mar 20 2009 for kernel (SMP)

cat /proc/asound/modules
0 snd_hda_intel

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf4500000 irq 22

cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.JhlWIrGTU2C:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#1 <==
Codec: Nvidia ID 3

==> /proc/asound/card0/codec#2 <==
Codec: Conexant CX20561 (Hermosa)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

codec may be has problem, why is ‘nvida’

i had update alsa to the new version,when i use mplayer,there’s no sounds,but other player has sounds.
when i test sound as user ,i can hear sond ,but root there’s no.

I recommend you start a new thread.

If I understand correctly, you have sound as a regular user, but user root does not have sound ??

… anyway, I recommend you start a new thread asking for help. And please make it clear in the new thread, as to what your sound problem is.

Trying to provide help on a long thread like this, where one is forced to hunt back and forth and back and forth and back and forth to obtain the salient information, is difficult. The likelyhood is your problem is different, and hence including your aspects in this thread will just confuse anyone trying to follow the thread.