hda-intel ati hdmi /dev/dsp hogging

First off I use hda-intel onboard spdif to pass everything to my 7.1 receiver. When I reboot, or leave the computer on for a while sometimes I have to use rcalsasound restart to get my spdif working again. I think it is my ati 4850 graphics card that is hogging the /dev/dsp output. I would like to have my spdif come up every time without having to use restart. I am at a loss for what to do next as these guides don’t seem to cover my situation. I do have sound working but not on initial startup, I have removed pulseaudio, and only use alsa. I also have hda-intel as the primary according to yast and I do not have any other options to set other than to modify the /etc/modprobe.d/sound file. If aplay is correct it looks like I have the wrong default, but I am unsure as to how to change this as I don’t have a .soundrc and am unsure of the proper format for the modprobe.d/sound file.

Here is a list what aplay puts out.

default:CARD=Intel
HDA Intel, STAC92xx Analog
Default Audio Device
front:CARD=Intel,DEV=0
HDA Intel, STAC92xx Analog
Front speakers
surround40:CARD=Intel,DEV=0
HDA Intel, STAC92xx Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
HDA Intel, STAC92xx Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
HDA Intel, STAC92xx Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
HDA Intel, STAC92xx Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
HDA Intel, STAC92xx Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
HDA Intel, STAC92xx Digital
IEC958 (S/PDIF) Digital Audio Output
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=HDMI
Default Audio Device
hdmi:CARD=HDMI
HDA ATI HDMI, ATI HDMI
HDMI Audio Output

SDB:AudioTroubleshooting - openSUSE

SDB:Intel-HDA sound problems - openSUSE

This is the contents of /etc/modprobe.d/sound

options snd-hda-intel model=5stack
options snd slots=snd-hda-intel

u1Nb.PA+KAPLQWwF:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

On Tue, 30 Jun 2009 23:36:03 GMT, rthoreau
<rthoreau@no-mx.forums.opensuse.org> wrote:

>
>First off I use hda-intel onboard spdif to pass everything to my 7.1
>receiver. When I reboot, or leave the computer on for a while sometimes
>I have to use rcalsasound restart to get my spdif working again. I think
>it is my ati 4850 graphics card that is hogging the /dev/dsp output. I
>would like to have my spdif come up every time without having to use
>restart. I am at a loss for what to do next as these guides don’t seem
>to cover my situation. I do have sound working but not on initial
>startup, I have removed pulseaudio, and only use alsa. I also have
>hda-intel as the primary according to yast and I do not have any other
>options to set other than to modify the /etc/modprobe.d/sound file. If
>aplay is correct it looks like I have the wrong default, but I am unsure
>as to how to change this as I don’t have a .soundrc and am unsure of the
>proper format for the modprobe.d/sound file.
>
>Here is a list what aplay puts out.
>
>default:CARD=Intel
>HDA Intel, STAC92xx Analog
>Default Audio Device
>front:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Analog
>Front speakers
>surround40:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Analog
>4.0 Surround output to Front and Rear speakers
>surround41:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Analog
>4.1 Surround output to Front, Rear and Subwoofer speakers
>surround50:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Analog
>5.0 Surround output to Front, Center and Rear speakers
>surround51:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Analog
>5.1 Surround output to Front, Center, Rear and Subwoofer speakers
>surround71:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Analog
>7.1 Surround output to Front, Center, Side, Rear and Woofer
>speakers
>iec958:CARD=Intel,DEV=0
>HDA Intel, STAC92xx Digital
>IEC958 (S/PDIF) Digital Audio Output
>null
>Discard all samples (playback) or generate zero samples (capture)
>default:CARD=HDMI
>Default Audio Device
>hdmi:CARD=HDMI
>HDA ATI HDMI, ATI HDMI
>HDMI Audio Output
>
>‘SDB:AudioTroubleshooting - openSUSE’ (http://tinyurl.com/45yytg)
>
>‘SDB:Intel-HDA sound problems - openSUSE’
>(http://en.opensuse.org/SDB:Intel-HDA_sound_problems)
>
>This is the contents of /etc/modprobe.d/sound
>
>options snd-hda-intel model=5stack
>options snd slots=snd-hda-intel
># u1Nb.PA+KAPLQWwF:82801I (ICH9 Family) HD Audio Controller
>alias snd-card-0 snd-hda-intel

This is just a wild guess, but it is something i have started seeing
recently. Some video cards have a sound card embedded for the
transition to HDMI. See if your system has a sound device associated
with your video card. If it does, try suppressing the video attached
sound hardware.

If running “rcalsasound restart” fixes your problem, and if you wish it run automatically every time you start your PC, you could as a work around (until you sort what is happening) put that as a line in your /etc/init.d/boot.local file. ie add a line at the end of /etc/init.d/boot.local
rcalsasound restart